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What’s New in Coulomb 3.3

e New Menu Features

“.inp” (rt.lat/reverse slip) and “.inr” (rake/net slip) input file options to define source and receiver faults

Coulomb now outputs to GMT using a command window plug-in script.
You can now digitize a fault from an image and quickly bring it into Coulomb.

Fault elements are now numbered, so it is easy to find the one you want to change. The number is located at
the "start" end, so you can also more easily confirm the dip polarity is correct. These identification numbers
can be turned off in the Preferences menu.

In making A-B cross sections, A no longer needs to be to the left of B. The cross-section parameters are
saved; you can read them from the cross-section dialog box.

For “3D View” images with slip scaled by a color, you can change the color saturation on the fly.
Both horizontal and vertical GPS displacements can be plotted, with station identification numbers.
Coulomb now reads the fault element lines in the input file rather than using "#fixed," in the .inp.

Once the grid size or calculation depth is changed from Functions—=> Change parameters menu, the 2D (2-
dimensional) map image is automatically refreshed.

You can now taper or subdivide a fault on the fly by clicking on it in map view, which brings up the
"Change parameters" menu.

Coulomb now launches quickly without accessing the web database.

When calculating stress on nodal planes, you can now plot the the stress change for the plane in each pair
that is most positive or most negative, and you can save the graphic as a raster or vector image.

* New Plug-in Functions (scripts that you type into the MATLAB Command Window)

digitize_faults: This allows you to quickly but accurately digitize active faults and other elements from a
Jjpeg or .png image with a graphical user interface. The saved text file can be read from the
Overlay—> Active faults menu in Coulomb.

another_overlay: If the map is changed to "lon & lat" format, simply draw lines on the main graphic
window. This is useful to superimpose another fault database, country borders, and so on. User can set the
line color and line width by an input dialog.

more_overlay_plot: This enables you to add numerous active fault files or other overlay material that has
been saved as a text file.

coulomb2gmt_source: This code converts the source fault image (as vector data) into the GMT formatted
line data. It saves the files, "gmt fault calc depth.data", "gmt fault map proj.data”
and "gmt_fault surface.data".

coulomb2gmt_cout: This converts the calculated Coulomb matrix data into the gmt text column data (lon,
lat, Coulomb stress change), so that it can be plotted in GMT draped over a DEM as a raster image. It saves
a file named "coulomb_out.dat"

seis_rate_change: This allows you to read in a seismic catalog, choose the minimum magnitude (for
example, Mc), select a smoothing radius, identify the date and time of the event (for example, a large
earthquake), and then calculate the seismicity rate change associated with the event, with colors scaled by
log (new rate/old rate). Two maps are produced, one to show the seismicity rate where it is defined, and the
other to show the undefined areas. Earthquakes can be overlaid on the map.

Now changes to the Preferences are saved on the fly; you no longer have to quit and relaunch.
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10 another overlay (to draw lines on the main graphic window to create fault or other files) 6
11 more overlay plot (add numerous active fault files or other overlay material at once) 6
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14 seis rate change (plots log[new rate/old rate] associated with an earthquake) 32
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Introduction

1.1 Why Coulomb? The Rationale and Philosophy of This Program

Coulomb is intended both for publication-directed research and for college and graduate school classroom
instruction. We believe that one learns best when one can see the most and can explore alternatives quickly.
So the principal feature of Coulomb is ease of input, rapid interactive modification, and intuitive
visualization of the results. The program has menus and check-items, and dialogue boxes to ease operation.
The internal graphics are suitable for publication, and can be easily imported into Illustrator, GMT, Google
Earth, or Flash for further enhancements.

Coulomb is designed to let one calculate static displacements, strains, and stresses at any depth caused by
fault slip, magmatic intrusion, or dike expansion/contraction. One can calculate static displacements (on a
surface or at GPS stations), strains, and stresses caused by fault slip, magmatic intrusion, or dike expansion.
Problems, such as how an earthquake promotes or inhibits failure on nearby faults, or how fault slip or dike
expansion will compress a nearby magma chamber, are germane to Coulomb. Geologic deformation
associated with strike-slip faults, normal faults, or fault-bend folds is also a useful application. Calculations
are made in an elastic halfspace with uniform isotropic elastic properties following Okada (1992)—see list
of key papers in section 1.9.

There is substantial evidence to support the hypothesis that faults interact by the transfer of stress, both on
the time scales of earthquake sequences and aftershocks and on longer time scales associated with the
interevent time of the largest shocks that occur in a given region. There is also evidence that faults and
magmatic systems interact as well, and that static stress changes influence intrusions and eruptions.
Processes not included in Coulomb are also important, such as dynamic stresses, pore-fluid diffusion, and
viscoelastic rebound. Further, elastic stiffness differences between basins and crustal layering modify the
stresses in comparison to the elastic halfspace implemented in Coulomb. Nevertheless, we believe that a
simple tool that permits exploration of a key component of earthquake interaction has great value for
understanding and discovery.

1.2 Hardware/software requirements:
¢ Macintosh OSX, Windows PC, or UNIX computer

* MATLAB 7.4 or higher is required. There are a few MATLAB functions that work on PCs but not
Macs. MATLAB 7.5 is not advised; it is full of bugs; there are strain problems with MATLAB 7.4.

* A color monitor of at least 600 x 400 pixel resolution. A laptop screen is fine.

* A text editor to modify ascii input files, and a spreadsheet to read tab-delimited text files. Some output
files are created as .csv (Excel-friendly) files. Use a text editor that allows you to distinguish spaces
from tabs, such as BBEdit (BBEdit Lite is free from http://www.barebones.com/) or Notepad on a
Windows PC. Use a nonkerning (uniform-spacing) font, such as Monaco, so that numbers stay aligned.

1.3 Recommended extras:

* A vector illustration program, such as Adobe Illustrator, is strongly recommended.
*  Google Earth (which is free)

1.4 Users Guide Alerts

1. Important warnings in the manual are printed in red

2. The images used in the manual to show you what you will see on the screen were captured at low
resolution (72 dpi). But don’t worry: you will save full-resolution vector files.
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1.5 Help menu

This can be useful; there is a search command, but unlike this Guide, we have not kept it current.

1.6 Cover images

The full-page cover was designed by Serkan Bozkurt (now at AMEC/Geomatrix) by importing Coulomb
numerical output into ArcGIS. All of the images on the inside covers were made exclusively from Coulomb
3.3.

1.7 Acknowledgments

We thank many users for testing the functions, finding errors, and suggesting improvements. We are
particularly grateful to Chris Rollins (University of Southern California) and Gavin Hayes (U.S. Geological
Survey, National Earthquake Information Center).

1.8 Some useful papers that explain and explore the Coulomb hypothesis

(Most are downloadable from http://profile.usgs.gov/rstein)
Introduction without jargon or math:
Stein, R.S., 2003, Earthquake conversations: Scientific American, v. 288, no. 1, p, 72-79.
Key review papers:

Harris, R.A., 1998, Introduction to special section—Stress triggers, stress shadows, and
implications for seismic hazard: Journal of Geophysical Research, v. 103, p. 24,347-24,358.

Stein, R.S., 1999, The role of stress transfer in earthquake occurrence: Nature, v. 402, p. 605—609.
King, G.C.P., and Cocco, M., 2000, Fault interaction by elastic stress changes; new clues from
earthquake sequences: Advances in Geophysics, v. 44, p. 1-36.

Freed, A., 2005, Earthquake triggering by static, dynamic, and postseismic stress transfer: Annual
Revue of Earth and Planetary Sciences, v. 33, p. 335-67, doi: 10.1146/annurev.earth.33
.092203.122505

Steacy, S., Gomberg, J., and Cocco, M., 2005, Introduction to special section—Stress transfer,
earthquake triggering, and time-dependent seismic hazard: Journal of Geophysical Research, v.
110, p. B05S01, doi:10.1029/2005JB003692.

Coulomb stress change concepts (for strike-slip faults):

King, G.C.P., Stein, R.S., and Lin, J., 1994, Static stress changes and the triggering of
earthquakes: Bulletin of the Seismological Society of America, v. 84, no. 3, p. 935-953.

Coulomb stress concepts (for thrust faults and interaction between thrust and strike-slip faults):

T. Parsons, T., R.S. Stein, R. W. Simpson and P.A. Reasenberg, 1999, Stress sensitivity of fault
seismicity; a comparison between limited-offset oblique and major strike-slip faults: Journal of
Geophysical Research, v. 104, p. 20183-20202.

Lin, J., and Stein, R.S., 2004, Stress triggering in thrust and subduction earthquakes, and stress
interaction between the southern San Andreas and nearby thrust and strike-slip faults: Journal of
Geophysical Reearch, v. 109, p. B02303, doi:10.1029/2003JB002607.
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Coulomb stress calculated on earthquake nodal planes

Toda, S., J. Lin, and R.S. Stein, 2011, Using the 2011 M=9.0 Tohoku earthquake to test the
Coulomb stress triggering hypothesis and to calculate faults brought closer to failure: Earth
Planets Space, in press.

Ma, K.F., C.H. Chan and R. S. Stein, 2005, Response of seismicity to Coulomb stress triggers and
shadows of the 1999 M,, = 7.6 Chi-Chi, Taiwan, earthquake: Journal of Geophysical Research,
Vol. 110, B05S19, doi:10.1029/2004JB003389.

Dislocation solution formulae:

Okada, Y., 1992, Internal deformation due to shear and tensile faults in a half-space: Bulletin of
the Seismological Society of America, v. 82, no. 2, p. 1018-1040.

Application of Coulomb to seismic hazard:

Toda, S., Stein, R.S., Reasenberg, P.A., and Dieterich, J.H., 1998, Stress transferred by the
M,=6.5 Kobe, Japan, shock; effect on aftershocks and future earthquake probabilities: Journal
of Geophysical Research, v. 103, p. 24,543-24,565.

Toda, S., and R.S. Stein, R.S., 2002, Response of the San Andreas fault to the 1983 Coalinga-
Nunez Earthquakes; an application of interaction-based probabilities for Parkfield: Journal of
Geophysical Research, v. 107, p. 10.1029/2001JB000172.

Toda, S., Stein, R.S., Richards-Dinger, K., and Bozkurt, S., 2005, Forecasting the evolution of
seismicity in southern California—animations built on earthquake stress transfer: Journal
of Geophysical Research, v. 110, p. B05S16, doi:10.1029/2004JB003415.

Application of Coulomb to dike inflation:

Toda, S., Stein, R.S., and Sagiya, T., 2002, Evidence from the 2000 Izu Islands swarm that
seismicity is governed by stressing rate: Nature, v. 419, p. 58-61.

Application of Coulomb to earthquake-volcano interaction:

Nostro, C., Stein, R.S., Cocco, M., Belardinelli, M.E., and Marzocchi, W., 1998, Two-way
coupling between Vesuvius eruptions and southern Apennine earthquakes (Italy) by elastic stress
transfer: Journal of Geophysical Research, v. 103, p. 24,487-24,504.

Other papers cited in the User Guide:

Aki, K., and P. G. Richards, 1980, Quantitative Seismology, 932 pp., W.H. Freeman & Co., New
York.

Wells, D. L., and K. J. Coppersmith, 1994, New empirical relationships among magnitude, rupture
length, rupture width, rupture area, and surface displacement: Bulletin of the Seismological
Society of America, v. 84, p. 974-1002.
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The Keys to the City, and a Quick Tour
2.1 The most important things about Coulomb in one page!
Menu options to view an input file Example sequence to make a calculation and save the graphic output

—Ar—

Input —> Select file I:: Grid — 3D view

Stress —» Coulomb stress change —» Specified receiver faults —» Calc. &View —» File —» Saveas —» My_plot.eps

L ] L J L J
Vv \4 \

Menu options to run a calculation Stress control panel options Menu options to save a graphic

* Source vs. receiver faults (Section 3.1)
Sources have slip and impart stress; receivers do not have slip and receive stress

* Coulomb failure hypothesis, Aoy =At,+u’ Ao, (7.1)
Failure is promoted when Ao or ACFF on the receiver fault caused by slip on the source fault(s)
increases. AT, is the shear stress change (positive in the direction of receiver fault slip), AG, is
normal stress change (positive when the receiver fault is unclamped), and w’ is the effective fault
friction coefficient on the receiver fault.

* How faults are defined in the input files (4.7)
Right-hand rule for start/fin points, positive dip, rt-lat/reverse (m) or rake®/net slip(m).

* Coulomb stress on specified vs. optimally oriented planes (7.1)
Assumed slip directions vs. regional stress field; visualizing slip lines, principal axes.

* Coulomb and MATLAB Figures (5.4)
“dead” editable vector .pdf files vs. “live” MATLAB 3D .fig files that can be spun.

* “inp” vs. “mat” input files (5.2)
.inp is editable text; .mat is a binary file, but can include fault and quake overlays

* Keep an eye on the command window
For calculation progress, input/output file names, input source moment, error reports.

* Start simple, and add complexity if needed later
Start with idealized faults and develop intuition about the problem.

* For classroom instruction, use Cartesian coordinates unless you want to use overlays
It‘s quicker and easier.

* How receivers are defined (7.2)
Specified faults via Aki-Richards, subdivided receivers, CMTs, and nodal planes:

Convention for resolving stress and for focal mechanisms

Y Aki & Richards (1980) 0 < STRIKE < 360° (21)
0 < DIP < 90° (n/2)
-180° (-r) < RAKE < 180° (1)
A
STRIKE (right-hand rule) Reverse Left-lat
o o
RAKE 90 0
Right-lat.
-90°
180°

Normal
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2.2 A quick tour of Coulomb 3.3

Here we just want you to learn the procedure to display and output graphics, and to save the results. We
always recommend that you save all your current working documents frequently to prevent lost of files in
the event of program crashes.

Menus and their pull-down items turn from light white to black as they become options. Here is the
procedure to lunch Coulomb:

N MATLAR [GXeXa) MATLAB

e0e
MATLAB File Edit Debug Desktop Window Help
DS & WMEB o o |8 rf| 2| /Applications/MATLAB704 Sim|

Shortcuts [2] How to Add [Z] What's New

x 2 C Window
x 2 Worksnace m
 Curre ir <MATLAB>

Current Directory INENEPEN n Copyright 1984-2005 The MathWorks, Inc. b
D version 7.0.4.352 (R14) Service Pack 2 Iy
X 2 Command History January 29, 2005 3

[ D <

4 start

1. Launch MATLAB on your computer. In the MATLAB menu bar top line, click on the L. icon to
browse to the location of the “Coulomb 3.3 folder” in your computer. In the example shown below, the
“Coulomb 3.3 folder* has a path of “/Users/jlin/Desktop/Coulomb folder”.

806 MATLAB
| File Edit Debug Desktop Window Help
D&l % @ o o |8 = | 2| /Users/jlin/Desktop/Coulomb 3.0 folder ==

2. In the MATLAB Command Window, type “coulomb”. Coulomb will take 10 seconds or so to launch.
Check the Coulomb website to check that you have the latest version. We recommend that you always
migrate to the latest version.

>> coulomb

Welcome to Coulomb 3.2.01

Start from Input menu to read or build an input file.

3. Choose Input > Preferences. Colors, line widths, the “color map” (color gradient maps), and the
output file folder can all be changed. For input files with lat/lon information, you can also choose to
plot maps with lat/lon rather than km frame tics. For now, leave them in the default setting. Note that
“Fault” refers to the source or receiver faults. Fault ID numbers can be unchecked. For volcanoes,
“point” controls the size the triangles. Changing the Grid point size to 0 removes the grid lines for
plots with many overlays, as you see on the right below.

800 Coulomb preferences
Color (R G B) Line width/plot 38
R(0-1) ©(0-1) B(0-1) point
Fault 1.0 0.0 0.0 1.2
0.0 0.0 0.0 .0 378
Disp. vector = . - -
Grid 0.7 0.7 0.0 0.2
376 F
Carsilin 0.0 0.0 0.0 12
Active fault 0.2 0.2 0.2 1.0
Earthquake 1.0 05 0.0 3.0 3141
VielETe 0.9 0.9 0.1 1.0
. 3721
Color map Coordi
|_Anatolia 4] | Caresian %] [ Default | [ OK |
 Fault number visible 37

Output directory
f @ Default (output_files’) O Input file directory
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In the pop-up Coulomb 3.3 window, choose Input > Open existing input file. In the pop-up Open
input file window, change to sub-directory “input_files”. Choose the “Example-2(LL) lonlat.inp” from
the dialog box, then hit <rtrn>. The program will automatically plot the 2D map view of the Grid
menu in Functions.

Once you release the mouse button, the calculation is performed and the program displays the result in
the Coulomb 3.3 window. It’s a simple grid with a NE-striking fault in the middle of the grid, as shown
below. The bottom right corner also shows the version of the Coulomb program you are using, current
date/time, name of the input file you are using, type of calculation for the image, and the calculation
depth.

806 X| Coulomb 3.0 e 06 Save As

Input Functions Overlay File Edit View Inset Tools Window Help

[DzEa|haams 08|

o

Y (km)

Save As: Test_figl

@B Desktop I3

Name 4| Date Modified

|~ Coulomb 3.0 folder Tuesday, October 3, 20... m
@ |~ Coulomb3.0_Manual... Wednesday, October 4, ...

F ¥ e

0 File Format: | JPEG image (*.jpg) =
Adobe Illustrator file (*.ai)

-20 H *
New Folder EPS file (-.eps) m

JPEG image (*.jpg)
MATLAB Figure (*.fig)
Paintbrush 24-bit file (*.pcx) L
Portable Bitmap file (*.pbm)

Portable Document Format (*.pdf) . ¥
Portable Graymap file (*.pgm) v

50 -40 30 20 -10 0 20 30 40 50

0 1
X (km)
Coulorab 3.0 05-Oct-2006 16:35:00
Exaraple-2(LL), onlat. inp
Map view grid Depth:7.50 ke

Now try Functions > 3D grid, and play with the zoom ® and swivel 2 tools. If you want to save
this image, choose File > Save As. Rename the file in the dialog box, and save it as a figure of one of
the several types. Do not use “main_menu_window.fig” as the filename.

You also have the options to Zoom In, Zoom Out, Pan, and Rotate your image by clicking on the
lower line on the Coulomb 3.3 menu bar. You can also perform these operations by choosing items in
the Tools pull-down menu.

If you click Functions > Displacements, in addition to making an image on your Coulomb 3.3
window, a numerical output file called “Displacement.cou” will appear in the sub-folder you
designated in the Preferences menu. Similarly, if you click Functions > Stress, a text output file called
“dcff.cou” will be created and can be opened in Excel.

To close the Coulomb 3.3 window, click Input > Quit. Do not quit out of MATLAB if you want to
continue with Coulonb. (If you wanted to quit MATLAB program, type “exit” in the MATLAB
Command Window.)
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Concepts, Dimensions, and Sign Conventions

This chapter briefly explains the things you should understand to use the software correctly.

3.1 The crucial concept of source and receiver faults

Source faults have slip, and so they impart stress to the surrounding crust and faults.
Receiver faults (almost always) have no slip (slip=0.0 m in the input files). Source and receiver
faults otherwise look identical in the input files. The stresses imparted by source faults are
resolved on the receiver faults through the command Functions > Stress > Calc. stress on faults.
Further options for resolving the stress on the receiver fault are controlled by the Stress on faults
control panel, which automatically appears.

3.2 Calculation procedure

1. Launch MATLAB; set the MATLAB path to working directory “Coulomb 3.3 folder”.

2. Type “coulomb” in MATLAB Command Window.

3. In Coulomb 3.3 window menu bar, choose Input> Open existing input file.

4. In Coulomb 3.3 window menu bar, choose Functions > Grid, Displacements, Strain, or
Stress. Many of these selections trigger requests for additional input and let you modify the
parameters in temporary windows. When you click “Calc. & view”, calculations are
performed and a new image is displayed.

5. You can perform many operations to the image on the Coulomb 3.3 window, including
Zoom In, Zoom Out, Pan, Rotate 3D, Data Cursor, Insert Color Bar, Insert Color Legend.
You can choose these operations either by clicking the lower menu in the Coulomb 3.3
window or the Tools pull down menu bar. While the graphic plot is open, you save this plot.

6. To print a plot, save it as a pdf and then print the small vector file from Acrobat Reader or an
illustration program. The File > Print cmd in MATLAB does not work properly.

7. After you have finished all calculations, quit MATLAB.

3.3 To change parameters interactively

Most of the settings and parameters can be changed either by modifying an input file using a text
editor or by changing them interactively within Coulomb. Choose Functions > Change
parameters. Parameters changed within the software interactively are transient and will not
permanently modify the input file. Every time you select Input > Save input file, all current
selections will be saved in an input file. Change the name of the file if you do not want it
overwritten.

3.4 To save, print, or modify a plot

Choose File > Save A. We recommend you choose eps, a compact vector format; generally
quality is lower when saved as pdf. Rename the file from the default “main_menu_window.fig”
or it will overwrite an important file. You then print the pdf from Preview (Mac) or Acrobat Reader,
or from an illustration program if you would like to spruce it up.

3.5 Coordinates, units, and sign conventions

Coulomb 3.3 calculates in the (x, y, z) Cartesian coordinate system. When the lat/lon of the corner
grid points are specified in the input file, it can also plot in lat/lon. In the map view projection on
the monitor, x is positive from left to right, y is positive from bottom to top, z is positive upwards
for displacement. DEPTH is positive downwards from the Earth’s surface. We use the standard
Aki and Richards (1980, 2002) sign conventions for fault geometry and slip.
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Input parameters and their dimensions (think bars and meters)
PR1 Poisson’s ratio: dimensionless, -1 to 0.5; 0.25 is typically used. 0.5 is an incompressible
volume, and so can be used to make “balanced cross-sections” of structural geology.
El Young’s modulus: [bars]; 8x10° bars is typically used.
FRIC Friction coefficient: [dimensionless; roughly 0-1]; 0.4 is often used; 0.65 is for dry
Byerlee’s law friction, 0.0-1.0 is typically considered the limits for the crust.
Sym Obsolete legacy from Coulomb 1.0; ignore it

Directions, angle, and dip: [degrees; dip must be positive!!]
Grid and fault positions (x, y): [km]

Depth: [km] downward is positive

Displacements: [m]

Faults: Right-lateral is positive, and reverse slip is positive [m]
Dikes: Opening displacement is positive [m]

Point Source: Inflation is positive [m’]

Regional stress tensor, 51, S2, S3: positive in compression [bars]

Output parameters and their dimensions

Displacement: [m] North, East, and Up are positive

Shear Strain: [dimensionless] Right-lateral is positive

Principal Strain: [dimensionless] Extension is positive (tensor notation)
Dilatational Strain: [dimensionless] Dilatation is positive

Stress: [bars] Right-lateral and unclamping are positive

Shear modulus, G. Young’'s modulus [E] and Poisson’s Ratio [PR] are s]soeafled in the input file.
G = E/[2(1+PR)]. So the shear modulus G for PR=0.25 and E=8x10° bars, is 3.3x10° bars or
3.3x10" dyne-cm™.
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Building Input Files

All Coulomb calculations require input files; some require successive information for which you will be
prompted. If an input file is improperly formatted (for example, it has tabs, or the number of faults is
inconsistent with the “#fixed=", a warning dialog will appear, but the input file will still be correctly read.
If it is a text (.inp) file, you must modify the input using text editor. If it is a binary (.mat) file you cannot
use it. You can also create an input file interactively or modify an existing file in Coulomb. Open this input
file in a text editor:

O0=———————— mpample-A(Hlin=""——— 0| H

This is a test file for the Coulomb 2.8
This is the second comment line

#regl= @ #regZ= @ #fixed= 1 sym= 1
FR1= .258 PR2= .258 DEPTH= 18.8 :

El= 0.2300080E+00 E2= 8.200080E+85 Number of soqrqes, elastic
XSYM= .0Ee YSYM= .Ge0 parameters, friction, and
FRIC= .68 I~ stress field, some of which
S10R= 24 .6aa1 S10P= B.66881 511N= 186,688 S1G0= Bapaaa can be Changed interactjve/y
S20R= 114 .6681 S30P= @.6801 S3IN= 20,800 S360= BEEEEE
S2DR= 80,9999 S20P= -89.999 SZIN= 6,660 S2GD= .BEE6EEE

#  K-start Y-start X-fin Y-fin Kode rt.lat reverse dip angle top bot
MK OGOOOOOON SOOOOGOGGN0 SOOOOOUGGN0 JOO0OGGGGN0 XXX IOCOOGOGNN OGO JOGOGGUGGN JOGONGOGGN0 SOGGOOEG

1 -16.8 25.688 25.80 -5.680 168 @.8608 2.8008 30.08 5.8 15.608 HM-1

Grid Parameters " l

1 Start-x = -5 ,0808a Source or receiver fault parameters, none

2 Start-y = -58.00060 of which can be changed interactively

3 Finish-x = S8 . 16686

4 Finish-y = 56 . 16686

= ®—increment = 2.860680

=} y-increment = 2.800680

Size Parameters
Flot size = 2.8808680 btpina = S | b inf

2 o Shade/Color increment = 1 BPoREE Plotting parameters, all of which

3 - Exaggeration for disp.& dist. = 10688 .68 can be changed interactively
Cross section default

Start-x = -16.06088

2 Start-y = -16.08668

3 Finish-x = 18 .66088

4 Finish-y = 26 .66680

S e e e Distant-increment = 1.886088

6 Z-depth = 26 .6E68E Tl

s Z-increment = 1.866668 =
L [«[»]~

All numbers need a decimal point, except for the line starting “#regl=" and the first three characters of the
source parameters marked “#”. All format statements are shown at the end of this chapter. Right-lateral and
reverse slip are reckoned positive (negative values denote left-lateral and normal slip); dip must always be
positive. “#reg2="is an obsolete inheritance from Coulomb 1.0; ignore it.

4.1 “.inp” (rt.lat/reverse slip) and “.inr”’ (rake/net slip) input file options

There are two input formats. The first (.inp) specifies the source slip by right-lateral and reverse slip (left
lateral or normal slip are negative). The second is an alternate (.inr) input format specifies rake (°) and net
slip, which permits one to calculate the stress change on receivers (faults without slip) in their rake
directions, where, for example, a left-lat. stress increase would inhibit failure on a right-lateral fault. Try
Input > Open & edit input file > “Example-2(LL)rake.inr” to see this:

Fault Data |
Total number of faults 1

# xstart ystat xfinish yfinish Kode rake net slip dip top  bottom
1 -15.00  -17.00 1520 17.20 100 0.0 3.000 89.9 5.00 15.00
(km) — (km)  (km) (km) ©) (m) ©) (km)  (km)

[ SaveAs | [ OK |
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Explanation for grid and fault position

Output graphic (for Data>Old>Example_3.inp)

Map view ( Functions > Grid )

] " axdfinish) y-finish| |
faultjtrace at| />?
RSLffach / ramne of the fayit i
0 the syrfade

N

et depth
1 -km) 104

x-5tart, y-start 1 '<

: Stirfﬂ:ce ion

—

y-increment

start-x, start-y

-
x-increment
(in this case, 5 km)

Note that the fault element ID, “1” appears at the ‘start” corner of each fault.

4.2 Structure and format for input files

finish-x, finish-y

(in this case, 5 km)

COULOMB 3.3
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An input file is composed of parameters for the halfspace, an optional regional stress field used only in one
kind of Coulomb stress calculation, source fault positions and slip, receiver fault positions, grid
information, graphical representation, and optional cross section and lat/lon information. See the figure,
‘structure and formats of Input file”, which annotates the entries. When making or modifying input files,
use a non-kerning (uniform-spacing) font, such as Monaco, so that all numbers align under the xxxxxxxx

headers.
Positioning a fault in the Input file

Fault trace at surface

(X-fin,Y-fin) km

Mapview
Intersection of
V'd
Yor target depth
lat. (X-start, with fault plane
Y-start)
%o Slip
L] shear (right-lateral positive, m)
m\\"’ reverse (thrust positive, m)
\}
Right-hand rule
® » X or longitude
Z
Cross-section
Fault trace Leading edge of fault plane projected vertically to surface
projected P .
up-dip (X-start,Y-start) z
(X-fin,Y-fin)
T Surface
(top, km) dip (0-90°)
Target depth in
(bot kh input file

Depth (km)
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4.3 Working in lat/lon coordinates
Coulomb can read and display lat/lon’s if you include the lat/lon of the grid borders and the (0, 0 km) point

COULOMB 3.3
User guide

in the input file, as seen here from “Example-SFBayArea.inp”

If you have lat/lon information for a source, you can convert it to Coulomb (X, y) input format by selecting

Cross section default

S AW -

A BN -

Distant-increment

Map infomation

Start-x = -36.60000
Start-y = 36 .00008
Finish-x = 38 .00008
Finish-y = -36.60000
= 1.606008

Z-depth = 30 .00008
Z-increment = 1.060000
min. lon = -123.0000
max. lon = -121.06608
zero lon = -122.0000
min. lat = 36 .0000
max. lat = 38.0000
zero lat = 37 .0000

Functions > Tools > Convert lat/lon to Cartesian, which brings up a calculator window.

4.4 To open, display and modify existing input file interactively

1.

2.

Input > Open existing input file > Example-2(LL)-lonlat.inp in the “input files” sub-folder within
the “Coulomb 3.3” folder.
The graphic on the left below appears in the Coulomb 3.3 window. You can see the undistorted grid

(yellow) and the surface projection of the source fault (green).

To show the same plot with lat/lon tic marks, put the cursor on the frame numbers and make a right
mouse-click (above right). Choose “change coordinates” and make a left mouse-click. Alternatively,
from the menu, Input > Preferences and change Coordinates from “Cartesian to Lon. & Lat.”, click

50

40

-10

Coulomb 3.0.1 13-Mar-2007 12:16:33 Example-2(LL)onlat.inp
Map view grid Depth: 7.50 km

0 10 20
X (k)

| | | | | I I Y Y A
B WIETTY: change study area
Longitude (de@a E s R aels]ds [ ELGH

T T T T T T T T
0 change study area
X (km)  change coordinates

Coulormb 3.0.01 21-£0g-2007 17:18:56 Exampl
hBp view gric

OK, and then choose Input > Open most recent input file.

To modify, subdivide, or tile a source or receiver fault, click on the fault with the right mouse-click,
and it will open the “change fault params” window (below left). You can do the same thing to the blue
study area border to change the study area boundaries. If you have multiple faults or a variable slip

model, you can see the total seismic moment of all patches in the Command window.
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Amount of net slip on each fault (m)

4.5 To display the undistorted grid in 3D view

1. Choose Functions > Grid > 3D view. The graphic above right appears in the Coulomb 3.3 window.
You can see the undistorted grid in 3D view (yellow) and the fault patches colored by their input slip.
You can color the slip by its components, change the color saturation in the Slip menu, and change the

viewing angle by clicking on the swivel tool.

4.6 Editing existing input files within Coulomb

Choose Input > Open & Edit Input File. The “All input parameters” window will appear as shown
below. You can modify all values without any formatting worries. If the “Total number of faults” is greater
than 1, enter the order number of a specific fault patch that you wish to modify below “#”. Then click
“OK”, properties of that particular source will appear.

| input parameters

8060 Al

This is a test file for the Coulomb 3.0
is file is prepared to check mainly thrust faulting calculation

1 1500 | 1700 | 1520 | 20 | 100 | 00 | 0000 | 9 || 500 | 1500

4.7 Modifying an existing file in a text editor

1. Click one of the example files we prepared for tutorials.

2. To duplicate it, type “d” holding command key (command + D), or drag the icon holding option key,
and rename it.
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W

Launch an editor and open the file using File > Open (command + O).

4. Use a non-kerning font, such as Monaco or Courier. Change the numbers you want, checking the units
and format. To add source or receiver faults, add a new row. Use your editor’s “show invisibles”
option to make sure that there are no tabs. Save the file.

4.8 Building an input file from a simple X,Y map

To build an input file from map, you can select from menu Input > Build Input File from x & y Map;
you can add as many faults as you like. You can add lon/lat information of your study area by clicking the
“Add lon.lat. info” button in the “Grid input setting” window. Don’t worry about the regional stresses for

now.
10
0 A//////’////B

¥ (km)

Position a fault. Move your mouse to L

the starting point on the map and 8 60 Element input panel

press the left button. And then move the Fault Data

mouse aga.in to the end point and press Total number of faults 1 Edit amounts of slip, dip, and fault depth

the right button. #  xsat  ysat  xfinish yfinish  latslp dipslp  dip top  botiom
1 2323 | 839 7.09 903 | 0000 | 0000 900 = 000 . 10.00 |

m lwhr;‘:m gri‘?sshbpo”::tr'lrgo?:‘ Type fault number in # to edit the fault element (do not put number over the total)

the startina point.

Note that you must close the above cursor message at left before specifying a fault on the following map.
Click “OK” and the fault color will turn to green.

4.9 Tapering a source fault and subdividing the slip on a source or receiver

Tapered Slip. To remove unrealistic stress concentrations at the edges of a fault, you can taper the slip in
Coulomb. Choose Input > Open an existing file and choose “Example-2(TH).inp”. Then right-click on the
fault frame and hit the “Taper/Subdivide” button (or choose Functions > Tools > Taper or subdivide
fault slip). When the “Element input panel” appears, choose “Linear tapering”. The tapered slip is built by
nested rectangles. Choose 10 km along strike, 5 km downdip, and 5 nested patches, and hit OK. Save the
tapered input file by Input > Save input file as ascii with a new name. In an editor you’ll see the 5 nested
coplanar sources, as shown below. The tapered fault has the same moment as its uniform-slip version.

# X-start Y-start X-fin Y-fin Kode rt.lat reverse dip angle top bot

MK HAHHHHHHH HHOHOHHN HHHOHHNHR HOOOOHKHNH KKK MO HHOOOHERN IO HHHHHHHH HHHHHHHHKH
1 -8.6771 22.7819 22.5266 -4.0441 108 8.0008 8.8664 45 .0080 8.8839 14.1161
1 -7.3542 20.4639 20.8533 -3.8882 100 8.0008 8.8664 45 .0080 1.7678 13.2322
1 -6.8312 18.1858 17.5799 -2.1323 108 8.6008 8.8664 45 .0080 2.6517 12.3483
1 -4.7083 15.8677 15.1865 -1.1765 168 8.6008 8.8664 45 .0000 3.5355 11.4645
1 -3.3854 13.5096 12.6332 -0.2266 100 8.6008 8.8664 45 .0000 4.4194 18.5806

Notice that the patches get successively smaller on down the list, and that each patch has the same slip. The
larger the number of patches, the smoother the stress. The patches with their ID numbers are shown below.

Subdivided slip (for sources and

Tapered slip (for sources only)

receivers)
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Splitting or subdividing a source or receiver. As you did before, choose Input > Open an existing
file and choose “Example-2(TH).inp”. Then right-click on the fault frame and hit the “Taper/Subdivide”
button as you did before. This time, when the “Element input panel” appears, click on “’splitting.” Now
choose a 7 x 3 patch subdivision, and hit OK, and you will see the right picture on the previous page. Save
the tiled input file by Input > Save input file as ascii with a new name, and open it in an editor to see the
21 adjacent coplanar sources (above right), all with the same slip as the initial input file. You can now
change the slip on each patch by hand. The input folder contains several examples of these (such as the
1992 M=7.3 Landers, California, and 1995 M=6.9 Kobe, Japan, shocks).

#  X-start Y-start X=fin Y-fin Kode rt.lat reverse dip angle top bot
XXX XXX

1 -10.0000 25.0000 -5.0000 20.7143 100 8.0000 2.0000 45.0000 8.0000 5.0000
1 -13.2540 21.2837 -8.2540 16.9180 100 8.0000 2.0000 45.0000 5.0000 10.0000
1 -16.5879 17.46874 -11.5879 13.1217 100 8.0000 2.0000 45.0000 10.0000 15.0000
1 -5.0800 20.7143 8.0800 16.4286 108 9.8000 2.8000 45.0000 8.6008 5.6008
1 -8.2540 16.9188 -3.2549 12.6323 100 8.0000 2.0000 45.0000 5.0000 16.0000
1 -11.5879 13.1217 -6.5879 8.8360 100 8.0000 2.0000 45.0000 10.0000 15.0000
1 8.0000 16.4286 5.0000 12.1429 100 8.0000 2.0000 45.0000 8.0000 5.0000
1 -3.2540 12.6323 1.7460 8.3466 108 @.0000 2.0000 45.0000 5.0000 10,0600
1 -6.5679 8.8360 -1.5879 4.5503 100 8.0000 2.0000 45.0000 16.0000 15.0008
1 5.0000 12.1429 10.0000 7.8571 100 8.0000 2.0000 45.0000 8.0000 5.0000
1 1.7468 8.3466 6.7460 4.0609 100 8.0000 2.0000 45.0000 5.0000 10.0000
1 -1.5879 4.5583 3.4921 @.2646 108 @.0000 2.0000 45.0000 16,0000 15.0000
1 16.6660 7.8571 15.6000 3.5714 100 8.0000 2.0000 45.0000 8.0000 5.0000
1 6.7468 4.0689 11.74608 -08.2249 100 8.0000 2.0000 45.0000 5.0000 16.0000
1 3.4921 8.2646 8.4921 -4.0211 108 8.0000 2.0000 45.0000 10.0000 15.0000
1 15.0000 3.5714 20.0000 -8.7143 100 @8.0000 2.0000 45.0000 8.0000 5.0000
1 11.74668 -8.2249 16.74660 -4.5186 100 8.0000 2.0000 45.0000 5.0000 16.6660
1 8.4921 -4.08211 13.4921 -8.3069 100 9.0000 2.0000 45.0000 10.0000 15.0000
1 20.0000 -8.7143 25.0000 -5.0000 100 8.0000 2.0000 45.0000 0.0000 5.0000
1 16.7468 -4.5186 21.7460 -8.7963 100 @.0000 2.0000 45.0000 5.0000 10.0000
1 13.4921 -8.3869 18.4921 -12.5926 108 9.8060 2.8000 45.0080 10,8000 15.8000

If you are tapering or subdividing a vertical fault, you can still see the nested or tiled patches by choosing
Functions > Grid > 3D view. Then you can use the swivel tool to view it on its side. 3D view is also
valuable because the patches are colored by their slip, rather than being translucent. Notice the rake vectors
with tiny arrowheads; the vectors are rooted to the center of each patch.

4.10 The seismic moment is calculated every time an input file is loaded

Every time you launch an input file, Coulomb calculates the total seismic moment of the sources in the
input file, using the fault area, slip, Young’s modulus, E, and Poisson’s ratio, PR, from the input file. The
seismic moment (in dyne-cm) and the equivalent M,, appears in the MATLAB window:

User selected/Users/Toda/AFRC project IV/coulomb30/input files/Example-l.inp
No lat. & lon. information is included in the input file.
Total seismic moment = 7.60e+26 dyne cm (Mw = 7.19)
--=> To calculate deformation, select one of the submenus from 'Functions'.
For the seismic moment of individual sources, click on the source with the right mouse-click. You can also
type “seis_moment” into the Command Window at any time to see the total moment of all input sources.

4.11 Using variable slip source models from the NEIC or university websites
Many large sources have “variable slip” (also called “finite fault”’) models with numerous small patches of
slip. You might also want to subdivide a receiver fault so that you can assess the variations in stress
imparted by a nearby earthquake.

The NEIC now routinely publishes variable slip models of large global earthquakes in Coulomb .inp
format. Go to the USGS NEIC Earthquake Event page, <http://earthquake.usgs.gov/earthquakes>, click
‘scientific & Technical,” then “Finite Fault Model”:

Scientific & Technical Information

OUSGS Centroid Moment Tensor Solution

USGS Body-Wave Moment Tensor Solution

Slip Distribution

USGS WPhase Moment Tensor Solution

Magnitude 7.0 - SOUTH ISLAND 0
Historic Moment Tensor Solutions + SUBFAULT FORMAT
2010 September 03 16:35:46 UTC W ¢ CMTSOLUTION FORMAT
ase Data

Theoretical P-Wave Travel Times * COULOMB INPUT FORMAT
Details | Summary | Maps || Scientific & Technical Energy and Broadband Solution + GOOGLE KML FORMAT
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Prof. Chen Ji (U.C. Santa Barbara) also publishes variable slip models in Coulomb .inp format. Go to

http://www.geol.ucsb.edu/faculty/ji/big_earthquakes/home.html

Choose an earthquake and scroll down to the bottom of the explanatory page and you will see:
Slip Distribution
SUBFAULT FORMAT COULOMB FORMAT CMTSOLUTION FORMAT

Prof. Martin Mai (King Abdullah Univ. of Science and Technology) has built the SRCMOD (source
model) database of over 150 variable-slip input files from the literature, which can be read in as Coulomb
input files. Some of these files can have hundreds to thousands of slip patches, and so calculations,
particularly “3D view” and “calc. stress on faults”, can be very slow. Also, SRCMOD has not been updated
since 2007, and the most recent earthquake was in 2005.

Go to http://www.seismo.ethz.ch/static/srcmod/Homepage.html and click on “Downloads”. Then
download the most recent .mat file for MATLAB 7 (the top file below left) to the Coulomb33 folder. Make
sure you “Save as” a binary “.mat” file, not a “.txt” file.

e 60

SRCMOD_JUL07_v7.mat (binary for MATLAB 7, with all source models, 2.9 MB) Select a tile:
SRCMOD_JULO07_v6.mat (binary for MATLAB 6, with all source models, 6.2 MB)

s1 that
References (pdf-file with references to published source models) g] "33%55@3‘%@’3

. - " . . . s1923KANTOJwalkd

Zip-file containing all *SLP ascii-files with simple slip-model representation (300 KB) $1944TONANKichi

51944 TONANKKato
Zip-file containing all *FSP ascii-files with complete rupture-model description (1.3 MB) :1 SZ}SNNKER

51944 TONANKtani
Zip-file containing all *PNG figures (6.4 MB) k.

948NANKAlkato

Zip-file containing all *FIG files, usable for viewing and modification in MATLAB (4.6 MB) :1;: A ::ﬁfﬁ?

In the MATLAB command window, type the plugin ‘srcmod2coulomb”. You will then see the file
selection window (above right). The selected file will automatically be saved into the input file folder as an
.mat input file. The file name will also indicate the number of sources (“100f ” means 100 slip patches).
Then, Input > Open existing input file > Grid >3D view. The example below left is
“1987WHITTIhart 100f coulomb.mat”, the 1987 M, =6 Whittier Narrows shock:

Amount of net slip an each fault (m)

sl Three varigble-slip sources merged into one input file
374

373

w
~
[

Latitude (degree)

Coyola Lake

w
4

36.9

i ] ;
3 4 2 0 2 n s Y222 221 22 1218 1218 1217 -1218 1215 -1214 1213
—— Longtuae (deqree

Coulormb 3.0.01 02-Now-2007 15:27:56 51939 LOMAP Rwald_96f_coulomb.mat
Mep view grid Depth: 7.50 km
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4.12 Merging several variable-slip models to one input file
(“merge_input_files” plugin)

Here’s how to take many variable-slip input files and merge them into one .mat input file:

1. Open an existing input file. Type “merge_input_files” into the MATLAB command window.
You are then requested to choose the second input file. This process is repeated until you have
included all files that you want.

2. Save the combined file with any name you would like.

4.13 Making realistically scaled source faults from Global CMT or focal
mechanism data

1. Choose Input > Build input file from lon. & lat. map. The “Build input from CMT or focal mech.
data” calculator will appear. Button sequence: 1) - 2) - 3) - 4)

a0 | s08m
53000 34500 o050 |

oare | | e | e aw | s

~‘Start-point per
Aki-Richards’
reference point
L1
‘Fault center’
Ry
o8t | 007 |70 | zasr | [nsesme) || reference point

[ couatmuparnes | [ Canoo | [ OK

2. Press “1) Cale.” in the ”’study area” box (above left) to calculate boundaries and grid increments of the
study area (the yellow fields). Then hit “2) Add to map” to apply changes to Coulomb window, which
will create the grid. If you do not have the MATLAB Mapping Toolbox, and your grid spans more
than one UTM zone, Coulomb will warn you that it is making simplified distance calculations.

3. To create the source fault from the CMT information, drop down to the “Fault element” box (above
left). You can choose the “Fault center” (this is the geometrical center of the rectangle, so make sure
the top of the fault is at or below the ground surface), or the ‘start-point per Aki-Richards” (this is the
Coulomb start-x, start-y position), and then input the M, strike, dip, and rake from a CMT file. In this
example, just change My, to 6.8 and change the dip to 20°.
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If you would like to use the Wells and Coppersmith (BSSA, 1994) empirical magnitude-area relations
to estimate appropriate fault lengths and widths, press the “From empirical relations” button, and the
“empirical relations...” box will appear (above right). Choose the type of fault (here, reverse) and hit
“Calc.” To accept the length and width values, hit the “Apply” button, and then close the “empirical
relations” window. You will now see the “length” and “width” information changed in the “Fault
elements” box. Notice, however, that these relations permit the fault width in great strike-slip events to
get too deep.

Now press “3) Calc.” in the “Fault element” window to calculate fault position, and press “4) Add to
map” to apply the fault to the Coulomb window. A portion of the resulting map is shown above at
right. Notice that the blue dot is the fault reference point you selected. To save the input file you just
created, choose ’save input file as ascii” in the Input menu, and name it, replacing the comment lines.

If you would like to add more sources, after you have hit “4) Add to Map”, just increment the “ID
number” to 2 and put in the new values into the “Fault elements” window, and so forth.
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Earthquake, Fault, Coastline Overlays, and Seismicity Rate
Changes

5.1 Overlays (coastlines, active fault traces, seismicity)

1.

It is enormously valuable to plot your map with lat/lon tic marks and to overlay geographic or seismic
catalog information. This is easy to do as long as the input file (.inp, .inr, or .mat) has lat/lon
information, which is the last item in the input file, such as

Map infomation

1 min. lon = -123.06066
2 max. lon = -121 .6666
3 zero lon = -122.8660
4 min. lat = 36.6008
S max. lat = 38.00008
6 zero lat = 37 .0068

To plot with lat/lon tic marks, Input > Preferences > Coordinates > lon. & lat. and then launch the
input file. (If you do not have this information, you can calculate it using the Coulomb tools:
Functions > Tools > Convert lat/lon to Cartesian, which opens a calculator window that will create
your input file for you.)

Use of the National Geophysical Data Center Coastline Extractor. Go to
http://www.ngdc.noaa.gov/mgg_coastline/ and input the boundary coordinates, or use “Java Map for
lat/lon”, zooming in as needed. We recommend the Medium Resolution (1:70,000) Coastline database.
Select the MATLAB Format, choose no compression, and preview it with a GMT plot. Hit the
”SUBMIT” button. Save the resulting “.dat” file in the Coulomb “coastline data” folder, and rename it
if you like. Open the file in your editor; if there are “nan” lines in the file, use a “replace” command in
your editor to change to “>“ symbols.

~ Coastline database: | NOAA/NOS Medium Resolution Coastline (designed for 1:70,000) _3]
Coastline Extractor

Use Java Map for laton Compression method for extracted ASCII data:
® None () GNU GZIP () UNIX Compressed () ZIP

Geographic Range of Coastline to Extract
(decimal degrees, west and south are negative) Coast Format options:

0 0 = 0
upper latitude O) Mapgen () Arc/Info Ungenerate ® Matlab () Splus

o Coast Preview options:
westernmost longitude easternmost longitude () No preview ® GMT Plot
-122.75 -122.0
lower latitude
375 Extract the Coast: SUBMIT - Extract the Coastline File

5.2 How to use overlays in 2D and 3D plots

1.

Launch “Example-SFBayArea.inp”. Now, Overlay > Coastlines. Open the “coastline data” folder in
the Coulomb33 folder, and select “california_coastline di_pos.dat”. The “di” refers to intermediate
resolution; there is also a high resolution “dh” file in the folder. Answer the pop-up question, “no”.
Some datasets treat western longitudes as negative; others do not. The coastline will appear on your
plot. Now try Overlay > Active faults. (You could load folds or roads or anything you like; the
formats are explained in a pop-up window.) Choose “California faults lonlat dat”. It‘s a large file but
will plot on your map. The “Coastline data format” and “active fault format” windows are shown
below:
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0 00 Coastline data format © OO0  afault_format_window

2. Now choose Overlay > Earthquakes, and choose the “(NCSN) readable” format in the “Earthquake
catalog formats” menu below left. Then select the “readable” format of the actual data file in the data
folder. It is only important that the format chosen matches the format of the dataset you are opening.
Fifteen catalog formats are supported by Coulomb from global data, the United States, Japan, and
Turkey.

earthquake_screening

ﬁ

No e b
oﬂhem Ca.llbmla EQ Data Cenbr NCSN) Fpfit (bcal mech)

USGS NEIC scr

ZMAP brmathd mhldgg

NIED F-net catalog (JAPAN, focal mech)
NIED Hi-net auto catalog (JAPAN)
Kandgll Tu catal

DAomoDD
orthern California DD
SOsus

i

8

»
~

20
oot

An “earthquake screening” window (shown above right) will appear that lets you filter the time, location,
depth, and magnitude of earthquakes you would like to plot. It if is a large catalog, this can take time. For
the CMT “ndk” format, go to http://www.globalemt.org/cmtfiles.html.

3. For this exercise, just click “OK” to plot all 324 earthquakes that occurred in the grid and are defined
in the input file, and you should see the image below. The default colors appear below, but the colors
of all overlays can be changed in the Preferences panel.

m File Edit View Insert Tools Desktop Window
Ev Coast lines
v Active faults
v Earthquakes
v Annotations
Clear overlay data from memory » =
Trace and put faults into input

T T

iy =

F

S

! T B

You can remove any overlay by Overlay > Clear overlay from memory, if you want to use a different
dataset instead, or you can toggle on/off any overlay by unchecking it. Note that coastlines are continuous
lines; by editing them in Adobe Illustrator, you can fill the land or sea area. Faults are line segments.
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4. Save an input file with all of the overlays by Input > Save Input + Overlays as .mat. Name it
uniquely. This will create a compact binary file that you can use in the future—a great time savings—
although it cannot be opened in an editor.

5.3 Adding source or receiver faults by tracing active faults (or folds)

It is fast and easy to build source or receiver faults by tracing the active faults on the map. Starting from
where you left off in the previous exercise, Overlay > Trace and put faults into input. Instructions pop
up to remind you that you use your left mouse button for the Start end of the fault and your right mouse
button for the Finish end. Remember that the right-hand rule means that for non-vertical sources, the Start-
Finish order determines which direction the fault dips: the fault dips to the right when you are looking
toward the Finish from the Start (see the Aki-Richards (1980) diagram in the “Keys to the City”).

The “Element input panel” appears (below) with the Start-Finish coordinates you moused on the map.
Now, add the slip and top/bottom depth and hit “OK”. Remember that if the fault is blind, it will be offset
from the trace as a function of its dip and upper depth (refer to the “Map Positioning” figure in Chapter 4 to
see this). The new fault appears in red (below left); when you hit OK, it turns green to indicate it is now the
trace of a source or receiver. If you save the input file, the new source or receivers will be included. When
saved, each source will get assigned its element number, which will be seen at the Start end (below right).

860 Element input panel =
2 i
2 3401 -4381 5212 -64.74 0.000 | 0.000 90.0 0.00 10.00 3 ’\
R
AQ o
L ol
ok i
2N e b
Add fault b o |7 C
Hel|
=] \[® 3
M 2 4
g 0 N B N --._,;--..4'\\ Y = \g
= AN N A
N 3
20 LY \ b Q
{ T i
Ay - { f
“ start — N ‘ e‘!k\\ g
R kY ™~ N
-60 T Y
finish
N,
50 N
. ! %,
A AN
-100 - \. b

0 0 40 -20 0 0 0 0

5.4 3D source and seismicity (.fig) figures that you can spin and roll
MATLAB lets you create very compact “.fig” files that can be manipulated in 3D to see, for example, if
your coseismic source fault is properly located with respect to its aftershocks.

1. Input > Preferences > Cartesian. Open an input file, add the coastline and earthquake catalog
overlays. Now, Functions > Grid > 3D view (see below left).

2. Switch to the MATLAB command window, and type the plug-in, “earthquake_plot3”. You will
be asked on screen if you would like the earthquake magnitude scaled by circle size and depth
scaled by color (choose Y) or by circles or filled disks (choose N).

3. You can use the tool to blow up the area of interest, but the file will still contain the full data.

Now use the © to spin and roll the view. A portion is shown below, at right. With this tool
selected, a right mouse-click lets you to reset to a regular map, side, or depth view. The source slip
is scaled by its color.

4. You can save this file and re-open it later. File > Save as > “yourname.fig.” It‘s an amazingly
small file.

5. If you simply double-click on this figure, it opens in MATLAB (not Coulomb) and can again be
manipulated.
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3D view in Grid
(using swivel tool)

3D view using “earthquake_plot3” plugin
(different view, quakes scaled by size and depth)

5.5 Volcano overlays &

Active volcanoes appear as triangles if you choose Overlay > volcanoes. Their size and color are
controlled in the Preferences menu. An example from Japan is shown in Chapter 2.2. Global volcanoes are
stored in “volcanoes NGDC NOAA.mat” in the plug_ins folder; you do not need to load them in. If, when
you select volcanoes, none appear, then there are not any in your grid area.

5.6 Digitizing faults from maps and images

Save the fault map you would like to digitize as a .jpg or .png (raster) file, cropping it so the boundaries of
the image lie at identified lat/lon coordinates. Type “digitize_faults” in the MATLAB Command Window,
and browse to your image, enter its upper left and lower right coordinates in the pop-up panel (below left).
Then, click on the push-pin icon and use the left mouse button to digitize a fault, ending with the right
mouse button. Each time you click the right mouse button you will be asked to name the fault or fault
section. Then choose “Export XY” and save it as a .dat file into the active fault data folder in the
Coulomb33 folder.

Digitiz
Load ExportXY Marker Style
SRR = CRC)
a ThE, T T A
™ O 7 Input the position 2 78 S —— Tl 70° .
R B . ' ® O 7 Input segme... b'”"%,. The vertical 50-250 scale
longitude(deg) at upper-left corner? | LU e 3 "m and horizontal 0-300 scale
) nter segment name ; -

79 i EnnigUilo, ; numbers seen at left are

latitude{deq) at upper-left corner? | iy

22

longitude(deq) at lower-right corner? BNt
30
; N 200
latitude{deq) at lower-right corner?
161
| B

Trough . - €\ h
== AlrEN "'- Tt PSS
130 /amAN) o ey s '

.
.

e
[ 19.5 mm/yr}/w&' .

| Caribbean Plate

100 200 300

simply the raster image
pixel numbers; they are not
kilometers. You can use the
zoom tool while digitizing.
Here we chose large
magenta circles as the
digitizing bread crumbs;
they can be changed in the
Marker Style menu.
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5.7 Making smoothed seismicity density plots

Rather than showing earthquakes, you might want to plot seismicity density smoothed over some radius.
This can be accomplished by plotting an earthquake catalog in a 2D Grid view, and then typing in the
plugin, “smoothed_background”. You choose a smoothing radius, and it will plot the seismicity density
over a box reduced in size to the original so that the smoothing kernal can use all cells, as shown below.

Seismicity rate

Insert Tools Desktop Window Help

SICSESVECIES]| W (=[] =)

Background seismicity rate

Use of the plugin,
‘smoothed_background’

Earthquake plot

Annual seismicity rate

A
n

50 0 50

5.8 Making smoothed seismicity rate change plots

This plug-in allows you to plot the seismicity rate change associated with an earthquake or volcanic event.
Just type “’seis_rate_change” into the Command Window. This allows you to read in a seismic catalog,
choose the minimum magnitude (for example, Mc), select a smoothing radius, identify the date and time of
the event (for example, a large earthquake in the catalog), choose a color saturation value, and then
calculate the rate change, which is scaled by log[new rate/old rate]. Two maps are produced, one to show
the seismicity rate where it is defined (above right; the dark blue areas are undefined because there are not a
sufficient number of earthquakes), and the other to show the undefined areas. Earthquakes can be overlaid
on the log seismicity rate change map.

5.9 Transferring Coulomb files to the GMT mapping software

There are two plug-ins used to convert the vector-based source and receiver fault information, and the
raster-based Coulomb stress gradient map, into GMT. After you have created the map view figure in
Coulomb, type this into the Command Window: coulomb2gmt source. It saves the files,
"gmt fault calc depth.data", "gmt fault map proj.data" and "gmt fault surface.data" Then type this into
the Command Window: coulomb2gmt_cout. This converts the calculated Coulomb matrix data into the
GMT text column data (lon, lat, Coulomb stress change), so that it can be plotted in GMT and draped over
a DEM as a raster image. It saves a file named "coulomb_out.dat"
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Deformation, GPS Displacement and Strain

Here we guide you in calculating deformation caused by an earthquake and display the results graphically.

6.1 To display horizontal displacement vectors

1.

Input > Preferences and change Coordinates from Cartesian to Lon. & Lat. Input > Open existing
input file > “Example-2(LL).inp”. Then, Functions > Displacements > Horizontal displ. (vectors).
You will see a dense vector image in the Coulomb 3.3 window. To plot fewer vectors, Functions >
Change parameters > Grid size, change it from 2 x 2 km to 4 x 4 km, and hit OK (like the plot below
left). Now repeat Functions > Displacements > Horizontal displ. (vectors). To change vector scale
and reference frame, in the “Displacement” control panel, either move the slider (which rescales the
vectors on the fly) or type in a number (try 10,000) in the text field (these means the vector scale is
10,000 x the distance scale).

No reference point Reference point by
mouse click
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Coulomb 3.0.1 13-Mar-2007 12:35:58 Example-2(LL)enlatinp Coulomb 3.0.1 13-Mar-2007 12:38:38 Example-2(LL)onlat.inp

Then click on “Fixed point (Cartesian)”, hit the “Mouse click” button and click on a point to the SE of
the fault. The new reference point indicated by a red circle (above right).

Numerical output files are created every time you make a run. When you click “Cal. & View” in the
“Displacement control panel ”, a text output file called “Displacement.cou” will be created or updated
and saved in a sub-folder called “Output files” within the “Coulomb 3.3 folder”. When you want to
save your latest run, remember to rename the “Displacement.cou” file; otherwise it will be overwritten
by your next displacement calculations. Below left is an excerpt of a “Displacement.cou” text output
file.

Coordinates Displacements

06 __ Displacement.cou Cross section default

Input file selected: Example-2(LL)_lonlat.inp 1 Start-x = —-36.00000
X y z ux uy uz 2 Start-y = 36.00008
(km) (km) (km) (m) (m) (m) 3 Finish-x = 38.00000
-50.00000000 -50.00000000 -7.50000000 -0.01714258 0.00551020 -0.00152591 4 Finish-y = -36.60000
-50.00000000 -48.00000000 -7.50000000 -0.01969615 0.00407689 -0.00206484 S —mmmmmmmmmmmmeeee Distant-increment = 1.660000
-50.00000000 -46.00000000 -7.50000000 -0.02256910 0.00253268 -0.00263662 6 Z-depth = 30.00008
-50.00000000 -44.00000000 -7.50000000 -0.02578451 0.00089117 -0.00323851 ? Z-increment = 1.066008

To change the sampling depth of calculation, in the “Displacement” control panel, type your desired
value after “Depth” and hit “Calc. & view”. To compare the results to geodetic data, set Depth=0.0.
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To make a displacement cross-section, choose Input > Open existing input file > “Example-
2(TH).inp.” Next, Functions > Displacements > Horizontal displ (vectors). In the “Displacement”
control panel, choose “Cross section”. This is a reverse fault; the dashed blue line in the plot below is
the depth of the horizontal vectors in the map view plot. The cross-section line was included in the
input file (this optional information is shown above right). You can change the cross-section line
interactively in the Cross section control panel. Change the increments to 2 km by 2 km (below left).
Use the left mouse button to click the start (A) point, and the right mouse button to click the end (B)
point. If you do not have a two-button mouse, use ctrl+click for the right button. To save the changes,
choose Input > Save input file as ascii with a new file name.

Displacement projected onto cross section

Depth(km)

””””” enn Cross section control panel
X Yy
Start (A) -16.00 -16.00 km
Horizontal increment
X y
Finish (B) 18.00 26,00 km 2.00 km
1 S K )y A A
8 1A A S A
T T T T T Mouse clicks
1 A S A B
S ) ) I
Pt rr et Depth 3000  km
S ) I
S ) ) Depthiin. 2.00 -
25 30 35 40 45 50
. Calc. & view
Distance(km)

For displacement plots, the dip of the cross section is always vertical. Within the “Cross

section control panel”, you can chose items on the menu bars to Zoom In, Zoom Out, Pan,
and 3D Rotate.

6.2 To display observed and modelled GPS vectors

1. You can create a GPS file with five columns: lon.°, 1at.°, dx, dy, dz (m), in space-delimited format.
If easier, prepare the file in Excel and then save as “Formatted text (space delimited)”. An
example of the format is shown below. Also, see “gps example.dat” in the GPS_data folder.

Lon. Lat. Easting{m} Northing{m} Upwardingim}
138.5744 37.3977 -.143186 6.8597 8.6608
138.5164 37.3485 -.86678 6.1819 8.068
138.7869 37.5358 11688 6.8597 8.6068

138.7988 37.3113 -0.8484 0.0301 B8.008
138.7885 37.6675 ©0.8054 0.0873 0.000

2. After you have plotted a figure, choose Overlay > GPS stations, and select the file you created. If
you did not set “Depth” in the input file to zero, choose Functions > Change Parameters >
Calculation depth. If the input file has a source fault, you will see a plot like the one below for
the observed and modelled vectors (the circles mark the stations; they are not error ellipses) and a
vector scale bar. Here we saved the file as a pdf and added the legend in Illustrator.

3. To output a numerical file of the observed and modelled displacements, follow the instructions in
the Command Window (reproduced below). The GPS DATA file can be opened in Excel
for calculation of residuals. The example below uses the input “Niigata-Chuetsuoki-
2007.mat” and “Niigata-Chuetsuoki-2007-GPS.dat”.



COULOMB 3.3
User guide

o
40 2007 Mw=6.7
Niigata Chetsu-Oki 9 |1
20
o
E i i
X 0
= “©
> S5
-20
© o
b ----- GPS data =ee==
E User selected/Users/ross/Desktop/coulomb30/GPS_data/niigata2007.dat
© GPS_output.csv is saved in /Users/ross/Desktop/coulomb30/output £11
-40 » Observed ———=> -
> * To save the GPS data as t ry, use the following command
Modeled Tl * in the Command Window.
* save filename GPS_DATA (e.g., save mygps.mat GPS_DATA
® o) * To read the .mat formatted GPS data, use 'File -> Open...' menu later.
-60 ®
o 4
S
-80
0.5m
I L . L

. .
40 -20 0 20 40 60 80
X (km)

Coulomb 3.0.08.06 06—Aug—-2007 16:23:37 2007 Niigata.mat

4. To plot the vertical GPS vectors, type GPS_FLAG = ‘vertical’ into the Command Window.

If you would also like stations labelled by their sequence number, type GPS_SEQN_FLAG = ‘on’.
You will then see a plot like the one below right. Observed displacements are blue; if you are running a
model, its predictions will be red.

Default setting
Command window entries:
(GPS_FLAG = “horizontal”) GPS_FLAG = “vertical”

and GPS_SEQN_FLAG = “on”

T

7

6.3 To display crustal deformation as wireframe images

1.

Using Example-2(TH).inp, Choose Functions > Displacements > Horizontal displ. (wireframe).
The undistorted grid is in yellow and the distorted grid in blue. For a cross-section, use the default
cross-section line, but change the horizontal and depth increments to 2 km in the “Cross section”
control panel to see the images below. These cross-sections can be made to conserve area (they are
“retrodeformable” in geological jargon) if you set Poisson’s ratio to 0.5 by Functions > Change
Parameters >All input parameters:

Half space

Poisson's ratio 0.50]

‘Young modulus 800000.0 bar
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2. The wireframe cross-sections are useful to illustrate deformed strata associated with thrust and normal
faults and ramp-thrusts. You can pop them into Illustrator and color the layering so it appears like

strata.
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6.4 To display the vertical displacement by color gradients and contours
1. Choose Input > Open an existing file “Example-2(LL).inp”; then Functions > Displacements >
Vertical displ. (color & contours). You will see the following left image in the Coulomb 3.3 window.

806

Tiled

[X] Coulomb 3.0

Input Functions Overlay File Edit View Insert Tools Window Help

[oz@a |k [aane|« |0E

¥ (km)

Vertical displacement (m)

Interpolated

000 X! Coulomb 3.0

Input Functions Overlay File Edit View Inset Tools Window Help

ozEa x| aans|w |08

Vertical displacement (m)

Y (km)

2. Data smoothing and color scale options: In the “Vertical displ.” control panel, you can choose un-
interpolated data (left above) or “Interp.”, that is, interpolated (right above). Color saturation: You can
adjust color scale by moving the slider bar under “Color saturation” or type the value in the box, hit
return, and then click “Calc. & View” in the Displacement control panel (below left).

Under-Saturated

Vertical displacement (m)

Contoured

Vertical displacement (m)

36



COULOMB 3.3
User guide

Contours: In the “Displacement” control panel, choose “Contours” and click “Calc. & View”.
Contours showing vertical displacements are superimposed on the color image (image above right).
You can choose the contour interval. To get smooth contours, you must use a fine grid, because there
is no interpolation of the contours..

Cross section: Choose “Cross section” in the “Displacement” control panel. The methods of making
cross sections are similar to those described in previous sections.

6.5 To display the vertical displacement as a 3D image drape

1.

3.

Choose Functions > Displacements > 3D image drape. The color scale is controlled by the parameter
in your input file. See the lower left panel below.

To control the amount of vertical exaggeration, choose Functions > Change parameters > Displ.
exaggeration, and you will see a pop-up “Displ. exaggeration” window, in which you can change
vertical exaggeration by entering a new value and then clicking “OK”.

sg” 50 X (krm)

In the Coulomb 3.3 window, you can use options of Zoom In, Zoom Out, Pan, 3D Rotate,
Insert/Remove ColorBar, and Insert/Remove Legend, as described in previous sections.

6.6 To display the vertical displacement as 3D image wireframed surface

1.

Choose Functions > Displacements > 3D image wireframed surface. The color scale is controlled
by the parameter in your input file.

Try changing the vertical exaggeration by Functions > Change parameters > Vertical exaggeration
> 8000. Then, choose Functions > Displacements > 3D image wireframed surface. A swivelled
version is shown above right.

6.7 To display and output the horizontal and vertical surface deformation in

cross-section

Both “Horizontal Displ. (vectors)” and “Horizontal displ. (wireframe)” provide cross-section outputs.
These also produce numerical output files of the ground surface deformation components, Ux, Uy, and Uz.
You will see these lines in the Command Window:

User selected/ Users/rstein/ Desktop/ Coulomb33/input_files/Example-2(TH).inp
No lat. & lon. information is included in the input file.
Total seismic moment = 6.26e+26 dyne cm (Mw =7.13)

---> To calculate deformation, select one of the submenus from “Functions”.

Displacement.cou is saved in /Users/rstein/ Desktop/ Coulomb33/output_files
displacement_section.cou is saved in /Users/rstein/ Desktop/ Coulomb33/output_files
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6.8 To display any component of the strain field

1. Choose Functions > Strain. A Strain control panel will appear (below left).

Strain control panel

50T T T

Strain SYY component
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2. In the Strain control panel, choose the type of strain you want to calculate. For example, choose “Eyy”
and you will see the image above right. We are not using the “Engineering Strain” convention, where
values are multiplied by 2.

3. Numerical output files. Every time you click “Calc. & View” in the “Strain” control panel, an output
file called “dilatation_section.cou” will be created or updated. When you want to save your latest runs,
remember to rename the “dilatation_section.cou” file within the “output files” sub-folder; otherwise it

will be written over by your future displacement calculations.

“dilatation_section.cou” output file:

®e06

__ dilatation_section.cou

Here is an example of

Input file selected: Example-2(LL)_lonlat.inp

X

(km)
-36.0000000000000000
-36.0000000000000000
-36.0000000000000000
-36.0000000000000000

y

(km)
36.0000000000000000
36.0000000000000000
36.0000000000000000
36.0000000000000000

z

(km)
-0.0000000000000000
1.0000000000000000
2.0000000000000000
3.0000000000000000

y+ez)

0.0000001666026758
0.0000001641860500
0.0000001616694448
0.0000001590625171

0.0000001666026758
0.0000001641860500
0.0000001616694448
0.0000001590625171

dilatation

0.0000001666026758

0.0000001641860500
0.0000001616694448
0.0000001590625171

4. By choosing parameters in the the “Strain” control panel, you have the options to switch between the
tiled versus interpolated data grid, change color saturation, and contours, as explained in previous

sections.
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Coulomb Stress Calculations

7.1 The Coulomb failure hypothesis explained

Here we calculate static stress changes caused by the displacement of a fault or dike or point source (we
refer to these as “source faults™). The displacements in the elastic halfspace are used to calculate the 3D
strain field; this is multiplied by the elastic stiffness to derive the stress changes.

We resolve the shear and normal (clamping/unclamping) components of the stress change on a 3D grid of
points or on specified “receiver” fault planes. Receiver faults are planes with a specified strike, dip, and
rake, on which the stresses imparted by the source faults are resolved; we call these ‘specified faults” in the
Coulomb menus. The shear stress increase or decrease is dependent on the position, geometry, and slip of
the source fault and on the position and geometry of the receiver fault, including its rake. The normal stress
change (clamping or unclamping) is independent of the receiver fault rake.

We use the Coulomb failure criterion, Ao; = At, + W Ao, in which failure is hypothesized to be promoted
when the Coulomb stress change is positive. Here, Aoy is the ch