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Introduction

This document provides detailed information about McMap, a map generation program I 
authored as a byproduct of the U.S. Geological Survey program PRISM (Pliocene 
Paleoclimate Research, Interpretation, and Synoptic Mapping). It describes McMap's 
concepts and how to perform mapping and plotting tasks using McMap's features. After a 
brief section on getting started there is a tutorial. Throughout this manual any actions 
requiring clicking or menu selections via the mouse are highlighted in bold faced type. I 
recommend doing the tutorial if you have not used McMap before. All McMap commands 
and menus are treated in approximate order of appearance in the Reference section. The 
last section gives examples of some maps that can be created with McMap. It is assumed



that you are already familiar with basic Macintosh concepts and know your way around 
the desktop. If not, read the introductory information that came with your computer.

McMap is a simple base map generation program. You can plot line segments on the 
Macintosh screen from a file of latitude and longitude pairs. After completion of the map, 
the user can plot points on the map at given latitudes and longitudes with a short text entry 
at each location. Finished maps can be enhanced by adding text directly to the Graph 
window and by transfer to more elaborate graphics applications. McMap is written in 
Absoft MacFortran  and makes extensive use of FaceWare's Facelt  Macintosh 
Interface. McMap works best with a hard disk but can be run off a floppy.

Contents of the McMap Package
McMap comes on two 3.5" floppy disks:
The McMap Program disk contains the McMap 2.0 application, custom data files, and 
several map examples. The McMap Data disk contains 4 data files used by McMap 2.0 to 
construct predetermined hemispheric and global views of the earth.

Getting Started
If you have a hard disk place the contents of both disks in a folder named McMap. It is 
important that all files used by McMap always be located in this folder. If you do not have 
a hard disk, you can run McMap off the floppy but it will be very slow. Important! Do 
not use Multifinder with version 2.0 of McMap.

There are three types of icons associated with McMap 2.0 (Fig. 1). The application itself 
has a diamond shape and the words MAP+. Maps (saved as PICT documents) have a 
crude outline of North America on them with the word MAP. Text files have the word 
TEXT printed on them. Figure 1 below shows the McMap 2.0 application, a text file 
named "points", and a map named "panama map".

panama map points

McMap 2.0

[Figure 1]
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To start the program, open the McMap folder and double click the McMap 2.0 icon. The 
program will take a few seconds to load and then you will be presented with 2 data 
editors, a reduced view graph window, and a full size graph window (Fig. 2). If you are 
working on a full page or larger display, the windows should fit on your screen. You can 
move them around to any chosen positions and sizes. On a regular Macintosh (Plus or 
SE) with small screen it is best to position the two text editors and reduced view graph 
window so that they can be seen. The Full view graph window can be resized to a thin 
rectangular shape at the bottom of the screen. Then, when you create a map, you will see 
it in the reduced view window. Later you can enlarge the full view window so that it fills 
the screen. Once you have the windows in a configuration you like, it is best to choose 
Save Settings from the File menu. This will preserve your window arrangements for 
future McMap sessions. As with any Macintosh application, windows can be closed by 
clicking the go away box in the upper left hand corner and zoomed by double clicking 
in the zoom box to the right of the window title (Fig. 2). Scroll bars work the same as all 
Macintosh applications.

ft File Edit Window Maps Points

Text Editors. McMap comes with four full screen text editing windows. These are 
powerful editors capable of handling most routine text editing jobs. Only 2 editors will be 
visible when you first start up McMap 2.0 but you can bring up the other editors at any



time from the Window menu. They are very useful for creating and viewing data to be 
used by McMap.

Graph Window. McMap has full view and reduced view Graph windows (Fig. 2). 
All graphics operations take place in the Graph Window. To create a map select North 
Atlantic or any other map type from the Maps menu. When presented with a color 
selection dialog, press Cancel. The cursor will change to a small "deck" of computer 
cards indicating that McMap is doing calculations. In a few seconds, the cursor will 
change back to a normal state and the map you chose will appear on your screen. This 
map can be printed by selecting Print from the File menu or saved as a PICT document 
by selecting Save As from the File menu. After being saved as a PICT document the 
map can be opened by any applications accepting the PICT format for enhancement. If 
you get a message like ?FILE NOT FOUND, CR TO CONTINUE in the graph window 
you probably requested a map file (North Atlantic, World HI Res, N. H. Orthographic, 
etc.) but the data file for that map is not in the folder with the McMap application. Press 
return and restart the program after moving files dbasel through dbase4 into the McMap 
folder.

Tutorial
The best way to learn on the Macintosh is by doing so follow the commands outlined in 
this section to gain a better understanding of what can and cannot be done with McMap.

If McMap is already open on your screen, use the Select AH command under the Edit 
menu to select any text in Editor 1 and then select Clear from the Edit menu to delete it. 
Do the same for Editor 2. Now click on the Graph window. If you have a map 
showing, choose Select AH from the Edit menu and then choose Combine from the 
Edit menu to combine all objects into one picture. Now, select Clear from the Edit 
menu to clear the picture from the Graph window. If you have just started the McMap 
application you do not need to clear anything from the windows.

You should now see both text editors and the Graph window and all should be 
empty.

Point Files. Point files contain latitude (decimal degrees), longitude (decimal degrees), 
and optional text information for plotting points on maps created by McMap. The format 
of a point file is shown below:

5,1
44.35 -30.27 
31.83 -74.35 
00.58 -21.78 
70.05 8.32 
54.00 -46.20

A152 
A167 
A180

V273



The last line of this file must be followed by a return. The first number on the first line of 
the file indicates the number of latitude, longitude pairs to follow (in this example 5). The 
next number on the first line is either 0 or 1 and is separated from the 5 by a comma. A 
zero [0] indicates that no text is to be plotted next to the point on the map. A one [1] 
indicates that text (< 5 characters in length) is to be found following the latitude longitude 
pairs and should be plotted next to the point on a map. The second through sixth lines in 
the example contain the latitude and longitude of each point (in decimal degrees) followed 
by a short text string to be plotted next to the point. The last line is followed by a return.

Type the numbers you see above into Text editor 1 exactly as you see them. The latitudes, 
longitudes, and text strings can be separated by one or more spaces or a tab character. 
Make sure you add a hard return after the last line. Now choose Save As from the File 
menu and supply a name like points when prompted. Click Ok and your file will be saved 
to disk with the name you supplied. You can also print this file by choosing Print from 
the File menu.

Now select North Atlantic from the Map menu. Choose the pen color for the map by 
clicking one of the colors if you have a color monitor. Then click Set. If you do not have 
a color monitor or wish to keep the default color selection click Cancel. After a few 
seconds, a map of the North Atlantic should appear on your screen. You can now click on 
the Points menu and pull down to Squares. When you let !jo of the mouse button you 
will see a dialog on the screen that explains what a points file is and how it is formatted. 
Click Ok when finished reading this dialog. You will be presented with a standard Open 
dialog and scrolling file list. Find the file you created before and click on it and then click 
the Open box (If at this point you did not have a points file, click Cancel and go back to 
a text editor to make one). A dialog will appear on the screen (Figure 3) that allows you to 
select pen color and Font size and style:

Custom Map 

Color
Cancel

® black Qred Qblue O magentei 
O white O green O cyan O yellouu

Size Font

Los Rngeles 
Mobile
Monaco
Neuu York 
Palatino

O

Style
i

] Bold
] /10J/C

1 Underline

[Figure 3]
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Make any selections you desire and then click Set. If you do not want to make a selection 
or wish to accept the current selection you can click Set or Cancel. In a few seconds the 
points will appear as small squares in the appropriate place on the map of the North 
Atlantic. Next to each square the text will appear to identify the different points. Your 
map should look something like Figure 4.

[Figure 4]

At this point you could plot a different set of points with a different symbol or color. You 
can plot as many different point sets as you wish on the same map. The Map and points 
actually exist as different pictures. Choosing Save As from the File menu at this point 
would only save the last set of plotted points. First you must combine the pictures into 
one picture. Choose Select All from the Edit menu. Next choose Combine from the 
Edit menu. Now choose Save As from the File menu. Supply a name when prompted 
and this map will be saved in PICT format to that name. The map can also be printed by 
choosing Page Setup and then Print from the File menu.

Text Entry. You may wish to enhance the map further before saving it. How about 
adding text to indicate the position of Greenland, Iceland, North America, and Africa. 
Hold down the command key and drag with the mouse to make a small rectangle 
somewhere off the map but on the Graph window. Now press the Enter key once. 
You will see a text entry cursor and can type text into the box. Before typing anything 
choose Font, Style, Size (Fig. 3) from the Window menu to set the characteristics of 
the text you are about to type. Change the Font to Helvetica - Bold - 12 pt. Click 
Set and then type AFRICA. When you are done typing, press the Enter key again to 
end text entry. Once the text entry is ended, it cannot be edited. Now move the cursor to 
the middle of the text entry box and slide it to any position on the screen. Slide the word 
AFRICA to the continent of AFRICA. If the text entry box is masking part of the outline 
of Africa itself, click on the word AFRICA to select it and choose Send to Back from 
the Edit menu. You can add a tide or other additional text to the map at this point.
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Once you have the map, points and any basic text you need you should Select All and 
Combine to form a PICT document that can be saved and opened in a full feature 
graphics application like Claris MacDraw.

Map Files. The user can supply a data file of latitude and longitude along with pen 
commands to plot custom maps not provided under the Map menu. The first line of the 
Map file must contain the northernmost latitude, southernmost latitude, westernmost 
longitude, and easternmost longitude, all separated by commas, space, or tab characters. 
Your map can be a small area within this latitude longitude rectangle or it can fill it, but no 
part of your map can extend beyond the rectangle. These latitudes and longitudes should 
be in decimal degrees.

45.00, -10.00,-100.00, -15.00
0 35.0 -90.0
1 40.0 -20.00
1 10.00 -22.05
1 15.98 -60.56
1 -9.5 -95.09
1 35.0 -90.0 
9999 9999

The remaining lines of the file should contain a pen flag, and latitude longitude pairs in 
decimal degrees. The pen flag is a zero [0] or one [1]. A [0] tells the pen to move-to the 
latitude longitude given. A [1] tells the pen to draw a line to the latitude and longitude 
given. Your map is drawn via a number of move-to and line-to commands in this way. 
The end of your file must contain a line with 9999 9999 separated by a space or tab 
character and followed by a return. Type the file shown above into a text editor. Be sure 
to put a hard return after the last line of the file. Save the file by choosing Save As from 
the File menu. Give it a name like MYMAP. Now choose Custom Map from the 
Maps menu. You will be prompted for Colors and Font characteristics. For now just 
click the Set button. You will be presented with the Standard Open dialog. Find your 
MYMAP file and click on it and then click the Open button. In a few seconds the 
following map should appear on your screen (Fig. 5).



[Figure 5]

This map can be saved, printed, or enhanced with text as described above. You can also 
plot points on the map by going to an editor and creating a point file.

This is the end of the tutorial section. You now have a general idea of what McMap 2.0 
can and cannot do for you. At this point it would be a good idea to clear the Graph 
window and plot several of the custom map files provided with the program: Australia, 
Panama, and Atlantic Coastal Plain. Try plotting these maps and then plotting the 
associated points files on them. After combining and saving as PICT, open these maps in 
MacDraw, SuperPaint, Delta Graph, Freehand, Illustrator, etc. The lines on the maps are 
drawn one pixel wide by one pixel high. The maps can be improved for printing by using 
one of these graphics packages to make the lines in the map thinner. Use charting 
programs like Delta Graph or Cricket Graph to place latitude- longitude grids on the 
finished maps.

Reference

File Menu

Open...The Open item is sensitive to the type of window currently active. If you have the 
Graph Window active, choosing Open... will bring up the standard Open File dialog with 
scrolling file list and will allow you to open a PICT file. Using the Open command with 
one of the 4 data editors active will allow you to open any ASCII text file created by 
McMap or any other text editor.

Save This menu selection will save the contents of the active window.



iSilMcMap

Save As...This menu selection will save the contents of the unnamed active window. If 
the Graph window is active the graph or map will be saved as a PICT file to the folder or 
disk you indicate with the name you supply.

Save Settings...Use this selection after moving or resizing windows to fit your 
display. Settings also saves page setup information for printing.

DeIete...This selection will allow you to delete files on disk from within McMap.

Page Setup...This activates the standard Page Setup dialog.

Print...Print the contents of the active window. Brings up a dialog box with choices.

96-Return This menu item is always gray and not available to the user with version 2.0.

Transfer... Allows you to launch another application from McMap without returning to 
the desktop. Simply select transfer and you will be given a list of applications on the disk 
to transfer to. You may launch any one of the applications or Cancel.

Quit Use this selection to quit McMap. 

Edit Menu

Undo Use this selection to undo last action in text Editor window.

Undo Resize Use this selection to undo last resizing of objects in Graph window.

Cut Cuts selected text from editor (object from graph windo\iO, stores in clipboard.

Copy Copys selected text from editor (object from graph window) and stores in 
clipboard.

Copy Frame Area Copies frame (drawn by holding do^vn 9  key while dragging 
mouse) into clipboard as a bitmap.

Copy Table Copies selected text to the clipboard and places tabs in between text items. 
This is useful for transforming a rectangular selection of data to tab text prior to pasting 
into spreadsheet like editors of applications like Excel or Cricket Graph.  ..

Paste Pastes current contents of clipboard at current insertion point. 

Clear Clears last object drawn in graph window (selected text in Editor window). 

Select AH Select all text in current editor (objects in graph window). 

Combine Combines selected pictures into a new picture.

Tabs-to-Spaces Convert tabs in current text selection to a user defined number of 
spaces.



Search For...Executes a search and replace routine to find all or some text strings. 
User can limit search to selected text and/or defined columns to speed search.
bone"       l|(XF-Find]£C'R-Henl*< p][Xfl-RII](ttN-!S'»>uj) D XT-From

Search For:

where '#

Change To:

[Help] '* 

[x] 3 l-lgnort

TopC

= <§>'#' OSP OTflB OCR OLF OflSCII: 32

= <§> #' OSP OTRB OCR OLF OflSCII: 

> Case D 9 UJ-UJord D § E-Regular E»press

32

ion

: sec-< «*o & \

_ j 
(

Selection

search 
:olumns:

1

to

255

[Expressions]

Next Case Continues searching for text string last defined in Search For... menu item. 
Bring to Front Brings selected picture to front of Graph Window. 
Send to Back Sends selected picture to back of Graph Window.

Window Menu

Editor Setup...Use to set tab size, auto indent, enter key designation, file handling, 
cursor position and selection information as shown below. Click on the Help button for 
help with this dialog box.

Tab 
Size

fluto 
Indent

Use ENTER key as:

OTflB
O Space-based TflB
O §£-Return
( ) Scroll to Insertion Point

File Handling:

O Selection-based 
® One file per window

Show cursor position & selection size

Graph Setup...Use to enable/disable various graph features. Click on the buttons at the 
bottom of this dialog box for information on Frames, Placement, Cursors, and Printing.



____________1 Graph Setup I

[x] always use [Page Setup] for page size [
Kl Show cursor position & frame size *
[3 Enable picture drag & resize
D Use reduced uiew of graph
n Mse P*< tun? frttiiws in reducpd uu?u;

Pages Size(piKels) Current Palette |

Rcross 

Down

ujidth 

height

641)

S<

Frame ) [Placement) [ Cursors ] [ Printing

6 point Sets text in editor to 6 point Geneva.

9 point Sets text in editor to 9 point Geneva.

12 point Sets text in editor to 12 point Geneva.

Left Left justifies text being typed into the Graph window.

Right Right justifies text being typed into the Graph window.

Centered Centers text being typed into the Graph window.

Reduced View Makes the reduced view graph window the (turrent window.

Graph Makes the full view graph window the current window.

Editor 1 Makes Editor 1 text editor window the current window.

Editor 2 Makes Editor 2 text editor window the current window.

Editor 3 Makes Editor 3 text editor window the current window.

Editor 4 Makes Editor 4 text editor window the current window.

Maps Menu
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North Atlantic Produces a Equidistant Cylindrical projection of the North Atlantic 
Ocean and surrounding land areas.

World (Coarse) Produces a Equidistant Cylindrical projection of the World at a very 
coarse scale (Plots very quickly). This is useful for plotting large amounts of data on a 
global view. Once satisfied with the results, data can be plotted on the High Resolution 
World Map (above). 
World (Hi Res) Produces a Equidistant Cylindrical projection of the World.

Northern Hemisphere (Orthographic) Produces an Orthographic Projection, North 
Polar aspect.

Northern Hemisphere (Stereographic) Produces a Stereographic Projection, North 
Polar aspect.

Southern Hemisphere (Orthographic) Produces an Orthographic Projection, South 
Polar aspect.

Southern Hemisphere (Stereographic) Produces a Stereographic Projection, South 
Polar aspect.

Custom Map Produces a custom Equidistant Cylindrical map from a user supplied text 
file with latitude - longitude pairs.

Points Menu

Circles Use this menu item to place circles with or without associated text at specific 
locations on a map.

Squares Use this menu item to place squares with or without associated text at specific 
locations on a map.

Crosses Use this menu item to place crosses with or without associated text at specific 
locations on a map.



Quick Maps

This section outlines the steps necessary to produce maps using the McMap application. It 
is intended as a checklist for those already familiar with McMaps features. If this is the 
first time you are using McMap, do the tutorial.

1. Make sure the Graph window is clear and active.
I

2. Select any of the map types from the Maps menu.

2a. If your selection is any of the predefined maps make sure the dbasel - dbase4 
files are in the same folder as the McMap application.

2b. If your selection is a custom map make sure you have a map file which has the 
boundaries of the map on the first line and 9999 9999 as the last line, followed by 
a return. Each line of the main part of the file should contain a pen movement 
command followed by a latitude and then a longitude in decimal degrees, all 
separated by commas. See Map Files (page 9) for details. Make sure this custom
map file is in the same folder as the McMap application 
this map file.

. When prompted, select

3. Your map should be drawn in the Graph window in severa seconds to several minutes 
depending on the size of the map file and speed of the machine^ you are working on.

4. With the Graph window still active, choose circles, squares, or crosses from the Points 
menu.

5. You will be prompted for a points file which should be set up with the first line 
containing the number of points to be plotted and a flag indicating whether or not text will 
be plotted adjacent to each point. Each remaining line in the file will contain a latitude, 
longitude, and a text string if text is to be plotted. The last line of the file should be 
followed by a return. See Point Files (page 6) for details.

6. To print or save your Map (PICT format) you must first dombine all objects into one 
drawing. To do this choose select all from the Edit menu. Next choose Combine from the 
edit menu. Now you can print or save as you would with any Macintosh application.
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Notes

All maps except the hemispheric views use the equidistant cylindrical projection. The 
equator is the standard parallel, true to scale and free of distortion. Future versions of 
McMap will allow the user to select various common projections for custom map types.

Custom map files and point files are restricted to 7000 line segments and points 
respectively.

If you have suggestions for improvements to future versions contact me, Harry J. 
Dowsett, US Geological Survey, 970 National Center, Reston VA, 22092.



Maps Available
North Atlantic
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World Hi Res
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World Coarse
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Northern Hemisphere Orthographic



Northern Hemisphere Stereographic
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Southern Hemisphere Orthographic



Southern Hemisphere Stereographic
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Custom Map Examples 
Panama



Australia


