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Abstract  
The monitoring of wide-area hydrologic events requires the manipulation of large amounts 

of geospatial and time series data into concise information products that characterize the location 
and magnitude of the event. To perform these manipulations, scientists at the U.S. Geological 
Survey Center for Earth Resources Observation and Science (EROS), with the cooperation of the 
U.S. Agency for International Development, Office of Foreign Disaster Assistance 
(USAID/OFDA), have implemented a hydrologic modeling system. The system includes a data 
assimilation component to generate data for a Geospatial Stream Flow Model (GeoSFM) that can 
be run operationally to identify and map wide-area streamflow anomalies. GeoSFM integrates a 
geographical information system (GIS) for geospatial preprocessing and postprocessing tasks and 
hydrologic modeling routines implemented as dynamically linked libraries (DLLs) for time series 
manipulations. Model results include maps that depicting the status of streamflow and soil water 
conditions. This Users Manual provides step-by-step instructions for running the model and for 
downloading and processing the input data required for initial model parameterization and daily 
operation.  

Introduction to GeoSFM 
The Geospatial Stream Flow Model (GeoSFM) was developed to establish a common visual 

environment for the monitoring of hydrologic conditions over wide areas (Artan and others, 2001). 
The monitoring activities include topographic analysis, data assimilation, time series processing, 
and presentation of the results. The GeoSFM is designed to use remotely sensed meteorological 
data in data sparse parts of the world (Artan and others, 2007). Many of the data sets involved in 
these processes are raster grids. The spatially distributed nature of the raster grids used in these 
processes required the adoption of a customizable geographic information system with excellent 
raster functionality. The ArcView GIS software was adopted for the implementation because it 
provided a visual, customizable development environment with excellent support of raster 
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operations. An ArcView extension was developed (in Avenue) for the geospatial processing 
operations and for initializing time series analysis tasks. Routines for performing the hydrologic 
computations involved in mass balance and routing were developed in a mixed programming 
environment (C/C++ and Visual Fortran) and compiled as dynamically linked libraries (DLLs). 
These DLLs are called up directly from within ArcView scripts, eliminating the need to develop a 
separate interface for hydrologic routing operations. Descriptions of the algorithms used within 
these programs are presented in the GeoSFM Technical Manual (Asante and others, 2007a). This 
Users Manual describes the software components, data sets, processing steps, and input/output files 
associated with running the model. It also includes appendices which provide step-by-step 
instructions, with associated screen images, to guide users through model set up procedures.   

Preprocessing Module  
 GeoSFM’s preprocessing module consists of routines for performing terrain analysis, 
extracting subbasin characteristics, and estimating unit hydrograph responses. The terrain analysis 
routine delineates rivers, subbasins, and other elevation derivatives such as slope and drainage area. 
The subbasin characterization routines extract hydrologic parameters from elevation, soil, and land 
cover data into files for use in subsequent model operations. The response estimation routine 
computes the distribution of flow at the subbasin outlet following an instantaneous input event. It 
stores the result in a text file for use in flow simulations. This section of the Users Manual begins 
with instruction on installing GeoSFM, followed by instructions for completing the preprocessing 
tasks.  

Model Installation 

As shown in figure 1, GeoSFM consists of a series of nine directories containing programs, 
documents, and data sets. The PROGRAMS directory contains the software executables and DLLs 
used in GeoSFM. It also contains a batch file for installing and registering the software on the local 
computer. The DOCUMENTATION directory contains this Users Manual and the accompanying 
Technical Manual. The PRESENTATION directory contains illustrated presentations used for 
classroom instruction of new users. The DEMDATA directory contains elevation data from the 
USGS HYDRO1k data set (Verdin and Greenlee, 1996). The SOILDATA directory contains soil 
parameters derived from the FAO/UNESCO Digital Soil Map of the World (FAO, 1995). The 
LANDCOV directory contains a grid of vegetation data from the Global Land Cover 
Characteristics (GLCC) database (Loveland and others, 2000). The RAINDATA and EVAPDATA 
directories contain samples of the rainfall and evapotranspiration grids used in model computations. 
The SAMPLES directory contains input and output text files from a sample application of GeoSFM 
for the Limpopo Basin (Asante and others, 2007b), which is used for illustrating model 
functionality in this manual. The data files are distributed by CD-ROM or by download from the 
USGS EROS Web site.  
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Figure 1. Components of the Geospatial Stream Flow Model. 
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To install GeoSFM, download or copy from CD all files described above to your C: drive. 

The GeoSFM software files listed in table 1 must be installed in the ArcView 3.x extension 
directory. The other files will be needed to complete the tutorials. 
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Table 1. Description of Software Programs in GeoSFM.  

Files Description 
geosfm.avx GeoSFM’s ArcView 3.x Extension; provides the model interface 
Geosfm.dll GeoSFM’s Dynamically Linked Libraries; contain hydrologic analysis routines 
Geosfmcalib.exe GeoSFM’s Calibration module; executes the multi-objection parameter estimation algorithm.  
Geosfmgzip.exe  Freeware for unzipping weather data files downloaded via FTP, renamed for easy 

identification 
Geosfmtar.exe Freeware for untarring weather data files downloaded via FTP, renamed for easy 

identification 
Geosfmpost.exe GeoSFM utility for postprocessing calibration module results 
Geosfmstats.dll GeoSFM Dynamically Linked Libraries for postprocessing simulation time series results. 
Geosfmstats.exe GeoSFM executable utility for postprocessing simulation time series results. 
INSTALL.bat GeoSFM installation utility for copying and registering program files to the local computer. 
 

In c:\GeoSFM\Programs, double-click the INSTALL.bat file and installation is complete. 
This installation will copy all GeoSFM files and register the .dll files to your computer. You will 
need to create a new directory, c:\GeoSFM\workspace, for output files. 

 

Open ArcView GIS by clicking the shortcut on your desktop or by selecting it 
from your Programs menu. When ArcView opens, the Welcome to ArcView GIS dialog box is 
displayed. Depending on the setup configuration, there are different ways to create a new project. If 
the dialog box below is displayed, click the with a new View radio button under Create a new 
project and click OK. 

 

 
 
The Add data dialog box appears asking if you would like to add data to the View now. 

Click No. 
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If the dialog box is not displayed, as shown below, click the Views icon and then click the 
New button in the untitled Project window. This will open the View1 window. Click and drag the 
bottom right corner to expand the view, and position the window next to the untitled Project 
window. 

 

 
 
Next, from the File menu, select Extensions to load Geospatial Stream Flow Model and the 

Spatial Analyst. 
 

 
 
Check the boxes next to Geospatial Stream Flow Model and Spatial Analyst to load the 

extensions to the project and click OK. 
The Menu and tool bar will update to reflect the additional functions of the Geospatial 

Stream Flow Model and the Spatial Analyst extensions. 
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From the File menu, select Save Project As. Save your project to your workspace 

c:\GeoSFM\workspace\ with the file name Limpopo.apr. The extensions will then be preloaded 
next time you open the project. 

 

 

Terrain Analysis 

Click the Add Theme button  to add the Limpopo Basin shapefile. Change the Data 
Source Types to Feature Data Source. Add the shapefile named limpbas.shp from the 
c:\GeoSFM\samples\limpbas directory. Click OK. 

 

 
 
The Geospatial Stream Flow Model uses a digital elevation model for the delineation of 

hydrologic modeling units.  

Add the elevations grid to the View using the Add Theme button . Change the Data 
Source Types to Grid Data Source. Click elevations from the c:\GeoSFM\demdata directory 
and click OK to add the DEM to the View.  
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Click and drag the Limpbas.shp theme to the top of the table of contents and check the box 
so that it is visible over the elevations grid.  
 

 
 
Next, set the analysis environment from the Analysis menu by selecting Properties. 

Change the Analysis Extent to Same As Limpbas.shp and the Analysis Cell Size to Same As 
Elevations. All other parameters will adjust themselves. Click OK. 
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Begin by clipping the DEM to the extent of the analysis area. In the Analysis menu, select 

the Map Calculator. Double-click [Elevations] from the Layers list and click Evaluate. 
 

 
 
Select Map Calculation 1 in the table of contents to display Theme in a raised box. From 

the Theme menu, select Save Data Set. In the Save Data Set: Map Calculation 1 dialog box, 
navigate to the c:\GeoSFM\workspace directory, and in Grid Name, name your new grid extent 
Limpopo_elev. Click OK.   

Click the Add themes button  to add the new permanent Limpopo_elev grid to the 
View. Change Data Source Type to Grid Data Source and click Limpopo_elev to add to the 
View. 

Next, remove all Themes except for the new Limpopo_elev theme. Select the Theme to be 
removed by clicking Theme, which is now a raised box. In the Edit menu, select Delete Themes to 
remove the selected Theme. Continue until all themes are removed except for the Limpop_elev 
theme.  Multiple themes can be selected by holding down the shift key while selecting the themes. 
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From the View menu, select Zoom To Themes to focus on the new extent area. You may 
want to apply a legend suitable for elevation to the theme. To do so, from the Theme menu select 
Edit Legend.   

In the Color Ramps drop-down list at the bottom of the Legend Editor, select Elevation 
#1 and click Apply. 

 

 
 
You are now ready to begin running the Geospatial Stream Flow Model!  
 
In the Geospatial Stream Flow Model, select Complete Terrain Analysis from the drop-

down list. 
 

 
Confirm your working directory as c:\GeoSFM\workspace and click OK.  
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If you have existing river or basin coverages, you may add them. For this tutorial, select No. 
 

 
 
Select the Corrected DEM as the only existing grid and click OK. 
 

 

 
 
Select Yes to confirm that you want to create the missing grids. 
 

 
 
Confirm that the grid called Limpopo_elev is indeed the Corrected DEM. 
Click OK. 
 

 

 10



The program should begin performing the terrain analysis. After a while, depending of 
DEM data resolution and modeling window spatial extend (time could vary from few seconds to 
hours), it will ask you to input the stream delineation threshold. This is the minimum number of 
cells that must be upstream of a given location before a river can be initiated.   

Use the suggested default of 1000 and click OK. Using a different threshold will result in a 
model with a different number of streams and watersheds.  

 

 
 
In a few minutes, you should get a message telling you the terrain analysis is complete. 

Click OK. (Limpopo.elev theme is replaced with Elevations theme during the processing.) 
 

 

Basin Characterization 

Next, you need to generate a file that summarizes basin characteristics. From the 
Geospatial Stream Flow Model menu, select Generate Basin Characteristics File. 
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Confirm your working directory as c:\GeoSFM\workspace. Select Yes when presented 

with the question Add Soils & LandCover Data to View? 
 

 
 
A list of the data sets you need will appear. Click OK. 
 

 
 
The required data sets are provided for you in the c:\GeoSFM\soildata directory. Change 

the Data Source Types to Grid Data Source. Hold the shift key down to select all the grids (ks, 
maxcover, rcn, soildepth, texture, and whc). Click OK to add them to the View. 
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The program will present a new list of your input grids including all the input parameters. 
 

 
 
The program will produce two files containing the characteristics of each subbasin and 

river. It will also produce a file containing the computational order, which is required for 
subsequent program operations. When the processing is complete, a dialog box will appear 
indicating the name and location of the output files. Click OK. 

 

 
 
Below all the input grids are added to the table of contents. 
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Unit Hydrograph Response 

From the Geospatial Stream Flow Model menu, select Generate Basin Response File.  
 

 
 
Confirm your working directory and click OK. 
 

  
 
Select the Non-Uniform from USGS Land Cover Grid option for determining the 

overland flow velocity. Click OK. 
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A list of the required inputs is displayed. Click OK. 
 

 
 
Click Yes when asked whether you want to add USGS Land Cover grid to the View.  
 

 
 
Change the Data Source Types to Grid Data Source. Select usgslandcov from 

c:\GeoSFM\landcov directory and click OK to add the land cover grid to the View. 
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Confirm the names of the input grids and the Computational Order File with values 
displayed in the Specify Required Inputs dialog box. Click OK. 

 

 
 
Manning’s N for different land cover types, derived from (Maidment, 1993), should now be 

displayed. Use the default Manning’s coefficient values for each of the land cover types. Click OK. 
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The program will compute a response file (similar to a unit hydrograph) for each subbasin. 
This may take a few minutes. After the computations are complete, a dialog box will appear and 
indicate to you the location of the output file.   

 

 
 
Traveltime and Velocity themes are added to the table of contents. Also, the response table 

is displayed. Click OK in the dialog box. You have now finished the terrain analysis and have 
generated the basin characteristics file and the response file. The basin and response files resulting 
from these computations are stored for use in subsequent model computations. 

Hydrologic Analysis Module 
GeoSFM’s hydrologic module contains several routines for moving water through the river 

basin. The module contains a data preparation routine for extracting time series data from 
geospatial grids into ASCII files by subbasins. The rainfall data presented here are derived from 
algorithms developed by Xie and Arkin (1997), while the evapotranspiration data are derived using 
the methods of Verdin and Klaver (2002). Two soil moisture accounting routines perform the 
vertical separation of incident rainfall into atmospheric releases, surface runoff, and subsurface 
flows. The module also contains three river flow transport routines for simulating the horizontal 
movement of water through the river network. The user is expected to prepare the input files, 
perform a soil moisture accounting, and then route the output with one river using one of the 
available routines. Instructions for completing the tasks are provided in the following sections, and 
detailed algorithm descriptions are provided in the accompanying Technical Manual.    

Preparing Input Time Series Files  

In this next step, a rainfall value will be estimated for each subbasin from the daily rainfall 
grids. To begin this computation, from the Geospatial Stream Flow Model menu, select Generate 
Rain/Evap Data Files.  
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Select Rainfall and Evaporation when prompted to Select Parameter to Extract. Click 

OK. 
 

 
 
Next, you will be prompted to Enter Model Parameters. Specify the location and dates to 

be processed as shown in the figure below. The Rain Data Directory and Evap Data Directory 
need to reflect the correct path; as seen below, these fields may need to be updated from the default 
path. The End Day Number field should be changed from the default of 240 to 10, which will 
result in a shorter processing time. Click OK. 
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After a few moments, a message box will appear indicating that the processing is complete. 
The message also gives the location of the output files: rain.txt and evap.txt. Click OK. 

 

 
 
The rain.txt file created from this process contains an average rainfall value in millimeters 

for each subbasin per day. The evap.txt file contains a potential evapotranspiration (PET) value in 
tenths of millimeters for each subbasin per day. The routing program will use these files for 
performing the soil water accounting. 

Soil Moisture Accounting 

The next item in the Geospatial Stream Flow Model menu allows you to compute how 
much water is contributed to streamflow through the soil. From the Geospatial Stream Flow 
Model menu, select Compute Soil Water Balance. 

 

 
 
Confirm the working directory as c:\geosfm\workspace. Click OK. 
 

 
 
You will then be prompted to verify the input and output files in the Enter Model 

Parameters dialog box; use the default files listed. Click OK. 
 

 19



 
 
Next, Enter Model Parameters as shown below; use the default values. Click OK. 
 

 
 
For short runs (30 days or less) getting the initial soil moisture content correct greatly 

influences the accuracy of your calculated flows. For this run, an initial soil wetness of 10 percent 
of storage capacity (Initial Soil Moisture value of 0.1) will be assumed.   

Next, a prompt comes up to Select Flow Routing Method for Computation. The available 
choices are Linear Soil Model and Non-Linear Soil Model. For this tutorial, choose the Linear 
Soil Model option. Click OK. 
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The model computes the soil water balance and indicates the location of the key output file 

containing the local contribution of each subbasin to downstream river flow. The Final Soil 
Moisture table is also displayed. Click OK. 

 

 
 
The basinrunoffyield.txt file produced will be used by the flow routing program in 

subsequent operations. The basin polygon theme, basply.shp, is also color-coded to indicate the 
spatial distribution of soil moisture at the end of the simulation period.   

Check the box next to this theme to turn it on, and make sure the theme is in a raised box. 
From the Theme menu, choose Hide/Show Legend to display the legend. There are three classes 
of soil moisture: dry, moist, and wet. 

 

 
 
The image provides you with visual information of the distribution of soil moisture at the 

end of the simulation. The full time series of soil moisture values is written to the soilwater.txt file 
which is stored in the working directory. Another important file stored in the same directory is the 
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basinrunoffyield.txt file, which contains the runoff values to be passed to the river transport 
module.  

Computing Streamflow 

Finally, you get to the part engineers like; moving the water around. To begin, click the 
Geospatial Stream Flow Model menu and select Compute Stream Flow.  

 

 
 
Specify your working directory. Click OK. 
 

 
 
The next dialog box that appears allows you to verify or enter the simulation input files and 

output files. Pay particular attention to the No. of Days of Forecast Required field. In this 
example the forecast will be for a 3-day period. Click OK. 
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You will next be prompted to select the Flow Routing Method for Computation. The 

choices include: Simple Lag Routing Method, Diffusion Analog Routing Method, and 
Muskingum Cunge Routing Method. Select the Simple Lag Routing Method for this tutorial. 
Click OK. 

 

 
 
The model will soon indicate that it has finished the computation and written the results to 

the streamflow.txt file in the working directory. Click OK in the Stream Flow Routing Complete 
dialog box.   
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The Streamflow.txt table is displayed in ArcView to allow you to browse through the 

results of the analysis, and a simple ASCII version of the same table, the streamflow.txt file, is 
written to the working directory. The file contains a streamflow value in cubic meters per second 
for each stream during each simulation time step, in comma delimited format.  

Parameter Calibration Module 
While the goal of GeoSFM is to allow for rapid assessment of streamflow conditions in 

basins with little ground-based information, its precision in representing flow processes can be 
greatly improved when observed flow information is available for adjusting initial parameter 
estimates. A parameter calibration module is incorporated into GeoSFM to facilitate such 
parameter adjustment within user-specified ranges. This module consists of one routine for 
analyzing the sensitivity of model results to changes in parameter estimates and another routine for 
testing different sets of selected parameters to determine which set results in the most accurate 
model results. User instructions for these two routines are provided in the following section. 
Detailed descriptions of the algorithms in the routines are provided in the accompanying Technical 
Manual. 

Performing Sensitivity Analysis 

The sensitivity analysis evaluates the sensitivity of model outputs to changes in input 
parameters, and it is used to determine which parameters to modify during calibration. To initiate 
sensitivity analysis, select the menu item Perform Sensitivity Analysis from the Geospatial 
Stream Flow Model menu.   
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The Working Directory dialog box will ask you to Specify your working directory. Click 

OK. 
 

 
The next dialog box displayed prompts you to Select the river reach for sensitivity 

analysis. In this tutorial, select basin 140 from the drop-down list and click OK. 
 

 
 
The next dialog box will list the absolute limits for the sensitivity parameters. Use the 

default values and click OK. This list shows the 20 different parameters that will be tested.  
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At this point, a window will open and display the number of data sets created and the 

number of model runs completed. This method is a one-at-a-time method where one model run will 
only have one parameter changed with all other parameters held constant. Twenty values are 
sampled at equal intervals for each of 20 parameters, resulting in a total of 400 model runs.   

This will take a few minutes to complete.   
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When the process is finished, the number of model runs successfully completed will reach 
400. A dialog box will display stating that the Sensitivity Analysis is Complete and the results 
have been written to sarunoutput.txt.   

 

 
 
The output file sarunoutput.txt will give you the mean absolute difference of test results 

over the parameter range for each parameter. The greater the differences, the more sensitive the 
parameter. Sensitivity analysis is important when preparing to calibrate so that resources are not 
wasted on parameters that have little or no effect on model output. 

 

 

In this example, parameters 1, 2, 5, 
7, 18, and 19 show the greatest 
differences as measured by the 
largest standard deviations. The 
parameters that are the most 
sensitive are SoilWhc, soil Depth, 
Interflow, BaseFlow, RivFPLoss, 
and Celerity. 

 
The sensitivity analysis provides you with information on which parameters to focus on 

during the calibration described in the following section.  

Performing Model Calibration 

The next menu item is Perform Model Calibration; from the Geospatial Stream Flow 
Model menu, select Perform Model Calibration. The purpose of calibration is to adjust model 
parameters to closely match the real system. 
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Confirm your working directory. Click OK. 
 

 
The next box will display the model calibration parameters. Both input and output files will 

default in the display. Click OK. 
 

 
 
The following dialog box displays the input and output files needed for the postprocessing 

program. Click OK. 
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Select the model configuration from the following drop-down list. Linear Soil Mode, Lag 

Routing is the option selected for this tutorial. Click OK. 
 

 
 
Copy the observed_streamflow.txt from the geosfm\samples directory and paste into your 

working directory—in this example c:\GeoSFM\workspace. In the next dialog box, select which 
observed streamflow stations will be used for calibration. In this example there are two stations; 
select 1 and click OK. 

 

 
 
Next, select the basin ID for the streamflow station from the drop-down list. The streamflow 

station used for this tutorial is located in basin 140. Select 140 and click OK. 
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Next, the parameters to be calibrated are selected. While the results of the sensitivity 

analysis are important in this selection, your knowledge of the basin and your interpretation of the 
deficiencies of the current model are also important in deciding which parameters to calibrate. In 
this example, six parameters were chosen: SoilWhc, Depth, Interflow, BaseFlow, RivFPLoss, and 
Celerity. These six parameters were the most sensitive from the sensitivity analysis tutorial. Select 
SoilWhc, Depth, Interflow, BaseFlow, RivFPLoss, and Celerity from the parameter list by 
holding down the Ctrl key and clicking OK. 

 

 
 
You are now prompted to Define a Maximum No. of Runs. The number of runs is 

dependent on the length of the streamflow record, the number of parameters being calibrated, and 
the complexity of the parameter dependent model response for the watershed being tested. In this 
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tutorial, select 1440 as the default number of runs. There are other options in the drop-down list; 
you may select a smaller number for a shorter processing time. For optimum results, more model 
runs are better.   

Click OK. 
 

 
 
The How Should Convergence Be Measured? dialog box is displayed with a prompt. 

Select Objective Function Type and the Root Mean Square Error (RMSE). Click OK. 
 

 
 

The following window will open and begin the calibration process. Notice the listed 
parameters. This process will take some time because it needs to run through 24 samples and 1,440 
iterations.  

In this screen you see the calibration process is now running. The six parameters chosen are 
displayed along with the lower and upper values. This is the beginning of the objective function 
results for the samples. Each sample will display number of fluxes selected—in this example only 
one flux was selected. 
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When the sampling is completed, the next process is labeled “Begin metropolis shuffled 

complex evolution,” which runs for 1,440 iterations.   
 

 
 
The next window will open and start the postprocessing.   
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The postprocessing produces a time series file which lists the observed streamflow and 

calibrated streamflow output values. The objectives_postproc.out file lists the best calibration 
values in the time series file, and the trdoff_bounds.out displays the lower and upper boundaries 
with the average streamflow from the sample runs. New basin and river files (basin.txt and 
river.txt) containing the parameter set which resulted in the best fit between simulations and 
observations are also produced for use in subsequent model runs. You can also revert to the 
precalibration basin and river characteristics by restoring the information contained in the 
basin_original.txt and river_original.txt files.  

Postprocessing Module 
One major advantage of performing hydrologic modeling in a geospatial environment is that 

simulation results can be linked to river and basin feature representations, allowing the user to view 
and interact with the results in a visual environment. Three postprocessing routines are provided in 
GeoSFM to facilitate such interaction. The first routine computes characteristic flows for each river 
reach and stores the results in the associated river shapefile. The second routine displays flow 
results in color-coded maps by linking flow time series with the associated basin shapefile. The 
third routine allows hydrographs to be plotted with a simple click any river reach. Instructions for 
running these routines are described in the following sections. 

Updating Bankfull and Flow Statistics 

From the Geospatial Stream Flow Model menu, select Update Bankfull and Flow 
Statistics to compute characteristic flows for each river reach and store the results in an associated 
river shapefile. 
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Confirm the working directory as c:\geosfm\workspace. Click OK. 
 

 
 
The Basin Theme dialog box displays asking you to Select basin coverage/grid theme 

from the drop-down list. Select basply.shp (basin polygon shapefile). Click OK. 
 

 
 
Next, the GeoSFM Utilities dialog box opens with a prompt to Enter Model Parameters. 

The input file defaults to streamflow.txt and the two output files default to monthlyflow.txt and 
annualflow.txt. Click OK. 
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If less than 9 months of data are supplied, the following Info dialog box will open. Click 
OK. 

 
 
The model will soon indicate that it has finished processing and has written the results to the 

riverstats.txt file in the working directory. The riverstats.txt file contains the statistical estimate 
of how much water is needed to fill a river channel (carrying capacity.) 

Click OK in the Bankfull and Flow Characteristics Computed dialog box. Notice the 
riverstats.txt table is also displayed. 

 

 
 
The View is updated and the annualflow.txt, monthlyflow.txt, riverstats.txt, and 

streamflow.txt files are added to ArcView as tables. 
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Display Flow Percentile Map 

From the Geospatial Stream Flow Model menu, select the next item in the list: Display 
Flow Percentile Map. 

 

 
 
Confirm the working directory as c:\geosfm\workspace. Click OK. 
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Select Streamflow.txt when prompted to Select Input Data File in the Input Flow Time 
Series dialog box. Click OK. 

 

  
 
Select basply.shp when prompted to Select basin coverage/grid theme in the Basin 

Theme dialog box. Click OK. 
 

 
 
Next, at the prompt Select day to plot flow percentile map, choose 1999010 from the 

drop-down list. This example represents day 10 in the year 1999. Click OK. 
 

 
 
After a few seconds, a map will display. The basins are now classified into three categories: 

low flow, normal flow, and high flow. 
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For the next example, day 13 was selected. Click OK. 
 

 
 
Results for day 13 are seen below. 

 38



 
 
Notice the decreasing flow trend in many headwater subbasins between day 10 and day 13. 

Such images provide a visual representation of simulated flows, which allows you to quickly 
identify areas of concern within the study area.  

Displaying Hydrographs 

GeoSFM provides a tool for plotting and displaying hydrographs. You may also open the 
resulting file in a spreadsheet to plot out the hydrographs; Microsoft Excel spreadsheet software 
provides some additional plotting options, and it does a good job displaying a long time series. In 
the View, make sure that you have basply.shp selected and displayed in a raised box. To plot the 
hydrographs in ArcView, go to the Geospatial Stream Flow Model menu and select Display Flow 
Hydrographs to activate the plotting tool.  
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After you select Display Flow Hydrographs, your cursor changes to a “+”. Now click in 

one of the subbasins for which you would like to create a hydrograph. The subbasin is now 
highlighted to show that it has been selected, and a window opens with the hydrograph displayed. 
An ArcView hydrograph is produced showing the daily variation of flow at the outlet of the 
selected subbasin. 

 

 
 
Click several different subbasins to see how different hydrographs compare. See if you can 

observe the downstream propagation of flow by comparing hydrographs from the headwater 
subbasins to those farther downstream. 
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You can analyze questions such as  

• Does the 3-day forecast indicate increasing or decreasing streamflows? 

• Are the basins with high soil moisture the same basins with the most streamflow? 
 
ArcView’s graphing capabilities are limited in the number of data points that can be plotted 

and in the ability to manipulate graph elements to enhance the display. You may want to import 
individual simulation output files into other programs, such as Microsoft Excel spreadsheet 
software, for presentation quality graphs. 

GeoSFM Utilities  
A number of utilities are included in GeoSFM for its use in operational settings.  

• RAINDATA tools for downloading and processing data produced at USGS EROS for daily 
GeoSFM runs  

• GISDATA tools for performing routine tasks associated with comparing and integrating 
satellite-derived data in raster format with vector station data 

• DEMDATA tools for removing spurious pits which may exist in elevation data sets other than 
the HYDRO1k 

• TIMESERIES tools for processing output files from hydrologic analysis to determine 
representative flows at daily, monthly, and annual time scales 

 
Instructions for using these utilities are given in the following sections. 

Rain Data Tool for Downloading Data  

GeoSFM contains several menu items designed to assist the operational user in retrieving 
and processing daily rainfall and evapotranspiration data. The first Raindata option is Download 
Rain/Evap Grid, which uses file transfer protocol (FTP) and a live Internet connection to 
download data from the USGS EROS anonymous FTP server. A listing of the data sets available 
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for download from the USGS EROS FTP site for 16 days after initial collection is provided in table 
2. 

Table 2. Operational geospatial time series data available for download from the USGS EROS FTP 

site.  

Region Data Source Naming Convention Comments 

  Rainfall  

Global NASA TRMM TRMM<YY><MM><DD>g  

Africa NOAA RFE Rain_<YYYY><JJJ>g Integrates in situ gauge data 

Asia NOAA RFE Rain_<YYYY><JJJ>g For limited project sites only 

  Potential Evapotranspiration  

Global USGS GPET1 Evap_<YYYY><JJJ>g  
1Global Potential Evapotranspiration data set from USGS EROS 

From the main toolbar, go to GeoSFM Utilities and select Raindata: Download 
Rain/Evap Grid from the drop-down list. 

 

 
 
Specify your working directory. Click OK. 
 

 
 
At the prompt, use the default entries. Click OK.   
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In the Specify Type Data to Download dialog box, select Get Rainfall Grids from the 

drop-down list. Click OK. (Get Global PET Grids would be selected for PET data.) 
 

 
 
In the Select the region for analysis dialog box, select Africa from the drop-down list. 

Click OK. The latest available data will be displayed for the region selected.  
 

 
 
Wait for the FTP transfer to complete (Internet connection must be open). The program 

writes a local file with the selected regional data sets. The available rain/evap data will be displayed 
for downloading. Generally, 16 days of data are available for downloading from the FTP site.   

Select ALL Grids to be downloaded by clicking and highlighting each selection that you 
want to download. For this tutorial, 10 days of data were used. Click OK. The naming convention 
for rain data is rain_YYYYJJJ.tar.gz (“Y”–year, “J”–Julian day). The naming convention for 
evapotranspiration data is YYMMDD.tar.gz (“Y”–year, “M”–month, “D”–day). 
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The GeoSFM Utilities box appears with the message Data Transfer Complete and the 

number of files downloaded. All downloaded files will now be in your working directory. Click 
OK. This process can be repeated for downloading PET data. 

 

 

Rain Data Tool for Image to Grid Conversion 

The second Raindata option is a tool for extracting and converting downloaded time series 
images into ArcInfo grid format. From the main toolbar, go to the GeoSFM Utilities tool and select 
Raindata: Unzip, Untar, Imagegrid from the drop-down list. 

 

 
Specify your working directory. Click OK. 
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Select ALL zipped Grids to be processed by clicking and highlighting each selection that 

you want to process. Click OK. 
 

 
 
Next, Select ALL image files (*.bil) to be converted to grids by clicking and highlighting 

each item. Click OK. 
 

 
 
A dialog box will appear for each file; confirm your directory. Click OK for each dialog 

box—one for each rain file to download. 
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At the same time, the rain grids will be added to the table of contents in a new View labeled 

Geographic View.  
 

 
 
When all processing is complete, the GeoSFM Utilities dialog box will appear, stating 

Data Processing Complete, along with the number of grids processed and directory information. 
This process can be repeated for PET data. The grid naming convention for raindata is 
Rain_YYYYJJJg (for example, Rain_1999001g), and for evapotranspiration data Evap_YYYYJJJg 
(for example, Evap_1999001g). 
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All Rain_YYYYJJJg themes are added to the table of contents as seen below. (A g at the 
end of a grid name indicates the geographic projection.) 

 

 

Rain Data Tool for Projecting Grids 

From the main toolbar, go to the GeoSFM Utilities tool and select Raindata: ProjectGrid, 
Geo to Lambert Azimuthal from the drop-down list to project the grids from geographic to the 
Lambert Azimuthal projection. 

 

 
Specify your working directory. Click OK. 
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In the Select the continent for analysis dialog box, select Africa from the drop-down list. 

Click OK. 
 

 
 
Select Yes in the Do you want to project the grid(s) from Geographic Coordinate 

System to Lambert Equal Area Azimuthal dialog box. 
 

 
Next, the Analysis Properties for Rain_YYYYJJJg is displayed; accept the default values 

and click OK. 
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Select Yes when prompted Do you want to use this analysis extent for all grids? 
 

 
 
After a few seconds, the Lambert Azimuthal View window opens with the 

Rain_YYYYJJJ themes projected in Lambert Azimuthal Equal Area projection. (Notice the g at 
the end of the grid name is no longer displayed.) 

 

 
 
Now the Rain_YYYYJJJ grids can be added to the View when prompted during the 

Generate Rainfall and Evaporation Basin Files.  

GIS Tool for Computing Grid Statistics 

GeoSFM contains a number of tools designed to facilitate some commonly performed 
operations. From the GeoSFM Utilities menu, select GIS Tools: Compute Rain/Evap Grid 
Statistics. 
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The Model Parameters dialog box is displayed; confirm the Output Directory and type in 

the correct path for the Rain Data Directory and Evap Data Directory. Confirm the Start Year 
and End Year fields. Enter the Start Day Number and the End Day Number field for the time 
frame you want to compute. In this example, the End Day Number was changed to 10 from the 
default value for faster processing time. Click OK. 

 

 
 
At the prompt, select Both Rainfall and Evaporation Grids to compute local statistics. 

Click OK. 
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Next, the Local Statistics Type dialog box appears with a list of various statistics that can 
be computed. Select the statistic to be computed from the drop-down list. For this tutorial, select 
GRID_STATYPE_SUM, which will display the sum rain/evap for the 10-day date range defined 
in the Model Parameters dialog box. Click OK. 

 

 
 
After a few seconds for processing, the R10SUM1 Theme (sum of the rain data for 10 days) 

is displayed.  
 

 
 

After a few more seconds if it’s correct, the E10SUM1 Theme (sum of the evap data for 10 
days) is displayed.   
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Run through the process again and select a different type of statistic to compute; compare 

the differences in the displayed data. 

GIS Tool for Point Sampling of Grids  

The second menu item is GIS Tools: Pick Grid Values at Point. Use this menu option to 
extract rainfall and evaporation grid data at points into a shapefile/coverage. To begin this process, 
a point theme is required. Instructions for creating such a theme are provided in Appendix 5 of this 
document. For completing this tutorial, a point theme is provided in the Geosfm\samples\point 
theme directory. 

First, to add a Theme, click the Add Theme button . From the Add Theme dialog 
box, navigate to the c:\geosfm\samples\point theme directory.   

In the Data Source Types box, make sure Feature Data Source is selected. Highlight 
gauges2.shp and click OK.   

 

 52



 
 
This shapefile contains randomly defined points just for use in this tutorial; these points do 

not reflect actual rain gauge station sites. This is to help you get an understanding of the 
functionality available to you through the GeoSFM Utilities tool. 

From the GeoSFM Utilities menu, select GIS Tools: Pick Grid Values at Point. 
 

 
 
Confirm your working directory. Click OK. 
 

 
 
Next, at the prompt to Select the Point Theme to be used, select gauges2.shp from the 

drop-down list. Click OK. 
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The Convert gauges2.shp dialog box opens. Convert the shapefile to a grid. Navigate to 
the c:\geosfm\workspace directory. Name your new grid in the Grid Name field. Click OK. 

 

 
 
In the Conversion Field: gauges2.shp dialog box at the prompt to Pick field with output 

header ID values, select Stations_i. Click OK. 
 

 
 
Next, at the prompt to Select Parameter to Extract, for this tutorial select Rainfall and 

Evaporation. Click OK. 
 

 
 
At the Enter Model Parameters prompt, confirm the Output Directory and type in the 

correct paths for the Rain Data Directory and Evap Data Directory. Confirm the Start Year and 
End Year fields. Enter the Start Day Number and the End Day Number for the time frame you 
want. In this example, the End Day Number was changed to 10 from the default value for faster 
processing time. Click OK. 

 54



 
 
It will take a few seconds for processing. When the processing is complete, a dialog box 

will display showing the path of the two new output files. Click OK. 
 

   
 
These two files contain the rain and evaporation data for the user-defined points (gauges) 

for the first 10 days in 1999. 

GIS Tool for Interpolating Point Data 

The third GIS Tools menu item listed in the GeoSFM Utilities is Interpolate Station Data 
to Grid. This function is used when there are areas over which spatially distributed precipitation 
data is not available. Data interpolation routines convert station readings into a continuous surface. 
Both rainfall and evaporation tables are required. These tables need to contain station IDs along 
with daily amounts of rainfall/evaporation for each station. Instructions for creating these tables are 
included in the appendices of this Users Manual. For the purposes of this tutorial, tables are 
provided in the c:\geosfm\samples\stations directory. 

Create two new folders in your working directory labeled Raindata and Evapdata; this 
will help in managing the data files that will be created from this process. Start by opening a new 
View by clicking View and the New button from the project window.  
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Add the gauges2.shp file to the View using the Add Theme button  from the View 
menu. Change the Data Source Types to Feature Data Source. Click the gauges2.shp file from 
your working directory and click OK to add to the View.  

 

 
 
Next, add the rain station table to ArcView by selecting Tables and clicking the Add button 

seen below. 
 

 
 
Navigate to your working directory. In the box to List Files of Type, select Delimited Text 

(*.txt) and select your .txt file (in this example, rainstations.txt). Click OK. 
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Next, join the new rainstations.txt file to the attribute table of the gauges2.shp file. 

Arrange both tables as seen below. Highlight the common column headers in both tables—
Stations_i in Attributes of Gauges2.shp and Station ids in rainstations.txt. Make sure the 
destination table is active (adding fields to Attributes of Gauges2.shp).   

 

 
 
Click the Join icon. The new columns are added to the Attributes of Gauges2.shp table. 
 

 
 
The new rain data fields are also added to the attribute table. 
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Repeat this process for the evaporation data. You can choose to process rainfall and 

evaporation data separately or at the same time. The attribute table will need all the necessary data 
for the selection made during processing. 

 

Click the Add Theme button  to add the Limpopo Basin shapefile. Change the Data 
Source Types to Feature Data Source. Add the shapefile named limpbas.shp from the 
c:\GeoSFM\samples\limpbas directory. Click OK to add shapefile to the View. 

 

 

Next, add the elevations grid to the View using the Add Theme button . Change the 
Data Source Types to Grid Data Source. Click elevations from the c:\GeoSFM\demdata 
directory and click OK to add the DEM to the View.  

 

 
 
Next, set the analysis environment from the Analysis menu by selecting Properties.   
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Change the Analysis Extent to Same As Limpbas.shp and the Analysis Cell Size to Same 

As Elevations. All other parameters will adjust themselves. Click OK. 
 

 
 
Now you are ready to start the process.   
 
From the GeoSFM Utilities menu, select GIS Tools: Interpolate Station Data to Grid. 
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Select the point theme to be interpolated from the drop-down list. In this example, select 

Gauges2.shp. Click OK. 
 

 
 
Select Parameter to Interpolate—in this example, select Rainfall and Evaporation. 

Click OK. If the evapotranspiration data are already provided as grids, they do not need to be 
interpolated in this tutorial. If the evapotranspiration data were in a text type formatted file, the data 
will need to be interpolated. 

 

 
 
Enter the output directory for rainfall grids in a new raindata folder created in 

c:\GeoSFM\workspace\raindata. Click OK. 
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At the Select Rainfall Fields prompt, select the fields that contain the rainfall values. Select 

the 10 days from the list, R1999001 through R1999010. You may select any number of days for 
which data are available. In this tutorial, select all 10 listed. Click OK. 

 

 
 
Enter the Output Directory for Evaporation Grids in a new evapdata folder created in 

c:\GeoSFM\workspace\evapdata. Click OK. 
 

 
 
At the Select Evaporation Fields prompt, select the fields that contain the evaporation 

values. Select the 10 days from the list, E1999001 through E1999010. Again, you may select any 
number of days for which data are available. For this tutorial, select all 10 listed. Click OK. 
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In the Start Date dialog box, change the default start date to 1/1/1999 to match the date of 

the first rainfall/evap fields selected above. The first field selected was 1999001 and represents 
1/1/1999. All the grids created will be based on the Julian day. Click OK. 

 

 
 
When asked if you would like to Add Interpolated Grids to the View, click Yes. 
 

 
 
Next, the Interpolate Surface dialog box is displayed. 
 
Populate:  
Method: options are IDW and Spline, select IDW (Inverse Distance Weighting) 
Z Value Field: select the default, Stations_i 
Nearest Neighbors or Fixed Radius: select Nearest Neighbors 
No: of Neighbors: select the default, 12 
Power: change the Power field to 1 to create a smoother surface (default is 2) 
Barriers: select the default, No Barriers 
Once parameters are selected, click OK. 
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It will take a few seconds to process the rainfall/evap grids. A process completion window 

appears when it is complete. Click OK. 
 

 
 
From the Theme menu, you may want to select Edit Legend and apply a precipitation color 

ramp like the one below. 
 

 

DEM Tool for Sink Filling 

In this tutorial, GeoSFM’s elevation grid filling tool is presented. The tool is used for filling 
spurious sinks, while maintaining sinks that are natural occurrences in the landscape. This time-
consuming process yields a DEM that will properly transport water across its surface. This process 
is best done on a smaller basin region than for an entire continent. If the elevation data are from the 
HYDRO1k DEM data set developed at USGS EROS, then this process is not needed. HYDRO1k is 
a hydrologically corrected DEM, which implies that it is devoid of spurious pits that interrupt 
hydraulic connectivity over the land surface. 
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To begin the process, add the Sinks_dem grid to the View using the Add Theme button 

. Change the Data Source Types to Grid Data Source. Click Sinks_dem from the 
c:\GeoSFM\samples directory and click OK to add the DEM to the View.  

 

  
 
The DEM is added to the View, as shown below. 
 

 
 
The only menu item under DEM Tools is Fill Sinks in DEM. From the GeoSFM Utilities 

menu, select DEM Tools: Fill Sinks in DEM.   
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Confirm your working directory. Click OK. 
  

 
 
Next, the Identify Input DEM dialog box is displayed. At the Select the Grid to be Filled 

prompt, select Sinks_dem from the drop-down list. Click OK. 
 

 
 
After a few moments for processing, the new fill1 grid is added to the table of contents. You 

may want to apply a legend appropriate to the elevation. To do so, from the Theme menu, select 
Edit Legend.   

In the Color Ramps drop-down list, select one of the Elevation choices and click Apply. 
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The Sinks_dem file in the samples folder is removed and a new fill1 grid is added to your 

workspace directory. The resulting elevation grid is ready for use in terrain analysis. 

Time Series Tool for Changing Temporal Resolution 

The GeoSFM Utilities contains three time series tools for performing tasks commonly 
required when examining simulation results. The first of the three functions is Convert Daily to 
Monthly and Annual. From the GeoSFM Utilities menu, select Time Series: Convert Daily to 
Monthly and Annual. 

 

 
 
Confirm your working directory. Click OK. 
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From the GeoSFM Utilities dialog box, Enter Model Parameters. The input file defaults 

to streamflow.txt, and the output files are monthlyflow.txt and annualflow.txt. Click OK. 
 

 
 
Next, at the Select Statistic to be Computed prompt, select Max. Click OK. 
 

 
 
After a few moments of processing, the Time Series Conversion Complete dialog box will 

display as seen below. The program will produce two files containing the monthly and annual 
streamflow amounts for each subbasin. The message contains the name and location of the output 
files. Click OK. 

 

 
 
Two new tables are shown below; the streamflow data was for a few days in January 1999. 
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Time Series Tool for Frequency Analysis 

The last tool in this tutorial is Compute Frequency Distribution. From the GeoSFM 
Utilities menu, select Time Series: Compute Frequency Distribution. 

 

 
 
Confirm your working directory. Click OK. 
 

 
 
Next, the Select Input File for Flow Statistics Computation dialog box is displayed. 

Navigate to your working directory and under List Files of Type, select Comma Delimited 
Textfile from the drop-down list. Select streamflow.txt as seen below. Click OK. 
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When the Basin Theme dialog box is displayed, select your basin coverage/grid theme. In 

this tutorial, the basin coverage selected is basply.shp. Click OK. 
 

 
 
Next, the Select the statistics to be computed dialog box opens. In this example, Total 

Flow, Mean Flow, Maximum Flow, and Minimum Flow have been selected. Notice that more 
than one statistical type can be selected at a time from the list of options provided. Click OK. 

 

 
 
Confirm Request to update Low/Med/High Bankfull flow levels is displayed. Select 

Yes. This analysis is not recommended for less than 10 years of data. Because you have only been 
working with 10 days of data, the results of the analysis will not be meaningful. The objective is to 
familiarize you with the functionality available in the GeoSFM Utilities tool. 
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The next dialog box displayed is the Select field to display; in this example, Mean has 

been selected. Click OK. Again, notice the list of options available for displaying the results. The 
new calculations will be displayed in the basply.shp, overwriting what was displayed.   

 

 
 
Below is the updated basply.shp with the Mean value displayed. 
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You can change the value displayed. From the Theme menu, select Legend Editor. Then change the 
Classification Field and click the Apply button. The Color Ramp selected is Yellow to Green to 
Dark Blue. Below, you can see the results with the Minimum classification field selected. 
 

 
 
Below is the result when the Maximum classification field is selected. 
 

 
 
Notice the differences among the three different classifications. The maximum flow 

classification is useful for quickly identifying subbasins through which the highest flows passed 
during the analysis period. 

Conclusions 
This manual provides step-by-step instructions for running the GeoSFM software and 

accompanying data sets for performing model setup, preprocessing, flow simulation, calibration, 
and postprocessing tasks. It also provides instructions for running utilities for downloading daily 
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data and processing of required time series grids and performing some common processing tasks 
for elevation and time series grids and files. Additionally, five appendices are included with 
detailed instructions for downloading and processing elevation, soil, and land cover data sets used 
in parameterizing GeoSFM. The accompanying GeoSFM Technical Manual details the functions 
underlying the menus described in this manual. Together, these two manuals should serve to 
document the GeoSFM system for potential users seeking to assess hydrologic conditions in data 
sparse settings (Artan and others, 2007).  
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Appendix 1: Processing Elevation Data  
GeoSFM can use any digital elevation model for the delineation of hydrologic modeling 

units. The use of the HYDRO1k data set is described in this document because it is readily 
available and easily distributed. The descriptions encompass the processes to download data and 
initial processing to remove nodata cells and prepare the data set for use in GeoSFM. As with other 
tutorials in this document, the Limpopo Basin in southern Africa is used as the test basin.  

These data are available from the U.S. Geological Survey Earth Resources Observation 
Science (EROS) Center at http://edcdaac.usgs.gov/gtopo30/hydro/africa.html. This Web site brings 
you to the Land Processes Distributed Active Archive Center. From this page, scroll down to the 
list of downloads. (Data for other regions are found at the same Web site at the following address: 
http://edcdaac.usgs.gov/gtopo30/hydro/). The Web site allows you to download the entire African 
data set (including elevation, compound topographic index, aspect, flow direction, flow 
accumulation, slope, drainage basins, and streams) or any of its individual components.  

Download the elevation data set by clicking Download HYDRO1k DEM for Africa as a 
tar file (34.0MB). Save the file to the workspace, c:\GeoSFM\workspace. Use WinZip to select 
and extract all files to the workspace. Extract the af_dem.bil from the af_dem.bil.gz file. If you do 
not already have WinZip installed, download a free trial version from 
http://www.winzip.com/winzip/download.htm. 

 
Extracted files: 
af_dem.gz 
af_dem.bil 
af_dem.blw 
af_dem.hdr 
af_dem.stx 
readme.af 
 
Next, you need to add the elevation data to the ArcView project, convert it into the required 

ArcInfo grid format, and make some corrections. Add the Digital Elevation Model to the View 

using the Add Theme button  from the View menu. Change the Data Source Types to Image 
Data Source. Click the af_dem.bil file from the c:\GeoSFM\workspace directory and click OK to 
add the DEM to the View.  

 

 
 
Next, the DEM will need to be converted to a grid. Select the theme Af_dem.bil so that it 

appears in a raised box. Checking the box next to the theme name will make it visible.   
From the Theme menu, select Convert to Grid. 
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The Convert Af_dem.bil dialog box appears. Navigate to the c:\GeoSFM\workspace 

directory and name your new grid Af_dem_grid in Grid Name. Click OK. 
 

 
 
A dialog box appears asking if you would like to Add grid as theme to the View. Click 

Yes. 
 

 
 
The new Af_dem_grid theme is shown below. 
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After adding the grid to the View, some map calculations must be performed to correct 

abnormally high values that are introduced into the DEM to avoid having to store negative values 
in the *.bil format. From the Analysis menu, choose Map Calculator. 

 

 
 
The first correction subtracts 65536 from all the cells with elevation higher than 32768, 

which restores the original negative values. The result of this computation is that all NODATA 
cells are assigned values of –9999 while all other cells will have their true elevation (negative or 
positive). 

In Map Calculator, type the following expression exactly as shown: 
 
( [Af_dem_grid] >= 32768).con( [Af_dem_grid] – 65536, [Af_dem_grid] ) 
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Click the Evaluate button. This produces a temporary grid called Map Calculation 1, seen 

below. 
 

 
 
Choose Map Calculator from the Analysis menu again to do the second calculation. The 

second calculation assigns values of zero to NODATA cells and values of one to all other cells so 
that the NODATA cells can be eliminated in the final step. Type in the following expression 
exactly as shown:   

 
( [Map Calculation 1] = -9999 ).con (0.AsGrid, 1.AsGrid) 
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Click the Evaluate button. This produces a temporary grid called Map Calculation 2, seen 

below. 
 

 
  
The final computation divides the result of the first correction with the result of the second 

correction. Zero divides values of –9999 while 1 divides all other values. Division by zero results in 
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a NODATA cell being created while division by 1 leaves the original value unaltered. Choose Map 
Calculator from the Analysis menu again and type in the following expression exactly as shown:   

 
( [Map Calculation 1] / [Map Calculation 2]) 
 

 
 
Click the Evaluate button. This produces a temporary grid called Map Calculation 3, seen 

below. 
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Because this final elevations grid will be used for the rest of the tutorial, it needs to be made 
permanent. Select the Map Calculation 3 Theme so it appears in a raised box. From the Theme 
menu, select Save Data Set. 

  

  
 
In the Save Data Set Dialog Box, navigate to the c:\GeoSFM\workspace directory and 

name the new grid Elevations in the Grid Name field. Click OK. 
 

 
 
You can now remove all themes by selecting the theme so it appears in a raised box, and 

then from the Edit menu, select Delete Themes. 
 

 
 
Now the permanent Elevations grid can be added to the View using the Add Theme button 

. The resulting elevation grid is ready for use in terrain analysis. 
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Appendix 2: Defining Analysis Extent 
GeoSFM uses a shapefile to define the analysis extent for use in the modeling process.  

HYDRO1k Basins data sets are derived using the vector stream networks along with the flow 
direction data set. Each polygon in the basin data set has been tagged with a Pfafstetter code 
uniquely identifying each subbasin. Additional attributes defining the characteristics of each 
subbasin have also been developed. These data are available in an ArcInfo export format and 
shapefile format. The process for downloading data documented below captures data needed to 
complete the terrain analysis tutorial. This tutorial was developed for the Limpopo Basin in 
southern Africa. The elevation data are available from the U.S. Geological Survey Earth Resources 
Observation Science (EROS) Center at http://edcdaac.usgs.gov/gtopo30/hydro/af_basins.asp. Data 
for other regions are also found at the Web site of the Land Processes Distributed Active Archive 
Center at http:/edcdaac.usgs.gov/gtopo30/hydro.  

 

 
 

                       
 
 
 
 
The African HYDRO1k data set can be downloaded in its entirety, or individual layers can 

be downloaded by selecting the data layer, see above. Detailed descriptions of the techniques used 
in the development of the HYDRO1k data set can be found in the Readme file. The page contains 
options for downloading the entire HYDRO1k data set for Africa as a tar file (215.5 MB) or 
downloading individual components in either ArcInfo export format or shapefile formats.  

Click Download HYDRO1k Basins data set for Africa as a tar file in shapefile format 
(7.4 MB). Save the file to your workspace, c:\GeoSFM\workspace. Use WinZip to select and 
extract all files to your workspace. Extract all files from the af_base.tar.gz file. If you do not 
already have WinZip installed, you can download a free trial version from 
http://www.winzip.com/winzip/download.htm. 

 
Extracted files: 
af.readme 
af_bas.dbf 
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af_bas.prj 
af_bas.shp 
af_bas.shp.xml 
af_bas.shx 
 
Next, you need to add the basin data to the ArcView project and select the basins for the 

analysis area, which is the Limpopo Basin in this tutorial. Add the basin data to the View using the 

Add Theme button  from the View menu. Change the Data Source Types to Feature Data 
Source. Click the af_bas.shp file from the c:\GeoSFM\workspace directory and click OK to add 
to the View.  

 

 
 
After adding the shapefile, select the basin area in the attribute table. Open the attribute 

table by clicking the Table icon. From the Table menu select Query. 
 

 
 
The Attributes of Af_bas.shp query box opens.  
Double-click Level 2 under Fields. Make sure the Update Values box is checked so all 

Level 2 values will display under Values. Click the “=” button and then the value you need for this 
basin. Select 54 for this tutorial. Click New Set. 
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([Level2] = 54) 
  
All attributes with a value of 54 in the Level2 column will have a yellow highlight. The 

African shapefile will also show the subbasins selected highlighted in yellow. 
 

 
 
Now you can convert the selections to a shapefile. From the Theme menu, select Convert 

to shapefile. 
 

 
 
The Convert Af_bas.shp dialog box opens. Navigate to the appropriate directory and under 

File Name type in the name of the new shapefile. Click OK. 
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The Add shapefile as theme to the view dialog box will display. Click Yes. 
 

 
 
Below, the new shapefile is displayed. 
 

 
 
The shapefile can be added to the View when prompted during the terrain analysis process. 
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Appendix 3: Processing Land Cover Data 
Download the data from the Internet at http://edcdaac.usgs.gov/glcc/af_int.html. 
 

 
 
This Web site brings you to the Land Processes Distributed Active Archive Center—Global 

Land Cover Characterization. From this page, scroll down to the Links to land cover data sets. 
Two different versions are available; select Version 2. 

Select the appropriate area for download from the table shown below.  
 

GLCC – Version 2 

Global North America Eurasia 

Africa South America Australia Pacific 

 
Select Africa because the study area is the Limpopo Basin in southern Africa. Create a new 

folder in the GeoSFM folder called glcc for all of the land cover data. Selecting Africa will display 
the Africa Land Cover Characteristics Data Base Version 2.0 page. From the Africa Land Cover 
page, select Data in Lambert Azimuthal Equal Area Projection. This transfers you to a page 
with links to data and documentation in either compressed or uncompressed format. Scroll down 
the page to the image files and click Compressed/3.3 Mb. Save the file to c:\GeoSFM\glcc. Use 
WinZip to select and extract all files to your workspace. From the afusgs2_0l.img.gz file, extract 
the afusgs2_0l.img. If you do not already have WinZip installed, you can download a free trial 
version from http://www.winzip.com/winzip/download.htm. You can also elect to download the 
uncompressed files directly if you have adequate bandwidth to support such a download.  

The downloaded land cover data is provided in a generic image array format (flat, 
headerless, binary raster data) to maximize the flexibility for importing the data into a variety of 
software systems. The following procedure is needed before importing these raster image files into 
ArcView. First, rename the image file to afusgs2_0l.bsq (.bsq –image file– band sequential). Next, 
create a header file with the following fields:  
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nrows—the number of rows in the image 
ncols—the number of columns in the image 
nbands—the number of spectral bands in the image; default is 1 
nbits—the number of bits per pixel per band; default is 8 
layout—the organization of the bands in the image file; acceptable values are bil, bip, and 

bsq 
skpbytes—the number of bytes of data in the image file to skip to reach start of image data 

(bypass header information); default is 0 
ulxmap—the x-axis map coordinate of the center of the upper-left pixel 
ulymap—the y-axis map coordinate of the center of the upper-left pixel 
xdim—the x dimension of a pixel in map units 
ydim—the y dimension of a pixel in map units 
 
The image parameters needed to populate the new header file can be found in the 

documentation for each of the continental databases. For example, the projection parameters for the 
Limpopo study area can be found by clicking Africa Documentation and scrolling down to 
section 2.2 Lambert Azimuthal Equal Area Projection Parameters. The data dimensions of the 
Africa land cover characteristics data set are 9,276 lines (rows) and 8,350 samples (columns), 
resulting in a data set size of about 77 megabytes for 8-bit (byte) images. The map projection 
parameters are as follows: 

 
Projection Type: Lambert Azimuthal Equal Area  
Units of Measure: meters  
Pixel Size: 1,000 meters  
Radius of sphere: 6,370,997 m  
Longitude of origin: 20 00 00 E  
Latitude of origin: 5 00 00 N  
False easting: 0.0  
False northing: 0.0  
XY corner coordinates (center of pixel) in projection units (meters):  
Lower left: ( –4458000, –4795000)  
Upper left: ( –4458000, 4480000)  
Upper right: ( 3891000, 4480000)  
Lower right: ( 3891000, –4795000) 
 
Prepare an ASCII header file in any text editor, such as WordPad, as shown below.   
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Save the document from the file under the name afusgs2_0l.hdr in the directory 

c:\GeoSFM\glcc. The land cover data must be added to the ArcView project and converted into a 
grid for use in GeoSFM. Add the afusgs2_0l.bsq file to the View using the Add Theme button 

 from the View menu. Change the Data Source Types to Image Data Source. Click the 
afusgs2_0l.bsq file from the c:\GeoSFM\glcc directory and click OK to add the land cover data to 
the View.  

 

 
 
The land cover data will not display until it has been converted to a grid. To convert the 

land cover data to a grid, select the theme afusgs2_0l.bsq so that it appears in a raised box. From 
the Theme menu select Convert to Grid. 
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The Convert Afusgs2_0l.bsq dialog box appears. Navigate to the c:\GeoSFM\glcc 
directory and type in usgslandcov in Grid Name. Click OK. 

 

 
 
A dialog box appears asking if you would like to Add grid as theme to the View. Click 

Yes. 
 

 
 

A new usgslandcov theme is shown below. 
 

 
 
Next, you need to add the Lu_code and description fields to the attribute table.   
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Africa Land Cover Characteristics Data Base Version 2.0 

 
 

Africa Readme  

Africa Land Cover Database Table  

Data in Interrupted Goode Homolosine Projection  

Data in Lambert Azimuthal Equal Area Projection 
 
 

Value  Code  Description  
1 100 Urban and Built-Up Land 

2 211 Dryland Cropland and Pasture 

3 212 Irrigated Cropland and Pasture 

4 213 Mixed Dryland/Irrigated Cropland and Pasture 

5 280 Cropland/Grassland Mosaic 

6 290 Cropland/Woodland Mosaic 

7 311 Grassland 

8 321 Shrubland 

9 330 Mixed Shrubland/Grassland 

10 332 Savanna 

11 411 Deciduous Broadleaf Forest 

12 412 Deciduous Needleleaf Forest 

13 421 Evergreen Broadleaf Forest 

14 422 Evergreen Needleleaf Forest 

15 430 Mixed Forest 

16 500 Water Bodies 

17 620 Herbaceous Wetland 

18 610 Wooded Wetland 

19 770 Barren or Sparsely Vegetated 

20 820 Herbaceous Tundra 

21 810 Wooded Tundra 

22 850 Mixed Tundra 

23 830 Bare Ground Tundra 

24 900 Snow or Ice 

Value 330 not recognized in model need to add 
 
Now that you have the data you need, you can prepare an ASCII file. Open WordPad 

(Start/Programs/Accessories/WordPad). Cut and paste the data into WordPad. 
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Commas need to be added to separate column values, and each line needs to be on a 

separate row. The header and the first line of data also need to be added. 
 
Add header names and values: 
Value, Code, Name 
0, 0, Unclassified—notice the commas separating field values 
An example of the WordPad document can be seen below.  
 

 
 
To save the document, from the File menu, select Save As. 
File Name—usgslandcov.txt 
Save as Type—Text Document  
Directory—c:\GeoSFM\glcc  
 
Click new grid theme so it appears in a raised box. Click table icon to open attribute table. 

The table should contain Value and Count fields.   
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Next, you need to add the new usgslandcov.txt file that was created.   
 
Click Tables, Add in the project window. 
 

 
 
The Add Table dialog box will open. In c:\geosfm\glcc, select usgslandcov.txt. List of 

Files of Type: Delimited Text (.txt) should be displayed. Click OK. 
 

 
 
Arrange both tables as seen below. Highlight the common column headers in both tables—

Value in Attributes of usgslandcov and Value in usgslandcov.txt. Make the destination table 
active (adding fields to Attributes of usgslandcov).   

 

 
 

 90



Click the Join icon. The new columns are added to the Attributes of usgslandcov table. 
 
 

 
 
Once the new fields are added to the attribute table, you need to make the added data 

permanent.   
From the Table menu, select Start Editing. 
 

 
 
Then from the Edit menu, select Add field. 
 

 
 
Two fields will be added.   
Field One: 
Name: Lu_Code 
Type: Number 
Width: 3 
Decimal Places: 0  
 

 
 
After Field Definition is populated, click OK. 
Field Two: 
Name: Description 
Type: String 
Width: 50 
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After Field Definition is populated, click OK. 
Next, populate the column values for the new fields by using the Field Calculator icon on 

the tool bar. Click the Field Calculator icon. 
 

 
 
The Field Calculator dialog box opens—double-click [Code] under Fields. 
The calculation is expressed as [Lu_code] = [Code], as seen below. Click OK. 
 

 
 
The new Lu_code field is populated with the same values as the Code field. 
 
Click the Field Calculator again to populate the Description column field. 
 

 
 
The Field Calculator dialog box opens—double-click [Name] under Fields. 
The calculation is expressed as [Description] = [Name]. Click OK. 
The new Description fields are populated with the same values as the Name fields. 
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Next, remove the join leaving Value, Count, Lu_code, and Description fields. 
From the Table menu, select Remove All Joins.   
 
From the Table menu, select Save Edits. Click Yes. 
 

 
 
From the Table menu, select Stop Editing. Click Yes. 
 

 
 
The USGS Land Cover grid can be added to the View when prompted during the Method 

of OverLand Flow Velocity Computation process in the unit hydrograph computation process. 
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Appendix 4: Processing Soil Characteristics 
Create a new folder for DSMW data to be stored in the GeoSFM folder. Download DSMW 

data from the CD into c:\geoSFM\dsmw. The downloaded files are: 
 
1STREAD 
ERDAS 
FAOSOIL 
IDRISI 
RASTEXPN 
VECTOR 
READ1ST.txt 
 
Now you can begin to import the data into an ArcView project for use in GeoSFM. First, 

import the vector files by clicking Start/Programs/ESRI/ArcView 3.2a/Import71, as seen below.   
 

 
 
The vector files are found in the Vector folder where they are listed by 10 different regions. 

The files for the study area in this tutorial are the 10 files for Africa, AFSNTLL.e00 – *.e09. By 
selecting .e00, all files are added. Browse to populate Export Filename: 

  
c:\geoSFM\dsmw\Vector\AFSCNTLL.E00.   
 
Browse to populate the Output Data Source and click OK. 
 

 
 
The Import71 Utility dialog box displays, stating Import Complete. Click OK. 
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Add the AFSCNTLL file to the View using the Add Theme button  from the View 
menu. Change the Data Source Types to Feature Data Source. Click the afscntll file from the 
c:\GeoSFM\dsmw directory and click OK to add to the View.  

 

 
 
Next, convert Afscntll to a shapefile. Select the theme Afscntll so that it appears in a raised 

box.  From the Theme menu, select Convert to Shapefile. 
 

 
 
The Convert Afscntll dialog box appears. Navigate to the c:\GeoSFM\dwms directory and 

name your new shapefile in File Name. Click OK. 
 

 
 
The new shapefile is added below.   
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Next, you need to project the shapefile to Lambert Equal-Area Azumuthal projection.   
Start by activating the Projector! Extension. From the File menu, select Extensions. Scroll 

down to Projector! and click the box to the left to select it. Click OK. 
 

 
 
The tool bar is updated to add the change projection button. 
 

 
 
Click the change projection button to start the projection process. The first dialog box is 

displayed. Select meters from the drop-down list for the output units. Click OK. 
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Next, the Projection Properties box is displayed. Select the Custom radio button. In the 

Projection drop-down list, select Lambert Equal-Area Azimuthal. Change the Central 
Meridian to 20 and the Reference Latitude to 5 for the continent of Africa. 

 

 
 
Click Yes when prompted, Recalculate area, perimeter and length fields (if present) 

using meters? 
 

 
 
Click Yes when asked to Add projected shapefiles as themes to a view. 
 

 
 
Next, select the view where you want the theme added. Select View1 and click OK. 
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Navigate to your directory, and under File Name, name your new projected shapefile. Click 

OK. 
 

 
 
Now you can delete the original africasoil.shp. From the Edit menu, select Delete Theme. 

(Make sure your theme is in a raised box.) 
 

 
 
Before you begin creating the soil depth grid, add the elevations theme to your view. Use 

this theme to define the output grid extent and the cell size. Add the elevations file to the View 

using the Add Theme button  from the View menu. Change the Data Source Types to Grid 
Data Source. Click the elevations file from the c:\GeoSFM\demdata directory and click OK to 
add to the View.  
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Now you can begin to create six different soil characteristic grids; these grids will be 

needed for generating the Basin Characteristics File.   

Soil Depth 

Soil depth will be the first grid created; it is a hydrological active soil layer depth grid. The 
source for this data will be a data set found in NASA Technical Memorandum 4286 (Webb and 
others, 1993). It contains a soil thickness data set with 106 soil types for six continents. The data in 
the Soil Code and Africa columns are required for completing this tutorial. Create a text document 
with two columns of data, as shown below.  

 

 

Populate: 
File name: 
“afsoildepth.txt” 
 
Save as type: 
CSV (Comma      
delimited) (*.csv) 

 
The table is displayed in Notepad. 
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The soil depths in this file are associated with soil types (depicted by soil codes). To map 

the spatial distribution of soil depth, the soil codes must be associated with specific soil polygons 
so that the depths can be transferred to the polygons. The soil polygons for Africa are stored in two 
files, AFRIC1.DAT and AFRIC2.DAT, which are found in the FAOSOIL\DATA folder on the 
DSMW CD. The data in the Faosoil column (4th column) and the Soil Code column (8th column) of 
these two files must be extracted into a new text document.  

 

 

Populate: 
File name: 
“soilcode.txt” 
 
Save as type: 
CSV (Comma 
delimited) (*.csv) 

 
The table is displayed in Notepad. 
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Now add the tables to a View by selecting Tables and clicking the Add button in the 
Project window. First, select the soilcode.txt as seen below. Click OK. 

 

 
 
Open the attribute table of Projafsoil.shp by selecting the Projafsoil theme and clicking the 

Table icon on the tool bar.  
 

 
 
Position the tables as seen below. Highlight the common column headers in both tables—

Faosoil in Attributes of Projafsoil and Faosoil in soilcode.txt. Make the destination table active 
(adding fields to Attributes of Projafsoil.shp).   

 

 
 
Click the Join icon. The new column is added to the Attributes of Projafsoil table. 
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Again, select Tables and click the Add button in the Project window to add the second 
table to the View. This time, select afsoildepth.txt. Click OK.  

Position the tables side by side. Highlight the common column headers in both tables—Soil 
code in Attributes of Projafsoil and Soilcode in afsoildepth.txt. Make the destination table active 
(adding fields to Attributes of Projafsoil.shp).   

Click the Join icon. The new column is added to the Attributes of Projafsoil table. 
Now add a new field to the Attributes of Projafsoil.shp. From the Table menu, select 

Start Editing. 
 

 
  
Then from the Edit menu, select Add Field. 
 

 
 
The Field Definition dialog box opens.   
Populate:  
Name: with the name of your new field 
Type: number 
Width: defaults to 16; changed to 3  
Decimal Places: 0  
 

 
 
Select the calculator icon on the tool bar. 
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The Field Calculator opens. Enter the following calculation:  
[soildepth] = [Africa] 
Click OK. 
 

 
 
The new soildepth field will be populated with the values from the Africa field. 
In the Table menu, select Save Edits to save the changes to the attribute table. Then in the 

Tables menu, select Stop Editing. Create a new grid with the data from the soildepth field. From 
the Theme menu, select Covert to Grid. 

 

 
 
The Convert Projafsoil.shp dialog box opens. Select the c:\geosfm\dsmw directory and 

name your grid in Grid Name. Click OK. 
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The Conversion Extent dialog box opens. In Output Grid Extent, select Same as 
Elevations from the drop-down list. In Output Grid Cell Size, select Same as Elevations. The 
other values will default. Click OK. 

 

 
 
Next, the Conversion Field dialog box opens. In Pick field for cell values, select 

soildepth. Click OK. 
 

 
 
When asked to Add grid as theme to the view, click Yes. 
 

 
 
The new Africa soil depth grid is displayed. 
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Texture 

The second required data layer is the soil texture grid. GeoSFM uses three different texture 
classes (coarse, medium, and fine) for defining basin soil characteristics. The soil texture data set 
used in the model is from Zobler (1986). It is contained in a file named 
FAO_soil.textur.1nnegl.bin, which is stored at the following FTP site: 
ftp://daac.gsfc.nasa.gov/data/inter_disc/hydrology/soil/. The following procedure is needed before 
importing these binary files into ArcView. First, the file is renamed from 
FAO_soil.textur.1nnegl.bin to texture.bil. Next, a header file is created with the following 
parameters:  

 
ncols: the number of columns in the data set 
nrows: the number of  rows in the data set 
xllcorner: the x-coordinate of the center or lower-left corner of the lower-left cell 
yllcorner: the y-coordinate of the center or lower-left corner of the lower-left cell 
cell size: cell size of the data set 
nodata_value: value in the file assigned to cells whose value is unknown. This keyword and 

value is optional. The nodata_value defaults to –9999. 
byteorder: the byte order of the binary cell values. You can choose between two keywords, 

msbfirst or lsbfirst. Msbfirst is used for cell values written with the most significant bit first. 
Lsbfirst is used for cell values written with the least significant bit first. 

 
The parameters needed to populate the new header file can be found in the 

Readme.fao_soil documentation. The parameters of the header file are saved in an ASCII file 
using any simple text editor, such as WordPad, as shown in the example below.   

 

 
 
Save the document. From the File menu, select Save As. 
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File Name: texture.hdr 
Save as Type: Text Document  
Directory: c:\GeoSFM\Zobler 
 
Next, import the texture.bil file. From the File menu, select Import Data Source. 
  

 
 
The Import Data Source dialog box is displayed; from the drop-down list, select Binary 

Raster. Click OK. 
 

 
 
Navigate to your directory and change the List Files of Type to All Files (*.*). Now you 

can select the texture.bil to populate the File Name. Click OK. 
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The Output Grid dialog box opens. Navigate to your directory and name your new grid 
under Grid Name. You are now converting the .bil file to a grid. Click OK. 

   

 
 
Select Yes when prompted to Add grid as theme to the View. 
 

 
 
The new Texturegeo grid is displayed. 
 

 
 
Zoom into the continent of Africa by clicking the zoom icon and putting a box around 

Africa. To accomplish this, click one corner of the area you want to capture, then hold the mouse 
button and drag to the opposite corner, boxing in Africa. See display below.   
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Now set the analysis extent to the display so you can clip the African continent (what is 

captured in our display area) from the global data set. 
From the Analysis menu, select Properties. Select Same As Display from the drop-down 

list to define the Analysis Extent. Use the default values for all other fields. Click OK. 
 

  
 
The Analysis extent is now defined; using the Map Calculator, you can clip the extent 

area from the global data area. To accomplish this, click the Analysis menu and select Map 
Calculator. From here, select the Texturegeo layer. Click Evaluate. 
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The Map Calculation 1 theme is displayed below. You now have a grid of Africa. 
 

 
 
Next, the data set must be transformed from the geographic projection to the Lambert 

Equal-Area Azimuthal projection to match the other data sets used in the GeoSFM. From the 
GeoSFM Utilities menu, select Raindata: ProjectGrid, Geo to Lambert Azimuthal. Normally, 
this function is used for projecting rain and PET data, but you can project any grid except for large 
global data sets. 

 

 
 
In the first window, Specify your working directory is displayed. Click OK. 
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Next, Select the continent for analysis is displayed; from the drop-down list, select Africa. 

Click OK. 
 

 
 
Click Yes when prompted to project the grid to Lambert Equal-Area Azimuthal. 
 

 
 
Use default values for Analysis Properties. Click OK. 
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The last dialog box informs you that the data set will need to be saved. Click OK. 
 

 
 
Before you save the data set, change the cell size to match the cell size of the other data you 

are using. First, add the elevations grid. Click the Add theme icon. Navigate to the demdata 
folder. Change Data Source Types to Grid Data Source and select elevations. Click OK. 

 

 
 
After the elevations theme is added, click the Analysis menu and select Properties. 
   

 

Populate: 
Analysis Extent – 
Same As Map 
Calculation 1 

 
Analysis Cell Size – 

Same As Elevations 
 
Analysis Mask – 

Elevations   

 
Click OK to define the cell size for resampling the Map Calculation 1. From the Analysis 

menu, select Map Calculator. Double-click Map Calculation 1 under layers to populate the 
Evaluate window. Click the Evaluate button. 
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Map Calculation 2 is now projected with a cell size of 1,000.   
 

 
 
Save the data set. From the Theme menu, select Save Data Set. 
  

 
 
Navigate to your working directory and name your new grid. Click OK. 
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Add the projtexture file to the View using the Add Theme button  from the View 
menu. Change the Data Source Types to Grid Data Source. Navigate to your working directory 
and select projtexture. Click OK to add to the View.  

 

 
 
To delete Map Calculation 2, select the theme in your table of contents. Then from the 

Edit menu, select Delete Themes. 
 

 
 
A new projected texture grid is displayed below. 
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Next, you need to convert the seven different texture classes to GeoSFM’s three classes. 
 
To begin this process, you need to work with integers. From the Analysis menu, select the 

Map Calculator. Double-click projtexture to populate the evaluation window and type in the 
following expression exactly as shown:   

 
([Projtexture]) .Int 
 
Click Evaluate. 
 

 
 
Now you are working with values 0–7. —Map Calculation 1. 
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Next, define GeoSFM class 1 as consisting of classes 1 and 2 from the Map Calculation 1 

theme. From the Analysis menu, select Map Calculator and type in the following expression 
exactly as shown:   

 
( [Map Calculation 1] = 1) or ([Map Calculation 1] = 2).Con(1.AsGrid, 0.AsGrid)   
 
Click the Evaluate button. 
 

 
 
Next, define GeoSFM class 2, which is classes 3, 4, and 7 from the Map Calculation 1 

theme. From the Analysis menu, select Map Calculator and type in the following expression 
exactly as shown:   

 
([Map Calculation 1] = 3) or ([Map Calculation 1] = 4) or ([Map Calculation 1] = 

7).Con(2.AsGrid, 0.AsGrid) 
 
Click the Evaluate button. 
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Similarly, define GeoSFM class 3 using class 5 from the Map Calculation 1 theme by 

selecting Map Calculator from the Analysis menu and typing in the following expression and 
clicking the Evaluate button: ( [Map Calculation 1] = 5).Con(3.AsGrid, 0.AsGrid) 

 

  
 
Next, you need to combine the results from Map Calculations 2 and 4 into a single grid with 

two classes. From the Analysis menu, select Map Calculator and type in the expression exactly as 
shown below and click the Evaluate button.  

 
( [Map Calculation 2] = 1).Con([Map Calculation 2],[Map Calculation 4]) 
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As a final calculation, allow the third class to be combined with the previously combined 

grid to create a new grid with all three classes. From the Analysis menu, select Map Calculator 
and type in the following expression exactly as shown and click the Evaluate button. 

 
( [Map Calculation 6] = 0).Con([Map Calculation 5],[Map Calculation 6]) 
 

 
 
Map Calculation 7 is the final grid with the corrected texture classes. To save this data set, 

click Map Calculation 7 to activate the theme in the table of contents. From the Theme menu, 
select Save Data Set. 
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Navigate to your working directory. Type in the grid name, texture, and click OK. 
 

 
 
Final Texture grid is displayed below. 
 

 

Hydraulic Conductivity 

The third soil characteristic grid required is the hydraulic conductivity, Ks. The values are 
assigned based on the seven Zobler texture classes. First, add the projtexture grid used in defining 

the texture classes. Add the projtexture file to the View using the Add Theme button  from 
the View menu. Change the Data Source Types to Grid Data Source. Navigate to your working 
directory and select projtexture. Click OK to add to the View. 
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From the Analysis menu, select the Map Calculator.   
 

 
 
This opens the Map Calculator window. Double-click projtexture to populate the 

evaluation window and type in the following expression exactly as shown and click Evaluate. 
 
([Projtexture]) .Int 
 

 
 
This produces the Map Calculation 1 grid with values 0–7. 
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Ks values (in cm/hr) are assigned based on the seven texture classes in the Zobler (1986) 

data set as follows: 5.076 for coarse, 1.882 for medium/coarse, 1.217 for medium, 1.602 for 
fine/medium, 0.882 for fine, 0.0 for ice, and 1.217 for organic soils. From the Analysis menu, 
select the Map Calculator. Type in the following expression exactly as shown:   

 
( [Map Calculation 1] = 1).Con(5.076.AsGrid, ([Map Calculation 1] = 

2).Con(1.882.AsGrid, ([Map Calculation 1]=3).Con(1.217.AsGrid, ([Map Calculation 
1]=4).Con(1.602.AsGrid, ([Map Calculation 1]=5).Con(0.882.AsGrid, ([Map Calculation 
1]=7).Con(1.217.AsGrid, [Map Calculation 1])))))) 

 

 
 
Once the new grid is created, you can check your data values by selecting both your new 

grid (Ks or Map Calculation 2) and the projtexture or (Map Calculation 1) grid. To select more 
than one Theme at a time, hold down the shift key while making your selections. Click the 
Identify icon and then click a cell in your grid.   
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The Identify Results window will open showing the values. If the Ks grid is highlighted in 

the table, the Ks value will display—1.217 as shown below. If the projtexture or Map 
Calculation 1 is highlighted, then the value is 3. This corresponds with our original table, where 
the texture value 3 has a Ks value of 1.217. 

 

  
 
The Map Calculation 2 grid is the final Ks grid, so we will save this data set. From the 

Theme menu, select Save Data Set. 
 

 
 
Navigate to your working directory and name your new grid Ks. Click OK. 
 

 
 

Add the Ks grid to the View using the Add Theme button  from the View menu. 
Change the Data Source Types to Grid Data Source. Navigate to your working directory and 
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select Ks. Click OK to add to the View. The other Themes can be deleted by selecting the themes 
and then from the Edit menu selecting Delete Themes. Below is the final Ks grid. 

 

 

WHC – Soil Water Holding Capacity  

The next required soil characteristic grid is the soil water holding capacity grid. The source 
for this data will be the SMAXl.ASC file found on the FAO Digital Soil Map of the World CD in 
the FAOSOIL\DATA\folder. The data in this file must be joined to the projafrica.shp file. Begin 
by opening the SMAX1.ASC file in WordPad. Add a line at the top for header information. The 
file contains a record number (RecNum), the mapping unit name (MapUnit), and the soil classes 
(Water, A, B, C, D, E, and F) as shown below. 
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From the File menu, select Save As. Navigate to your directory. 
 
 

 

Populate: 
File name: 

WHC.txt 
Save as type: 

Text Document  
 
 
Next, add the projafsoil.shp file to the View. Add the shapefile to the View using the Add 

Theme button  from the View menu. Change the Data Source Types to Feature Data 
Source. Navigate to your working directory and select projafsoil.shp. Click OK to add to the 
View. 

 

 
 
In View, click projafsoil.shp so it appears in a raised box. Click the Open theme table 

icon. 
 

 
 
Next, you need to add the new whc.txt to the View. From the project window, select Tables 

and click the Add button. Navigate to your working directory and select whc.txt. List Files of 
Type which will need to be Delimited Text (*.txt). Click OK. 
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Arrange both tables as seen below. Highlight the common column headers in both tables—

Faosoil in Attibutes of projafsoil.shp and Mapunit in whc.txt file. Make the destination table 
active (adding fields to Attributes of Projafsoil.shp). 

 

 
 
Click the Join icon; the new columns are added to the Attributes of Projafsoil.shp table. 
 

 
 
Now add a new field to the attribute table. From the Table menu, select Start Editing. 
 

 
 
Then from the Edit menu, select Add Field. 
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The Field Definition box opens. 
Populate: 
Name: whc 
Type: Number 
Width: 5 
Decimal Places: 3 
 

 
 
Click OK. 
Select the calculator icon on the tool bar. 
 

 
 

This will display the Field Calculator; enter the following expression: 
 
(([Water] / 100) * 0) + (([A] / 100) * 250) + (([B] / 100) * 175) + (([C] / 100) * 125) + 

(([D] / 100) * 80) + (([E] / 100) * 40) + (([F] / 100) * 10) 
 
Click OK. 
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The water, A, B, C, D, E, and F values correspond with the soil class values listed in the 

attribute table. The values that are multiplied are the median soil moisture and the total available 
water. After a few moments for processing, the whc values are populated in the new column. 

 

 
 
Next, you will save the edits; from the Table menu select Save Edits. 
 

 
 
The Save Edits dialog box is displayed; click the Yes button. 
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From the Table menu, select Stop Editing. This will end the editing session. 
 

 
 
Set the Analysis extent before you create the new whc grid. Add the elevations grid to the 

View. Add the grid to the View using the Add Theme button  from the View menu. Change 
the Data Source Types to Grid Data Source. Navigate to your working directory and select 
elevations. Click OK to add to the View. 

 

 
 
Now, from the Analysis menu, select Properties. The Properties dialog box is displayed. 
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Populate: 
Analysis Extent: 
 Same As Projafsoil.shp 
Analysis Cell Size: 
 Same As Elevations 

 
Click OK. 
From the Theme menu, select Convert to Grid. 
 

 
 
Navigate to your working directory and type in the Grid Name—whc. Click OK. 
 

 
 
When prompted for Conversion Field, select whc from the drop-down list. Click OK. 
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Click Yes when asked to Add grid as theme to the View. 
 

 
 
The new whc grid is shown below. 
 

 

Maxcover 

The next required soil characteristic grid is the maximum impervious area, maxcover. It is 
the area covered by a wetland or water body in the GLCC data or designated as a stream in the flow 

accumulation grid. Add the grid to the View using the Add Theme button  from the View 
menu. Change the Data Source Types to Grid Data Source. Navigate to the land cover directory 
and select usgslandcov. Click OK to add to the View. 
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Next, add the flow accumulation grid to the View. Add the grid to the View using the Add 

Theme button  from the View menu. Change the Data Source Types to Grid Data Source. 
Navigate to the workspace directory and select flowacc. Click OK to add to the View. 

 

 
 
Next, define the analysis extent. 
 

 

Populate: 
Analysis Extent: 
       Same As Flowacc 
Analysis Cell Size: 
       Same As Flowacc 
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Click OK. Next, select all water bodies and wetland areas from the land cover grid 
including values 16 (Water Bodies), 17 (Herbaceous Wetland), and 18 (Wooded Wetland). From 
the Analysis menu, select the Map Calculator. Type in the following expression exactly as shown 
below and click the Evaluate button:   

 
( [Usgslandcov] = 16).Con(1.AsGrid, ([Usgslandcov] = 17).Con(1.AsGrid, 
([Usgslandcov] = 18).Con(1.AsGrid, 0.AsGrid)))  
 

 
 
This creates Map Calculation 1 with all water body and wetland cells assigned a value of 

1; all other cells are assigned a value of 0. 
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Next, select all cells with a value equal to or greater than 1,000 in the flow accumulation 
grid. These cells are defined as streams in the flow accumulation grid. From the Analysis menu, 
select the Map Calculator. Type in the following expression exactly as shown:   

 
( [Flowacc] >= 1000).Con(1.AsGrid, 0.AsGrid) 
 
Click Evaluate. 
 

 
 
This creates Map Calculation 2 with all stream cells assigned a value of 1; all other cells 

are assigned a value of 0.   
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The next calculation combines the water body, wetland, and stream cells into one grid. 
From the Analysis menu, select the Map Calculator. Type in the following expression exactly as 
shown:    

 
( [Map Calculation 1] = 0).Con([Map Calculation 2], [Map Calculation 1]) 
 
Click Evaluate. 
 

 
 
You have created a grid with all water bodies, wetlands, and streams assigned a cell value 

of 1. All other cell values are assigned a value of 0. 
 

 
 
Save the new grid; from the Theme menu, select Save Data Set. 
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Navigate to your directory; name your grid maxcover in Grid Name. Click OK. 
 

 
 
Delete the themes you no longer need from the table of contents. From the Edit menu, 

select Delete Themes. 
 

 
 
Add the new maxcover grid to the View. Add the grid to the View using the Add Theme 

button  from the View menu. Change the Data Source Types to Grid Data Source. Navigate 
to your dsmw directory and select maxcover. Click OK to add to the View. 
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Below is the final maxcover grid. 
 

 

RCN 

The last required soil characteristic grid is the Soil Conservation Service (SCS) runoff curve 
number (RCN) grid. SCS is the former name of the U.S. Department of Agriculture Natural 
Resources Conservation Service (NRCS). The runoff curve numbers are estimated from land cover 
classes and hydraulic soil groups. First, add the land cover grid. Add the grid to the View using the 

Add Theme button  from the View menu. Change the Data Source Types to Grid Data 
Source. Navigate to the land cover directory and select usgslandcov. Click OK to add to the View. 

 

 

 135



Then add the protexture grid. Add the grid to the View using the Add Theme button  
from the View menu. Change the Data Source Types to Grid Data Source. Navigate to your 
directory and select projtexture. Click OK to add to the View. 

 

 
 
After you have added the landcover and projected texture grids to the View, set the 

Analysis Extent. From the Analysis menu, select Properties. The Analysis Properties dialog box 
will be displayed. 

 

 

Populate: 
Analysis Extent: 
      Same As Usgslandcov 
Analysis Cell Size: 
      Same As Usgslandcov 

 
To begin this process you need to work with integers. From the Analysis menu, select the 

Map Calculator.   
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This opens the Map Calculator window. Double-click projtexture to populate the 

evaluation window. Type in the following expression exactly as shown:  
 
([Projtexture]) .Int 
 
Click Evaluate. 
 

 
 
This produces the Map Calculation 1 grid with values 0–7. 
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Next, create a soil hydraulic class grid. A text file, “texture.txt,” containing the texture 

classes is required. This file was created earlier in this tutorial. Add the new texture.txt to the 
View. From the project window, select Tables and then click the Add button. Navigate to your 
working directory and select texture.txt. List Files of Type is set to Delimited Text (*.txt). Click 
OK. 

 

 
 
Join the texture.txt to the attribute table of Map Calculation 1. In the View click the Map 

Calculation 1 theme so it appears in a raised box, then click the Open theme table icon. Arrange 
tables side by side. Highlight the common column headers in both tables—Value in Attributes of 
Map Calculation 1 and Index in the texture.txt file. Make the destination table active (adding 
fields to Attributes of Map Calculation 1). 
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Click the Join icon. The new columns are added to the Attributes of Map Calculation 1 
table. 

 

 
 
Now you can create a grid of the Numeric soil hydraulic classes. From the Analysis menu, 

select the Map Calculator. Type in the following expression exactly as shown: 
 
( [Map Calculation 1 . Numeric soil hydraulic class]) 
 
Click Evaluate. 
 

 
 
The created grid is displayed below with values of 0, 88, 89, 90, and 91. 
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Save this data set; from the Theme menu, select Save Data Set. Navigate to your directory 

and name your new grid—soilhyd. Click OK. 
 

 
 
Now you can delete all themes except for the usgslandcover grid; from the Edit menu, 

select Delete Themes. Make sure the themes you want deleted are selected in a raised box. Now 
add the new soilhyd grid to the View. Create four grids for each Soil Hydraulic class (A, B, C, and 
D) with the RCN values for the landcover classes. The Hyd_a_mean field in the usgslandcov 
attributes table indicates the RCN values for soil hydraulic class “A,” Hyd_b_mean for soil 
hydraulic class “B,” Hyd_c_mean for soil hydraulic class “C,” and Hyd_d_mean for soil 
hydraulic class “D.” If the attribute table does not contain these Hyd_a–d_mean values, one has 
been created for you in the GeoSFM/Samples directory with the file name “rcn.txt.” 
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Add the new rcn.txt to the View. From the project window, select Tables and then click the 
Add button. Navigate to your working directory and select rcn.txt. List Files of Type is set to 
Delimited Text (*.txt). Click OK. 

Arrange the tables side by side. Highlight the common column headers in both tables—
Value in Attibutes of Usgslandcov and nlucode in the rcn.txt file. Make the destination table 
active (adding fields to Attributes of Usgslandcov). Click the Join icon; the new columns are 
added to the Attributes of Usgslandcov table. 

Next, create four separate grids for each of the soil classes. The first grid will capture all the 
Hyd_a_mean values. From the Analysis menu, select the Map Calculator. Type in the following 
expression exactly as shown:  

 
([Usgslandcov.Hyd_a_mean])   

 
You can double-click the field under Layers to populate the evaluation area. Click Evaluate. 
 

 
 
Save your new data set; from the Theme menu, select Save Data Set. 
 

  
 
Navigate to your working directory and type a_rcn in the Grid Name. Click OK. 
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Repeat this process for the remaining three grids. The second grid will capture the 

Hyd_b_mean values and be saved as b_rcn. The third grid will capture the Hyd_c_mean values 
and be saved as c_rcn. The last grid will capture the Hyd_d_mean values and be saved as d_rcn. 
Delete all the Map Calculation 1–4 grids, and add the newly created a_rcn, b_rcn, c_rcn, and 
d_rcn grids. You can select more than one grid by holding down the shift key while selecting. Add 

the grids to the View using the Add Theme button  from the View menu. Change the Data 
Source Types to Grid Data Source. Navigate to your directory and select the four grids. Click OK 
to add to the View. 

 

 
 
The next step is to combine the grids into one final rcn grid. From the Analysis menu, select 

the Map Calculator. Type in the following expression exactly as shown below and click Evaluate. 
 

([Soilhyd]=88).con([A_rcn],([Soilhyd]=89).con([B_rcn],([Soilhyd]=90).con([C_rcn],([S
oilhyd]= 91).con([D_rcn], 0.AsGrid)))) 
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Save your new data set, from the Theme menu, select Save Data Set. 
 

  
 
Navigate to your working directory and type rcn in the Grid Name box. Click OK. 
 

 
 
You can now delete all the themes in the View and add your new rcn grid as seen below. 
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All of the soil characteristic grids have been created. Now the soil grids can be added to the 

View when prompted during the Creating Basin Characteristics process. 
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Appendix 5: Creating Reservoir and Gauge Rating Files 
Reservoir characteristics files (reservoir.txt) are created whenever dams are present on a 

river or stream within the basin being analyzed. A dam insertion utility is included in GeoSFM for 
this purpose. On the View Toolbar, click the dam icon to select it. 

 

 
 
In the View window, position your mouse on the stream containing the dam. Left-click your 

mouse and a Dams shapefile will be added to your project. In the first dialog box displayed, select 
basply.shp from the drop-down list. Click OK. 

 

 
 
In the Key Field dialog box, select Gridcode. 
 

 
 
Next, enter the reservoir parameters. The Dam ID will populate with the Basin ID of the 

selected point on the stream. The Storage value is needed along with the Residence Time in days. 
The Operated field is populated with either a 0 or 1 depending on a user-defined file. (0 if no file, 
1 if there is a file.) If the file is needed, the file path and name will be populated in the Operation 
FileName field. Click OK. 
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The dam is added to the View. This process will create a reservoir.txt file. 
 

 
 
It may also be necessary to insert a stream gauge into the model for Muskingum Cunge 

computations. If you need to input streamflow data from stream gauges, the data will need to be in 
a format as in the file below. The first column header is BasinID, starting with the most 
downstream basin. The next column header is Type, which will be populated with either a 1 or 2 
depending on the type of rating equation being used. The next three column headers are the three 
different equation parameters—Par1, Par2, and Par3. The last column is hmax, which is populated 
with the maximum flow height where the equation is valid. Create the file using Microsoft Excel 
spreadsheet software.   

A sample rating file is shown below. 
 

 
 
To save the file, select File and Save As.  
File name: “rating.txt” 
Save as type: CSV (Comma delimited) (*.csv). 
  

 
 
Enclosing the file name (rating.txt) in quotation marks ensures that the rating file will 

retain the specified file name when it is stored as a comma delimited file for subsequent use by the 
Muskingum Cunge program. 
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