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What’s New in Coulomb 3.3 
 

• New Menu Features 
 
“.inp” (rt.lat/reverse slip) and “.inr” (rake/net slip) input file options to define source and receiver faults 
  
Coulomb now outputs to GMT using a command window plug-in script. 
 

You can now digitize a fault from an image and quickly bring it into Coulomb. 
 

Fault elements are now numbered, so it is easy to find the one you want to change. The number is located at 
the "start" end, so you can also more easily confirm the dip polarity is correct. These identification numbers 
can be turned off in the Preferences menu. 
 

In making A-B cross sections, A no longer needs to be to the left of B. The cross-section parameters are 
saved; you can read them from the cross-section dialog box. 
 

For “3D View” images with slip scaled by a color, you can change the color saturation on the fly. 
 

Both horizontal and vertical GPS displacements can be plotted, with station identification numbers.  
 

Coulomb now reads the fault element lines in the input file rather than using "#fixed," in the .inp. 
 

Once the grid size or calculation depth is changed from FunctionsChange parameters menu, the 2D (2-
dimensional) map image is automatically refreshed.  
 

You can now taper or subdivide a fault on the fly by clicking on it in map view, which brings up the 
"Change parameters" menu. 
 

Coulomb now launches quickly without accessing the web database. 
 
When calculating stress on nodal planes, you can now plot the the stress change for the plane in each pair 
that is most positive or most negative, and you can save the graphic as a raster or vector image. 
 
• New Plug-in Functions  (scripts that you type into the MATLAB Command Window) 
 

digitize_faults: This allows you to quickly but accurately digitize active faults and other elements from a 
.jpeg or .png image with a graphical user interface. The saved text file can be read from the 
OverlayActive faults menu in Coulomb. 
 

another_overlay: If the map is changed to "lon & lat" format, simply draw lines on the main graphic 
window. This is useful to superimpose another fault database, country borders, and so on. User can set the 
line color and line width by an input dialog. 
 

more_overlay_plot: This enables you to add numerous active fault files or other overlay material that has 
been saved as a text file.  
 

coulomb2gmt_source: This code converts the source fault image (as vector data) into the GMT formatted 
line data. It saves the files, "gmt_fault_calc_depth.data",  "gmt_fault_map_proj.data" 
and "gmt_fault_surface.data". 
 

coulomb2gmt_cout: This converts the calculated Coulomb matrix data into the gmt text column data (lon, 
lat, Coulomb stress change), so that it can be plotted in GMT draped over a DEM as a raster image. It saves 
a file named "coulomb_out.dat" 
 

seis_rate_change: This allows you to read in a seismic catalog, choose the minimum magnitude (for 
example, Mc), select a smoothing radius, identify the date and time of the event (for example, a large 
earthquake), and then calculate the seismicity rate change associated with the event, with colors scaled by 
log (new rate/old rate). Two maps are produced, one to show the seismicity rate where it is defined, and the 
other to show the undefined areas. Earthquakes can be overlaid on the map. 
 
Now changes to the Preferences are saved on the fly; you no longer have to quit and relaunch. 
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Chapter 1   
 

Introduction 
 
1.1  Why Coulomb? The Rationale and Philosophy of This Program 
 
Coulomb is intended both for publication-directed research and for college and graduate school classroom 
instruction. We believe that one learns best when one can see the most and can explore alternatives quickly. 
So the principal feature of Coulomb is ease of input, rapid interactive modification, and intuitive 
visualization of the results. The program has menus and check-items, and dialogue boxes to ease operation. 
The internal graphics are suitable for publication, and can be easily imported into Illustrator, GMT, Google 
Earth, or Flash for further enhancements.  

Coulomb is designed to let one calculate static displacements, strains, and stresses at any depth caused by 
fault slip, magmatic intrusion, or dike expansion/contraction. One can calculate static displacements (on a 
surface or at GPS stations), strains, and stresses caused by fault slip, magmatic intrusion, or dike expansion. 
Problems, such as how an earthquake promotes or inhibits failure on nearby faults, or how fault slip or dike 
expansion will compress a nearby magma chamber, are germane to Coulomb. Geologic deformation 
associated with strike-slip faults, normal faults, or fault-bend folds is also a useful application. Calculations 
are made in an elastic halfspace with uniform isotropic elastic properties following Okada (1992)—see list 
of key papers in section 1.9.  

There is substantial evidence to support the hypothesis that faults interact by the transfer of stress, both on 
the time scales of earthquake sequences and aftershocks and on longer time scales associated with the 
interevent time of the largest shocks that occur in a given region. There is also evidence that faults and 
magmatic systems interact as well, and that static stress changes influence intrusions and eruptions. 
Processes not included in Coulomb are also important, such as dynamic stresses, pore-fluid diffusion, and 
viscoelastic rebound. Further, elastic stiffness differences between basins and crustal layering modify the 
stresses in comparison to the elastic halfspace implemented in Coulomb. Nevertheless, we believe that a 
simple tool that permits exploration of a key component of earthquake interaction has great value for 
understanding and discovery. 
 
 
1.2 Hardware/software requirements: 
• Macintosh OSX, Windows PC, or UNIX computer 
• MATLAB 7.4 or higher is required. There are a few MATLAB functions that work on PCs but not 

Macs. MATLAB 7.5 is not advised; it is full of bugs; there are strain problems with MATLAB 7.4. 
• A color monitor of at least 600 x 400 pixel resolution. A laptop screen is fine. 
• A text editor to modify ascii input files, and a spreadsheet to read tab-delimited text files. Some output 

files are created as .csv (Excel-friendly) files. Use a text editor that allows you to distinguish spaces 
from tabs, such as BBEdit (BBEdit Lite is free from http://www.barebones.com/) or Notepad on a 
Windows PC. Use a nonkerning (uniform-spacing) font, such as Monaco, so that numbers stay aligned. 

 
1.3 Recommended extras: 
• A vector illustration program, such as Adobe Illustrator, is strongly recommended. 
• Google Earth (which is free) 
 
1.4  Users Guide Alerts 
1. Important warnings in the manual are printed in red 
2. The images used in the manual to show you what you will see on the screen were captured at low 

resolution (72 dpi). But don’t worry: you will save full-resolution vector files. 
 

http://www.barebones.com/
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1.5 Help menu 
This can be useful; there is a search command, but unlike this Guide, we have not kept it current. 
 
1.6  Cover images 
The full-page cover was designed by Serkan Bozkurt (now at AMEC/Geomatrix) by importing Coulomb 
numerical output into ArcGIS. All of the images on the inside covers were made exclusively from Coulomb 
3.3. 
 
1.7  Acknowledgments 
We thank many users for testing the functions, finding errors, and suggesting improvements. We are 
particularly grateful to Chris Rollins (University of Southern California) and Gavin Hayes (U.S. Geological 
Survey, National Earthquake Information Center). 
 
1.8   Some useful papers that explain and explore the Coulomb hypothesis  

 
(Most are downloadable from http://profile.usgs.gov/rstein) 

 
Introduction without jargon or math: 
 
 Stein, R.S., 2003, Earthquake conversations: Scientific American, v. 288, no. 1, p, 72-79.  
 
Key review papers: 
 

Harris, R.A., 1998, Introduction to special section—Stress triggers, stress shadows, and 
implications for seismic hazard: Journal of Geophysical Research, v. 103, p. 24,347–24,358. 
 
Stein, R.S., 1999, The role of stress transfer in earthquake occurrence: Nature, v. 402, p. 605–609. 
King, G.C.P., and Cocco, M., 2000, Fault interaction by elastic stress changes; new clues from 
earthquake sequences: Advances in Geophysics, v. 44, p. 1–36.  
 
Freed, A., 2005, Earthquake triggering by static, dynamic, and postseismic stress transfer: Annual 
Revue of Earth and Planetary Sciences, v. 33, p. 335–67, doi: 10.1146/annurev.earth.33 
.092203.122505 
 
Steacy, S., Gomberg, J., and Cocco, M., 2005, Introduction to special section—Stress transfer, 
earthquake triggering, and time-dependent seismic hazard: Journal of Geophysical Research, v. 
110, p. B05S01, doi:10.1029/2005JB003692. 

 
Coulomb stress change concepts (for strike-slip faults): 
 
 King, G.C.P., Stein, R.S., and Lin, J., 1994, Static stress changes and the triggering of 

earthquakes: Bulletin of the  Seismological Society of America, v. 84, no. 3, p. 935-953. 
 
 
Coulomb stress concepts (for thrust faults and interaction between thrust and strike-slip faults): 
 

T. Parsons, T., R.S. Stein, R. W. Simpson and P.A. Reasenberg, 1999, Stress sensitivity of fault 
seismicity; a comparison between limited-offset oblique and major strike-slip faults: Journal of  
Geophysical Research, v. 104, p. 20183-20202. 

 
 Lin, J., and Stein, R.S., 2004, Stress triggering in thrust and subduction earthquakes, and stress 

interaction between the southern San Andreas and nearby thrust and strike-slip faults: Journal of 
Geophysical Reearch, v. 109, p. B02303, doi:10.1029/2003JB002607. 

 

http://profile.usgs.gov/rstein
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Coulomb stress calculated on earthquake nodal planes 
 

Toda, S., J. Lin, and R.S. Stein, 2011, Using the 2011 M=9.0 Tohoku earthquake to test the 
Coulomb stress triggering hypothesis and to calculate faults brought closer to failure: Earth 
Planets Space, in press. 

 
Ma, K.F., C.H. Chan and R. S. Stein, 2005, Response of seismicity to Coulomb stress triggers and 
shadows of the 1999 Mw = 7.6 Chi-Chi, Taiwan, earthquake: Journal of Geophysical Research, 
Vol. 110, B05S19, doi:10.1029/2004JB003389. 

 
Dislocation solution formulae: 
 
 Okada, Y., 1992, Internal deformation due to shear and tensile faults in a half-space: Bulletin of 

the Seismological Society of America, v. 82, no. 2, p. 1018-1040. 
 
Application of Coulomb to seismic hazard: 
 
 Toda, S., Stein, R.S., Reasenberg, P.A., and Dieterich, J.H., 1998, Stress transferred by the 

Mw=6.5 Kobe, Japan, shock; effect on aftershocks and future earthquake probabilities: Journal 
of Geophysical Research, v. 103, p. 24,543-24,565. 

 
 Toda, S., and R.S. Stein, R.S., 2002, Response of the San Andreas fault to the 1983 Coalinga-

Nuñez Earthquakes; an application of interaction-based probabilities for Parkfield: Journal of 
Geophysical Research, v. 107, p. 10.1029/2001JB000172. 

 
Toda, S., Stein, R.S., Richards-Dinger, K., and Bozkurt, S., 2005, Forecasting the evolution of 
seismicity in southern California—animations built on earthquake stress transfer: Journal 
of Geophysical Research, v. 110, p. B05S16, doi:10.1029/2004JB003415. 

 
Application of Coulomb to dike inflation: 
 
 Toda, S., Stein, R.S., and Sagiya, T., 2002, Evidence from the 2000 Izu Islands swarm that 

seismicity is governed by stressing rate: Nature, v. 419, p. 58-61. 
 
Application of Coulomb to earthquake-volcano interaction: 
 

Nostro, C., Stein, R.S., Cocco, M., Belardinelli, M.E., and Marzocchi, W., 1998, Two-way 
coupling between Vesuvius eruptions and southern Apennine earthquakes (Italy) by elastic stress 
transfer: Journal of Geophysical Research, v. 103, p. 24,487-24,504.  
 

Other papers cited in the User Guide: 
 

Aki, K., and P. G. Richards, 1980, Quantitative Seismology, 932 pp., W.H. Freeman & Co., New 
York. 
 
Wells, D. L., and K. J. Coppersmith, 1994, New empirical relationships among magnitude, rupture 
length, rupture width, rupture area, and surface displacement: Bulletin of the Seismological 
Society of America, v. 84, p. 974-1002. 
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Chapter 2 
 

The Keys to the City, and a Quick Tour 
 
2.1 The most important things about Coulomb in one page! 
 

 
 
• Source vs. receiver faults (Section 3.1) 

Sources have slip and impart stress; receivers do not have slip and receive stress 
 
• Coulomb failure hypothesis, Δσ f = Δτs + µ’ Δσn  (7.1) 

Failure is promoted when Δσ f or ΔCFF on the receiver fault caused by slip on the source fault(s) 
increases. Δτs is the shear stress change (positive in the direction of receiver fault slip), Δσn is 
normal stress change (positive when the receiver fault is unclamped), and µ’ is the effective fault 
friction coefficient on the receiver fault. 

 
• How faults are defined in the input files  (4.1) 

Right-hand rule for start/fin points, positive dip, rt-lat/reverse (m) or rake°/net slip(m). 
 
• Coulomb stress on specified vs. optimally oriented planes (7.1) 
  Assumed slip directions vs. regional stress field; visualizing slip lines, principal axes. 
 
• Coulomb and MATLAB Figures  (5.4) 
  “dead” editable vector .pdf files vs. “live” MATLAB 3D .fig files that can be spun. 
 
 •  “inp” vs. “mat” input files  (5.2) 
  .inp is editable text; .mat is a binary file, but can include fault and quake overlays 
 
• Keep an eye on the command window  
  For calculation progress, input/output file names, input source moment, error reports. 

• Start simple, and add complexity if needed later  
Start with idealized faults and develop intuition about the problem.  

 
• For classroom instruction, use Cartesian coordinates unless you want to use overlays  

It‘s quicker and easier. 

• How receivers are defined  (7.2) 
  Specified faults via Aki-Richards, subdivided receivers, CMTs, and nodal planes: 
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2.2 A quick tour of Coulomb 3.3 
 
Here we just want you to learn the procedure to display and output graphics, and to save the results. We 
always recommend that you save all your current working documents frequently to prevent lost of files in 
the event of program crashes. 
 
Menus and their pull-down items turn from light white to black as they become options. Here is the 
procedure to lunch Coulomb: 
 

      
 

1. Launch MATLAB on your computer. In the MATLAB menu bar top line, click on the  icon to 
browse to the location of the “Coulomb 3.3 folder” in your computer. In the example shown below, the 
“Coulomb 3.3 folder“ has a path of “/Users/jlin/Desktop/Coulomb folder”. 

 

 
 
2. In the MATLAB Command Window, type “coulomb”. Coulomb will take 10 seconds or so to launch. 

Check the Coulomb website to check that you have the latest version. We recommend that you always 
migrate to the latest version.  

 

 
 
3. Choose Input > Preferences. Colors, line widths, the “color map” (color gradient maps), and the 

output file folder can all be changed. For input files with lat/lon information, you can also choose to 
plot maps with lat/lon rather than km frame tics. For now, leave them in the default setting. Note that 
“Fault” refers to the source or receiver faults. Fault ID numbers can be unchecked. For volcanoes, 
“point” controls the size the triangles. Changing the Grid point size to 0 removes the grid lines for 
plots with many overlays, as you see on the right below. 
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4. In the pop-up Coulomb 3.3 window, choose Input > Open existing input file. In the pop-up Open 

input file window, change to sub-directory “input_files”. Choose the “Example-2(LL)_lonlat.inp” from 
the dialog box, then hit <rtrn>. The program will automatically plot the 2D map view of the Grid 
menu in Functions.  

 
5. Once you release the mouse button, the calculation is performed and the program displays the result in 

the Coulomb 3.3 window. It’s a simple grid with a NE-striking fault in the middle of the grid, as shown 
below. The bottom right corner also shows the version of the Coulomb program you are using, current 
date/time, name of the input file you are using, type of calculation for the image, and the calculation 
depth. 

 

          
 
6. Now try Functions > 3D grid, and play with the zoom  and swivel  tools. If you want to save 

this image, choose File > Save As. Rename the file in the dialog box, and save it as a figure of one of 
the several types. Do not use “main_menu_window.fig” as the filename. 

 
7. You also have the options to Zoom In, Zoom Out, Pan, and Rotate your image by clicking on the 

lower line on the Coulomb 3.3 menu bar. You can also perform these operations by choosing items in 
the Tools pull-down menu. 

 
8. If you click Functions > Displacements, in addition to making an image on your Coulomb 3.3 

window, a numerical output file called “Displacement.cou” will appear in the sub-folder you 
designated in the Preferences menu. Similarly, if you click Functions > Stress, a text output file called 
“dcff.cou” will be created and can be opened in Excel. 

 
9. To close the Coulomb 3.3 window, click Input > Quit. Do not quit out of MATLAB if you want to 

continue with Coulonb. (If you wanted to quit MATLAB program, type “exit” in the MATLAB 
Command Window.) 
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Chapter 3   
 
Concepts, Dimensions, and Sign Conventions 
 
This chapter briefly explains the things you should understand to use the software correctly. 
 
3.1 The crucial concept of source and receiver faults 
Source faults have slip, and so they impart stress to the surrounding crust and faults. 
Receiver faults (almost always) have no slip (slip=0.0 m in the input files). Source and receiver 
faults otherwise look identical in the input files. The stresses imparted by source faults are 
resolved on the receiver faults through the command Functions > Stress > Calc. stress on faults. 
Further options for resolving the stress on the receiver fault are controlled by the Stress on faults 
control panel, which automatically appears.  
 
3.2  Calculation procedure 
1. Launch MATLAB; set the MATLAB path to working directory “Coulomb 3.3 folder”. 
2. Type “coulomb” in MATLAB Command Window. 
3. In Coulomb 3.3 window menu bar, choose Input> Open existing input file. 
4. In Coulomb 3.3 window menu bar, choose Functions > Grid, Displacements, Strain, or 

Stress. Many of these selections trigger requests for additional input and let you modify the 
parameters in temporary windows. When you click “Calc. & view”, calculations are 
performed and a new image is displayed. 

5. You can perform many operations to the image on the Coulomb 3.3 window, including 
Zoom In, Zoom Out, Pan, Rotate 3D, Data Cursor, Insert Color Bar, Insert Color Legend. 
You can choose these operations either by clicking the lower menu in the Coulomb 3.3 
window or the Tools pull down menu bar. While the graphic plot is open, you save this plot. 

6. To print a plot, save it as a pdf and then print the small vector file from Acrobat Reader or an 
illustration program. The File > Print cmd in MATLAB does not work properly. 

7. After you have finished all calculations, quit MATLAB.   
 
3.3  To change parameters interactively 
Most of the settings and parameters can be changed either by modifying an input file using a text 
editor or by changing them interactively within Coulomb. Choose Functions > Change 
parameters. Parameters changed within the software interactively are transient and will not 
permanently modify the input file. Every time you select Input > Save input file, all current 
selections will be saved in an input file. Change the name of the file if you do not want it 
overwritten. 
 
3.4  To save, print, or modify a plot 
Choose File > Save A. We recommend you choose eps, a compact vector format; generally 
quality is lower when saved as pdf. Rename the file from the default “main_menu_window.fig” 
or it will overwrite an important file. You then print the pdf from Preview (Mac) or Acrobat Reader, 
or from an illustration program if you would like to spruce it up.  
 
 
3.5  Coordinates, units, and sign conventions 
Coulomb 3.3 calculates in the (x, y, z) Cartesian coordinate system. When the lat/lon of the corner 
grid points are specified in the input file, it can also plot in lat/lon. In the map view projection on 
the monitor, x is positive from left to right, y is positive from bottom to top, z is positive upwards 
for displacement. DEPTH is positive downwards from the Earth’s surface. We use the standard 
Aki and  Richards (1980, 2002) sign conventions for fault geometry and slip.  
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Input parameters and their dimensions (think bars and meters) 
 
PR1    Poisson’s ratio: dimensionless, -1 to 0.5; 0.25 is typically used. 0.5 is an incompressible 
volume, and so can be used to make “balanced cross-sections” of structural geology. 
E1  Young’s modulus: [bars]; 8x105 bars is typically used. 
FRIC Friction coefficient: [dimensionless; roughly 0-1]; 0.4 is often used; 0.65 is for dry 
Byerlee’s law friction, 0.0-1.0 is typically considered the limits for the crust. 
Sym Obsolete legacy from Coulomb 1.0; ignore it 
 
Directions, angle, and dip: [degrees; dip must be positive!!] 
Grid and fault positions (x, y): [km] 
Depth: [km] downward is positive 
Displacements: [m] 
Faults: Right-lateral is positive, and reverse slip is positive [m] 
Dikes: Opening displacement is positive [m] 
Point Source: Inflation is positive [m3] 
Regional stress tensor, S1, S2, S3: positive in compression [bars] 
 
Output parameters and their dimensions 
 

Displacement: [m] North, East, and Up are positive 
Shear Strain: [dimensionless] Right-lateral is positive 
Principal Strain: [dimensionless] Extension is positive (tensor notation) 
Dilatational Strain: [dimensionless] Dilatation is positive 
Stress: [bars] Right-lateral and unclamping are positive 

 
 
Shear modulus, G.  Young’s modulus [E] and Poisson’s Ratio [PR] are specified in the input file. 

G = E/[2(1+PR)]. So the shear modulus G for PR=0.25 and E=8x105 bars, is 3.3x105 bars or 
3.3x1011 dyne-cm-2.  
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Chapter 4   
 

Building Input Files 
 
All Coulomb calculations require input files; some require successive information for which you will be 
prompted. If an input file is improperly formatted (for example, it has tabs, or the number of faults is 
inconsistent with the “#fixed=“, a warning dialog will appear, but the input file will still be correctly read. 
If it is a text (.inp) file, you must modify the input using text editor. If it is a binary (.mat) file you cannot 
use it. You can also create an input file interactively or modify an existing file in Coulomb. Open this input 
file in a text editor: 
 

 
 
All numbers need a decimal point, except for the line starting “#reg1=” and the first three characters of the 
source parameters marked “#”. All format statements are shown at the end of this chapter. Right-lateral and 
reverse slip are reckoned positive (negative values denote left-lateral and normal slip); dip must always be 
positive. “#reg2=” is an obsolete inheritance from Coulomb 1.0; ignore it. 
 
4.1 “.inp” (rt.lat/reverse slip) and “.inr” (rake/net slip) input file options 
There are two input formats. The first (.inp) specifies the source slip by right-lateral and reverse slip (left 
lateral or normal slip are negative). The second is an alternate (.inr) input format specifies rake (°) and net 
slip, which permits one to calculate the stress change on receivers (faults without slip) in their rake 
directions, where, for example, a left-lat. stress increase would inhibit failure on a right-lateral fault. Try 
Input > Open & edit input file > “Example-2(LL)rake.inr” to see this: 
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Note that the fault element ID, “1” appears at the ‘start” corner of each fault. 

 
4.2 Structure and format for input files 
An input file is composed of parameters for the halfspace, an optional regional stress field used only in one 
kind of Coulomb stress calculation, source fault positions and slip, receiver fault positions, grid 
information, graphical representation, and optional cross section and lat/lon information. See the figure, 
‘structure and formats of Input file”, which annotates the entries. When making or modifying input files, 
use a non-kerning (uniform-spacing) font, such as Monaco, so that all numbers align under the xxxxxxxx 
headers.  
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4.3 Working in lat/lon coordinates 
Coulomb can read and display lat/lon’s if you include the lat/lon of the grid borders and the (0, 0 km) point 
in the input file, as seen here from “Example-SFBayArea.inp” 

 
 

If you have lat/lon information for a source, you can convert it to Coulomb (x, y) input format by selecting 
Functions > Tools > Convert lat/lon to Cartesian, which brings up a calculator window. 
 
 
4.4 To open, display and modify existing input file interactively 
1. Input > Open existing input file > Example-2(LL)-lonlat.inp in the “input_files” sub-folder within 

the “Coulomb 3.3” folder. 
2. The graphic on the left below appears in the Coulomb 3.3 window. You can see the undistorted grid 

(yellow) and the surface projection of the source fault (green). 
 

    
 

3. To show the same plot with lat/lon tic marks, put the cursor on the frame numbers and make a right 
mouse-click (above right). Choose “change coordinates” and make a left mouse-click. Alternatively, 
from the menu, Input > Preferences and change Coordinates from “Cartesian to Lon. & Lat.”, click 
OK, and then choose Input > Open most recent input file.  

4. To modify, subdivide, or tile a source or receiver fault, click on the fault with the right mouse-click, 
and it will open the “change fault params” window (below left). You can do the same thing to the blue 
study area border to change the study area boundaries. If you have multiple faults or a variable slip 
model, you can see the total seismic moment of all patches in the Command window. 
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4.5  To display the undistorted grid in 3D view 
1. Choose Functions > Grid > 3D view. The graphic above right appears in the Coulomb 3.3 window. 

You can see the undistorted grid in 3D view (yellow) and the fault patches colored by their input slip. 
You can color the slip by its components, change the color saturation in the Slip menu, and change the 
viewing angle by clicking on the swivel tool.  

 
4.6 Editing existing input files within Coulomb  
Choose Input > Open & Edit Input File. The “All input parameters”_window will appear as shown 
below. You can modify all values without any formatting worries. If the “Total number of faults” is greater 
than 1, enter the order number of a specific fault patch that you wish to modify below “#”. Then click 
“OK”, properties of that particular source will appear. 
 

 
 
4.7 Modifying an existing file in a text editor 
1. Click one of the example files we prepared for tutorials. 
2. To duplicate it, type “d” holding command key (command + D), or drag the icon holding option key, 

and rename it.  
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3. Launch an editor and open the file using File > Open (command + O). 
4. Use a non-kerning font, such as Monaco or Courier. Change the numbers you want, checking the units 

and format. To add source or receiver faults, add a new row. Use your editor’s ”show invisibles” 
option to make sure that there are no tabs. Save the file. 

 
4.8 Building an input file from a simple X,Y map 
To build an input file from map, you can select from menu Input > Build Input File from x & y Map; 
you can add as many faults as you like. You can add lon/lat information of your study area by clicking the 
“Add lon.lat. info” button in the “Grid input setting” window.  Don’t worry about the regional stresses for 
now. 

 

            
 
Note that you must close the above cursor message at left before specifying a fault on the following map. 
Click “OK” and the fault color will turn to green. 
 
4.9 Tapering a source fault and subdividing the slip on a source or receiver 
Tapered Slip. To remove unrealistic stress concentrations at the edges of a fault, you can taper the slip in 
Coulomb. Choose Input > Open an existing file and choose “Example-2(TH).inp”. Then right-click on the 
fault frame and hit the “Taper/Subdivide” button (or choose Functions > Tools > Taper or subdivide 
fault slip). When the “Element input panel” appears, choose “Linear tapering”. The tapered slip is built by 
nested rectangles. Choose 10 km along strike, 5 km downdip, and 5 nested patches, and hit OK. Save the 
tapered input file by Input > Save input file as ascii with a new name. In an editor you’ll see the 5 nested 
coplanar sources, as shown below. The tapered fault has the same moment as its uniform-slip version. 
 

 
Notice that the patches get successively smaller on down the list, and that each patch has the same slip. The 
larger the number of patches, the smoother the stress. The patches with their ID numbers are shown below. 
 
                            Tapered slip (for sources only)                Subdivided slip (for sources and 
receivers) 
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Splitting or subdividing a source or receiver. As you did before, choose Input > Open an existing 
file and choose “Example-2(TH).inp”. Then right-click on the fault frame and hit the “Taper/Subdivide” 
button as you did before. This time, when the “Element input panel” appears, click on ”splitting.” Now 
choose a 7 x 3 patch subdivision, and hit OK, and you will see the right picture on the previous page. Save 
the tiled input file by Input > Save input file as ascii with a new name, and open it in an editor to see the 
21 adjacent coplanar sources (above right), all with the same slip as the initial input file. You can now 
change the slip on each patch by hand. The input folder contains several examples of these (such as the 
1992 M=7.3 Landers, California, and 1995 M=6.9 Kobe, Japan, shocks). 
 

 
 

If you are tapering or subdividing a vertical fault, you can still see the nested or tiled patches by choosing 
Functions > Grid > 3D view. Then you can use the swivel tool to view it on its side. 3D view is also 
valuable because the patches are colored by their slip, rather than being translucent. Notice the rake vectors 
with tiny arrowheads; the vectors are rooted to the center of each patch. 
 
4.10 The seismic moment is calculated every time an input file is loaded 
Every time you launch an input file, Coulomb calculates the total seismic moment of the sources in the 
input file, using the fault area, slip, Young’s modulus, E, and Poisson’s ratio, PR, from the input file. The 
seismic moment (in dyne-cm) and the equivalent Mw appears in the MATLAB window: 
 

 
For the seismic moment of individual sources, click on the source with the right mouse-click. You can also 
type “seis_moment” into the Command Window at any time to see the total moment of all input sources. 
 
4.11 Using variable slip source models from the NEIC or university websites  
Many large sources have “variable slip” (also called “finite fault”) models with numerous small patches of 
slip. You might also want to subdivide a receiver fault so that you can assess the variations in stress 
imparted by a nearby earthquake.  
 
The NEIC now routinely publishes variable slip models of large global earthquakes in Coulomb .inp 
format. Go to the USGS NEIC Earthquake Event page, <http://earthquake.usgs.gov/earthquakes>, click 
‘scientific & Technical,” then “Finite Fault Model”: 

          
 

http://earthquake.usgs.gov/earthquakes
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Prof. Chen Ji (U.C. Santa Barbara) also publishes variable slip models in Coulomb .inp format. Go to  
 

http://www.geol.ucsb.edu/faculty/ji/big_earthquakes/home.html 
 
Choose an earthquake and scroll down to the bottom of the explanatory page and you will see: 

 
 
Prof. Martin Mai (King Abdullah Univ. of Science and Technology) has built the SRCMOD (source 
model) database of over 150 variable-slip input files from the literature, which can be read in as Coulomb 
input files. Some of these files can have hundreds to thousands of slip patches, and so calculations, 
particularly “3D view” and “calc. stress on faults”, can be very slow. Also, SRCMOD has not been updated 
since 2007, and the most recent earthquake was in 2005. 
 
Go to http://www.seismo.ethz.ch/static/srcmod/Homepage.html and click on “Downloads”. Then 
download the most recent .mat file for MATLAB 7 (the top file below left) to the Coulomb33 folder. Make 
sure you “Save as” a binary “.mat” file, not a “.txt” file. 

 

                
 
In the MATLAB command window, type the plugin ‘srcmod2coulomb”. You will then see the file 
selection window (above right). The selected file will automatically be saved into the input file folder as an 
.mat input file. The file name will also indicate the number of sources (“100f_” means 100 slip patches). 
Then, Input > Open existing input file > Grid >3D view. The example below left is 
“1987WHITTIhart_100f_coulomb.mat”, the 1987 Mw=6 Whittier Narrows shock: 

 

 
 

http://www.geol.ucsb.edu/faculty/ji/big_earthquakes/home.html
http://www.seismo.ethz.ch/static/srcmod/Homepage.html
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4.12 Merging several variable-slip models to one input file 
(“merge_input_files” plugin) 

 
Here’s how to take many variable-slip input files and merge them into one .mat input file: 

1. Open an existing input file. Type “merge_input_files” into the MATLAB command window. 
You are then requested to choose the second input file. This process is repeated until you have 
included all files that you want.  

2. Save the combined file with any name you would like.  
 
4.13 Making realistically scaled source faults from Global CMT or focal 

mechanism data 
 
1. Choose Input > Build input file from lon. & lat. map. The “Build input from CMT or focal mech. 

data” calculator will appear. Button sequence: 1) - 2) - 3) - 4) 
                

                              
 
2.  Press “1) Calc.” in the ”study area” box (above left) to calculate boundaries and grid increments of the 

study area (the yellow fields). Then hit “2) Add to map” to apply changes to Coulomb window, which 
will create the grid. If you do not have the MATLAB Mapping Toolbox, and your grid spans more 
than one UTM zone, Coulomb will warn you that it is making simplified distance calculations. 

 
3.  To create the source fault from the CMT information, drop down to the “Fault element” box (above 

left). You can choose the “Fault center” (this is the geometrical center of the rectangle, so make sure 
the top of the fault is at or below the ground surface), or the ‘start-point per Aki-Richards” (this is the 
Coulomb start-x, start-y position), and then input the Mw, strike, dip, and rake from a CMT file. In this 
example, just change Mw to 6.8 and change the dip to 20°. 
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4.  If you would like to use the Wells and Coppersmith (BSSA, 1994) empirical magnitude-area relations 

to estimate appropriate fault lengths and widths, press the “From empirical relations” button, and the 
“empirical relations…” box will appear (above right). Choose the type of fault (here, reverse) and hit 
“Calc.” To accept the length and width values, hit the “Apply” button, and then close the “empirical 
relations” window. You will now see the “length” and “width” information changed in the “Fault 
elements” box. Notice, however, that these relations permit the fault width in great strike-slip events to 
get too deep. 

 
5. Now press “3) Calc.” in the “Fault element” window to calculate fault position, and press “4) Add to 

map” to apply the fault to the Coulomb window. A portion of the resulting map is shown above at 
right. Notice that the blue dot is the fault reference point you selected. To save the input file you just 
created, choose ”save input file as ascii” in the Input menu, and name it, replacing the comment lines. 

 
6. If you would like to add more sources, after you have hit “4) Add to Map”, just increment the “ID 

number” to 2 and put in the new values into the “Fault elements” window, and so forth. 
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Chapter 5 
   

Earthquake, Fault, Coastline Overlays, and Seismicity Rate 
Changes 
 
5.1 Overlays (coastlines, active fault traces, seismicity) 
1. It is enormously valuable to plot your map with lat/lon tic marks and to overlay geographic or seismic 

catalog information. This is easy to do as long as the input file (.inp, .inr, or .mat) has lat/lon 
information, which is the last item in the input file, such as 

 

 
To plot with lat/lon tic marks, Input > Preferences > Coordinates > lon. & lat. and then launch the 
input file. (If you do not have this information, you can calculate it using the Coulomb tools: 
Functions > Tools > Convert lat/lon to Cartesian, which opens a calculator window that will create 
your input file for you.) 

 
2. Use of the National Geophysical Data Center Coastline Extractor. Go to 

http://www.ngdc.noaa.gov/mgg_coastline/ and input the boundary coordinates, or use “Java Map for 
lat/lon”, zooming in as needed. We recommend the Medium Resolution (1:70,000) Coastline database. 
Select the MATLAB Format, choose no compression, and preview it with a GMT plot. Hit the 
”SUBMIT” button. Save the resulting “.dat” file in the Coulomb “coastline_data” folder, and rename it 
if you like. Open the file in your editor; if there are “nan” lines in the file, use a “replace” command in 
your editor to change to “>“ symbols. 

 

                    
 
5.2 How to use overlays in 2D and 3D plots 
1. Launch “Example-SFBayArea.inp”. Now, Overlay > Coastlines. Open the “coastline data” folder in 

the Coulomb33 folder, and select “california_coastline_di_pos.dat”. The “di” refers to intermediate 
resolution; there is also a high resolution “dh” file in the folder. Answer the pop-up question, “no”. 
Some datasets treat western longitudes as negative; others do not. The coastline will appear on your 
plot. Now try Overlay > Active faults. (You could load folds or roads or anything you like; the 
formats are explained in a pop-up window.) Choose “California faults_lonlat_dat”. It‘s a large file but 
will plot on your map. The “Coastline data format” and “active fault format” windows are shown 
below: 

 

http://www.ngdc.noaa.gov/mgg_coastline/
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2. Now choose Overlay > Earthquakes, and choose the “(NCSN) readable” format in the “Earthquake 

catalog formats” menu below left. Then select the “readable” format of the actual data file in the data 
folder. It is only important that the format chosen matches the format of the dataset you are opening. 
Fifteen catalog formats are supported by Coulomb from global data, the United States, Japan, and 
Turkey. 
 

                     
 

An “earthquake_screening” window (shown above right) will appear that lets you filter the time, location, 
depth, and magnitude of earthquakes you would like to plot. It if is a large catalog, this can take time. For 
the CMT “ndk” format, go to http://www.globalcmt.org/cmtfiles.html. 
 
3. For this exercise, just click “OK” to plot all 324 earthquakes that occurred in the grid and are defined 

in the input file, and you should see the image below. The default colors appear below, but the colors 
of all overlays can be changed in the Preferences panel. 

 

 
 

You can remove any overlay by Overlay > Clear overlay from memory, if you want to use a different 
dataset instead, or you can toggle on/off any overlay by unchecking it. Note that coastlines are continuous 
lines; by editing them in Adobe Illustrator, you can fill the land or sea area. Faults are line segments. 
 

http://www.globalcmt.org/cmtfiles.html
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4. Save an input file with all of the overlays by Input > Save Input + Overlays as .mat. Name it 

uniquely. This will create a compact binary file that you can use in the future—a great time savings—
although it cannot be opened in an editor.  

 
5.3  Adding source or receiver faults by tracing active faults (or folds) 
It is fast and easy to build source or receiver faults by tracing the active faults on the map. Starting from 
where you left off in the previous exercise, Overlay > Trace and put faults into input. Instructions pop 
up to remind you that you use your left mouse button for the Start end of the fault and your right mouse 
button for the Finish end. Remember that the right-hand rule means that for non-vertical sources, the Start-
Finish order determines which direction the fault dips: the fault dips to the right when you are looking 
toward the Finish from the Start (see the Aki-Richards (1980) diagram in the “Keys to the City”). 
 
The “Element input panel” appears (below) with the Start-Finish coordinates you moused on the map. 
Now, add the slip and top/bottom depth and hit “OK”. Remember that if the fault is blind, it will be offset 
from the trace as a function of its dip and upper depth (refer to the “Map Positioning” figure in Chapter 4 to 
see this). The new fault appears in red (below left); when you hit OK, it turns green to indicate it is now the 
trace of a source or receiver. If you save the input file, the new source or receivers will be included. When 
saved, each source will get assigned its element number, which will be seen at the Start end (below right). 
 

        
 
5.4  3D source and seismicity (.fig) figures that you can spin and roll 
MATLAB lets you create very compact “.fig” files that can be manipulated in 3D to see, for example, if 
your coseismic source fault is properly located with respect to its aftershocks. 
 

1. Input > Preferences > Cartesian. Open an input file, add the coastline and earthquake catalog 
overlays. Now, Functions > Grid > 3D view (see below left). 

2. Switch to the MATLAB command window, and type the plug-in, “earthquake_plot3”. You will 
be asked on screen if you would like the earthquake magnitude scaled by circle size and depth 
scaled by color (choose Y) or by circles or filled disks (choose N). 

3. You can use the  tool to blow up the area of interest, but the file will still contain the full data. 
Now use the  to spin and roll the view. A portion is shown below, at right. With this tool 
selected, a right mouse-click lets you to reset to a regular map, side, or depth view. The source slip 
is scaled by its color. 

4. You can save this file and re-open it later. File > Save as > “yourname.fig.” It‘s an amazingly 
small file. 

5. If you simply double-click on this figure, it opens in MATLAB (not Coulomb) and can again be 
manipulated. 
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                  3D view in Grid              3D view using “earthquake_plot3” plugin  
               (using swivel tool)                       (different view, quakes scaled by size and depth) 
 

                         
 
 
5.5 Volcano overlays  
Active volcanoes appear as triangles if you choose Overlay > volcanoes. Their size and color are 
controlled in the Preferences menu. An example from Japan is shown in Chapter 2.2. Global volcanoes are 
stored in “volcanoes_NGDC_NOAA.mat” in the plug_ins folder; you do not need to load them in. If, when 
you select volcanoes, none appear, then there are not any in your grid area. 
 
5.6 Digitizing faults from maps and images 
Save the fault map you would like to digitize as a .jpg or .png (raster) file, cropping it so the boundaries of 
the image lie at identified lat/lon coordinates. Type “digitize_faults” in the MATLAB Command Window, 
and browse to your image, enter its upper left and lower right coordinates in the pop-up panel (below left). 
Then, click on the push-pin icon and use the left mouse button to digitize a fault, ending with the right 
mouse button. Each time you click the right mouse button you will be asked to name the fault or fault 
section. Then choose “Export XY” and save it as a .dat file into the active_fault_data folder in the 
Coulomb33 folder.  
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5.7 Making smoothed seismicity density plots 
Rather than showing earthquakes, you might want to plot seismicity density smoothed over some radius. 
This can be accomplished by plotting an earthquake catalog in a 2D Grid view, and then typing in the 
plugin, “smoothed_background”. You choose a smoothing radius, and it will plot the seismicity density 
over a box reduced in size to the original so that the smoothing kernal can use all cells, as shown below. 
 

        
 
 
5.8 Making smoothed seismicity rate change plots 
This plug-in allows you to plot the seismicity rate change associated with an earthquake or volcanic event. 
Just type ”seis_rate_change” into the Command Window. This allows you to read in a seismic catalog, 
choose the minimum magnitude (for example, Mc), select a smoothing radius, identify the date and time of 
the event (for example, a large earthquake in the catalog), choose a color saturation value, and then 
calculate the rate change, which is scaled by log[new rate/old rate]. Two maps are produced, one to show 
the seismicity rate where it is defined (above right; the dark blue areas are undefined because there are not a 
sufficient number of earthquakes), and the other to show the undefined areas. Earthquakes can be overlaid 
on the log seismicity rate change map. 
 
5.9 Transferring Coulomb files to the GMT mapping software  
There are two plug-ins used to convert the vector-based source and receiver fault information, and the 
raster-based Coulomb stress gradient map, into GMT. After you have created the map view figure in 
Coulomb, type this into the Command Window: coulomb2gmt_source. It saves the files, 
"gmt_fault_calc_depth.data",  "gmt_fault_map_proj.data" and "gmt_fault_surface.data" Then type this into 
the Command Window: coulomb2gmt_cout. This converts the calculated Coulomb matrix data into the 
GMT text column data (lon, lat, Coulomb stress change), so that it can be plotted in GMT and draped over 
a DEM as a raster image. It saves a file named "coulomb_out.dat" 
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Chapter 6 
   

Deformation, GPS Displacement and Strain  
 
Here we guide you in calculating deformation caused by an earthquake and display the results graphically. 
 
 
6.1  To display horizontal displacement vectors 
1. Input > Preferences and change Coordinates from Cartesian to Lon. & Lat. Input > Open existing 

input file > “Example-2(LL).inp”. Then, Functions > Displacements > Horizontal displ. (vectors). 
You will see a dense vector image in the Coulomb 3.3 window. To plot fewer vectors, Functions > 
Change parameters > Grid size, change it from 2 x 2 km to 4 x 4 km, and hit OK (like the plot below 
left). Now repeat Functions > Displacements > Horizontal displ. (vectors). To change vector scale 
and reference frame, in the “Displacement” control panel, either move the slider (which rescales the 
vectors on the fly) or type in a number (try 10,000) in the text field (these means the vector scale is 
10,000 x the distance scale). 

 
            No reference point                      Reference point by 
mouse click 

           
 
2. Then click on “Fixed point (Cartesian)”, hit the “Mouse click” button and click on a point to the SE of 

the fault. The new reference point indicated by a red circle (above right). 
 
 3. Numerical output files are created every time you make a run. When you click “Cal. & View” in the 

“Displacement control panel”, a text output file called “Displacement.cou” will be created or updated 
and saved in a sub-folder called “Output files” within the “Coulomb 3.3 folder”. When you want to 
save your latest run, remember to rename the “Displacement.cou” file; otherwise it will be overwritten 
by your next displacement calculations. Below left is an excerpt of a “Displacement.cou” text output 
file. 

 
                 Coordinates                 Displacements 

            
 
4. To change the sampling depth of calculation, in the “Displacement” control panel, type your desired 

value after “Depth” and hit “Calc. & view”. To compare the results to geodetic data, set Depth=0.0. 
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5. To make a displacement cross-section, choose Input > Open existing input file > “Example-

2(TH).inp.” Next, Functions > Displacements > Horizontal displ (vectors).  In the “Displacement” 
control panel, choose “Cross section”. This is a reverse fault; the dashed blue line in the plot below is 
the depth of the horizontal vectors in the map view plot. The cross-section line was included in the 
input file (this optional information is shown above right). You can change the cross-section line 
interactively in the Cross section control panel. Change the increments to 2 km by 2 km (below left). 
Use the left mouse button to click the start (A) point, and the right mouse button to click the end (B) 
point. If you do not have a two-button mouse, use ctrl+click for the right button. To save the changes, 
choose Input > Save input file as ascii with a new file name. 

 

     
 

For displacement plots, the dip of the cross section is always vertical. Within the “Cross 
section control panel”, you can chose items on the menu bars to Zoom In, Zoom Out, Pan, 
and 3D Rotate. 
 
6.2 To display observed and modelled GPS vectors 
1. You can create a GPS file with five columns: lon.°, lat.°, dx, dy, dz (m), in space-delimited format. 

If easier, prepare the file in Excel and then save as “Formatted text (space delimited)”. An 
example of the format is shown below. Also, see “gps_example.dat” in the GPS_data folder.  

 
 
2. After you have plotted a figure, choose Overlay > GPS stations, and select the file you created. If 

you did not set “Depth” in the input file to zero, choose Functions > Change Parameters > 
Calculation depth. If the input file has a source fault, you will see a plot like the one below for 
the observed and modelled vectors (the circles mark the stations; they are not error ellipses) and a 
vector scale bar. Here we saved the file as a pdf and added the legend in Illustrator. 

 
3. To output a numerical file of the observed and modelled displacements, follow the instructions in 

the Command Window (reproduced below). The GPS_DATA file can be opened in Excel 
for calculation of residuals. The example below uses the input “Niigata-Chuetsuoki-
2007.mat” and “Niigata-Chuetsuoki-2007-GPS.dat”. 
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4. To plot the vertical GPS vectors, type GPS_FLAG = ‘vertical’ into the Command Window. 
If you would also like stations labelled by their sequence number, type GPS_SEQN_FLAG = ‘on’. 
You will then see a plot like the one below right. Observed displacements are blue; if you are running a 
model, its predictions will be red. 

 
                                          Default setting                                                                  

Command window entries:  
                                   (GPS_FLAG = “horizontal”)                                   GPS_FLAG = “vertical” 

and GPS_SEQN_FLAG = “on” 

   
 
 
6.3  To display crustal deformation as wireframe images 
1. Using Example-2(TH).inp, Choose Functions > Displacements > Horizontal displ. (wireframe). 

The undistorted grid is in yellow and the distorted grid in blue. For a cross-section, use the default 
cross-section line, but change the horizontal and depth increments to 2 km in the “Cross section” 
control panel to see the images below. These cross-sections can be made to conserve area (they are 
“retrodeformable” in geological jargon) if you set Poisson’s ratio to 0.5 by Functions > Change 
Parameters >All input parameters: 
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2. The wireframe cross-sections are useful to illustrate deformed strata associated with thrust and normal 

faults and ramp-thrusts. You can pop them into Illustrator and color the layering so it appears like 
strata. 

    
 
 
6.4  To display the vertical displacement by color gradients and contours 
1. Choose Input > Open an existing file “Example-2(LL).inp”; then Functions > Displacements > 

Vertical displ. (color & contours). You will see the following left image in the Coulomb 3.3 window. 
 

       Tiled                               Interpolated 

             
 

2. Data smoothing and color scale options: In the “Vertical displ.” control panel, you can choose un-
interpolated data (left above) or “Interp.”, that is, interpolated (right above). Color saturation: You can 
adjust color scale by moving the slider bar under “Color saturation” or type the value in the box, hit 
return, and then click “Calc. & View” in the Displacement control panel (below left).  
 

   Under-Saturated             Contoured 
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3. Contours: In the “Displacement” control panel, choose “Contours” and click “Calc. & View”. 

Contours showing vertical displacements are superimposed on the color image (image above right). 
You can choose the contour interval. To get smooth contours, you must use a fine grid, because there 
is no interpolation of the contours.. 

 
4. Cross section: Choose “Cross section” in the “Displacement” control panel. The methods of making 

cross sections are similar to those described in previous sections. 
 
6.5  To display the vertical displacement as a 3D image drape 
1. Choose Functions > Displacements > 3D image drape. The color scale is controlled by the parameter 

in your input file. See the lower left panel below. 
 
2. To control the amount of vertical exaggeration, choose Functions > Change parameters > Displ. 

exaggeration, and you will see a pop-up “Displ. exaggeration” window, in which you can change 
vertical exaggeration by entering a new value and then clicking “OK”. 
 

    
 

3. In the Coulomb 3.3 window, you can use options of Zoom In, Zoom Out, Pan, 3D Rotate, 
Insert/Remove ColorBar, and Insert/Remove Legend, as described in previous sections. 

 
6.6  To display the vertical displacement as 3D image wireframed surface 
1. Choose Functions > Displacements > 3D image wireframed surface. The color scale is controlled 

by the parameter in your input file.  
 
2. Try changing the vertical exaggeration by Functions > Change parameters > Vertical exaggeration 

> 8000. Then, choose Functions > Displacements > 3D image wireframed surface. A swivelled 
version is shown above right. 

 
6.7 To display and output the horizontal and vertical surface deformation in 

cross-section 
Both “Horizontal Displ. (vectors)” and “Horizontal displ. (wireframe)” provide cross-section outputs. 
These also produce numerical output files of the ground surface deformation components, Ux, Uy, and Uz. 
You will see these lines in the Command Window: 

 
User selected/Users/rstein/Desktop/Coulomb33/input_files/Example-2(TH).inp 
   No lat. & lon. information is included in the input file. 
   Total seismic moment = 6.26e+26 dyne cm (Mw = 7.13) 
---> To calculate deformation, select one of the submenus from “Functions”. 
  
Displacement.cou is saved in /Users/rstein/Desktop/Coulomb33/output_files 
displacement_section.cou is saved in /Users/rstein/Desktop/Coulomb33/output_files 
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6.8  To display any component of the strain field 
1. Choose Functions > Strain. A Strain control panel will appear (below left). 
 

                         
 
2. In the Strain control panel, choose the type of strain you want to calculate. For example, choose “Eyy” 

and you will see the image above right. We are not using the “Engineering Strain” convention, where 
values are multiplied by 2. 

 
3.  Numerical output files. Every time you click “Calc. & View” in the “Strain” control panel, an output 

file called “dilatation_section.cou” will be created or updated. When you want to save your latest runs, 
remember to rename the “dilatation_section.cou” file within the “output files” sub-folder; otherwise it 
will be written over by your future displacement calculations. Here is an example of 
“dilatation_section.cou” output file: 

 

 
 
4. By choosing parameters in the the “Strain” control panel, you have the options to switch between the 

tiled versus interpolated data grid, change color saturation, and contours, as explained in previous 
sections. 
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Chapter 7 
   

Coulomb Stress Calculations 
 
7.1 The Coulomb failure hypothesis explained 
Here we calculate static stress changes caused by the displacement of a fault or dike or point source (we 
refer to these as ”source faults”). The displacements in the elastic halfspace are used to calculate the 3D 
strain field; this is multiplied by the elastic stiffness to derive the stress changes.  
 
We resolve the shear and normal (clamping/unclamping) components of the stress change on a 3D grid of 
points or on specified “receiver” fault planes. Receiver faults are planes with a specified strike, dip, and 
rake, on which the stresses imparted by the source faults are resolved; we call these ‘specified faults” in the 
Coulomb menus. The shear stress increase or decrease is dependent on the position, geometry, and slip of 
the source fault and on the position and geometry of the receiver fault, including its rake. The normal stress 
change (clamping or unclamping) is independent of the receiver fault rake.  
 
We use the Coulomb failure criterion, Δσf = Δτs + µ’ Δσn, in which failure is hypothesized to be promoted 
when the Coulomb stress change is positive. Here, Δσf is the change in failure stress on the receiver fault 
caused by slip on the source fault(s), Δτs is the change in shear stress (reckoned positive when sheared in 
the direction of fault slip), Δσn is change in normal stress (positive if the fault is unclamped), and µ’ is the 
effective coefficient of friction on the fault. 
 
In Coulomb, we’ll explore four kinds of receiver faults: (1) “specified” receiver faults in which all faults 
have a uniform receiver fault geometry, (2) faults optimally oriented for failure, (3) receiver faults with 
geometry set in the input file, and (4) focal mechanism files, in which there are always two orthogonal fault 
planes. The optimal orientations are a function of the regional (also called “tectonic”) stress, the stress 
imparted by the source fault, and the assumed friction coefficient on the receiver fault.  
 
On the following page are figures 2 and 3 from King and others (1994), which graphically present the 
Coulomb stress change resolved on vertical strike-slip faults parallel to the source fault (fig. 2A) and 
resolved on optimally oriented planes (fig. 2B) for a given regional uniaxial compression and an assumed 
friction coefficient. In figure 3, the influence of the regional stress magnitude is seen on the orientation of 
the optimal planes and on the stress change resolved on these planes. These figures were made in a 
primordial version of Coulomb. 
 

 
 

Above, just notice that the fault or “failure plane” is oriented β° from the principal 
compressive stress (σ1), and the shear stress t and normal stress σ act on the fault. 
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Illustration of the Coulomb stress change (fig. 2 from King and others, 1994) above. The panels show a 
map view of a vertical strike-slip fault embedded in an elastic halfspace, with imposed slip that tapers 
toward the fault ends. Stress changes are depicted by graded colors; green represents no change in stress. 
(A) Graphical presentation of equation 8 of King and others (1994), a ”specified fault” calculation. (B) 
Graphical presentation of equation 13 of King and others (1994), for optimally oriented strike-slip (“opt 
strike-slip”) faults.  
 
 
Dependence of the Coulomb stress change on the regional stress magnitude, σr, for a given 
earthquake stress drop, Δτ  (fig. 3 from King and others, 1994). If the earthquake relieves all of the 
regional stress (left panel), resulting optimum slip planes rotate near the fault. If the regional deviatoric 
stress is much larger than the earthquake stress drop (right panel), the orientations of the optimum slip 
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planes are more limited, and regions of increased Coulomb stress diminish in size and become more 
isolated from the source fault. In this and subsequent plots, the maximum and minimum stress changes 
exceed the plotted color bar range (in other words, the scale is saturated). 

 
 
7.2  Coulomb stress change on specified receiver faults (”specified faults”) 
This is the simplest calculation, and is widely used by researchers. To resolve the stress, you need to 
specify the fault strike, dip, and rake of the receiver planes following the Aki and Richards convention, 
shown graphically in the next page of this manual. 
 
1. Choose Input > Open existing input file. Then in the “Open input file” window, choose the 

“input_files” sub-folder within the “Coulomb 33” folder, and select “Example-2(LL).inp” 
2. Choose Functions > Stress > Coulomb stress change. The “Stress” control panel appears. 
3. To calculate stress changes on specified receiver fault planes, use the default ”specified faults”. 

Coulomb averages the information on all input fault patches listed in the input file and puts the values 
in the boxes, but you can change them. Strike, dip, and rake are defined following the conventions of 
Aki and Richards (1980): 
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For practice, choose a strike/dip/rake of 360°/90°/0°, change the friction coefficient to 0.0, set the stress-
change color saturation to ±5 bars, and hit “Calc. & View”. 
 

 
 
The Coulomb stress changes default using our “Anatolia” color scheme. Other schemes (“Rainbow” or 
“Black & White”) can be changed by pulling down the Input > Preferences menu bar and clicking on 
“Color Map”. Then re-run the input file.  
 
7.3 Using the strike/dip/rake/friction slider (Specified slip control panel) 
To vary these parameters on the fly, hit the “>” button in the Stress control panel, and the “Specified slip” 
control panel pops up (see it above). Slide the balls to explore how the stress pattern changes. 
 
7.4 Saving the graphic and numerical output of stress calculations 
To save this graphic, File > Save As… > choose a .eps (if it has a color gradient map) or .pdf if it does not, 
format and rename it; its only 40 kb but is a full vector image. Stress change is calculated in the lower left 
corner of each grid square at the target depth specified in the input file. Calculated values of stress change 
may saturate (exceed the plotted range), so experiment with the slider to see more subtle features. The 
stress-scale legend is to the right of the plot. 
 
Every time you click “Cal. & View” in the “Stress” control panel, a numerical output file called “dcff.cou” 
will be created or overwritten and saved in a sub-folder you designate in the Preferences menu. Remember 
to rename dcff.cou if you want to save the numerical file. 
 

         
 
 
7.5  The importance of receiver fault geometry in Coulomb modeling 
In the figure below, from Lin and Stein (2004), the source is an idealized M~7.9 right-lateral southern San 
Andreas rupture. The most familiar stress pattern is the case of source and receiver faults with the same 
strike, dip, and rake (a). But look how strongly the pattern changes when the receiver faults are nearby 
thrusts (b-c) or left-lateral faults (d). Thus, a stress shadow for one receiver may be a stress trigger zone for 
another receiver fault. Note also that in our work, we tend to assume a high coefficient of friction (~0.8) for 
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continental thrust faults, moderate friction (0.4) for strike-slip or unknown faults, and very low friction 
(>0.2) for major transforms, such as the San Andreas. This is, in part, based on Parsons and others (1999).  
 

 
 
7.6 Adding Coulomb stress to an overlay plot and viewing it in 3D 
1.  Launch “Example-SFBayArea.inp”. Overlay > Coastlines. Open the “coastline data” folder in the 

Coulomb33 folder, and select “california_coastline_di_pos.dat” Answer the pop-up question, “no” 
(some datasets treat western longitudes as negative; others do not). Now, Overlay > Active faults. 
Choose “California faults_longlat_dat”.  

 
2.  You can now add any kind of stress changes to this plot without losing any of the overlays. Just hit 

Functions > Stress > Coulomb stress change, and select a stress component and option, and you will 
see a map view image such as that below left. 
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3. After completing any Coulomb stress calculation made over the grid, such as Coulomb stress change, 
Shear stress change, or Normal stress change, just return to the MATLAB window and type in 
"coulomb_3d_view". This calls a plugin (which can be found in the plugin folder in Coulomb33 folder). It 
executes a 3D view that you can manipulate and save as a pdf file, such as that above right. 
 
7.7  Coulomb stress cross-sections 
1. Choose Input > Open existing input file > Example-2(TH).inp. Next, choose Functions > Stress > 

Coulomb stress change. Change the color saturation to 3.0 bars, and hit “Calc. & View” in the 
“Stress” control panel. After the mapview plot appears, hit the “Cross section” button on the Stress 
control panel, which displays the cross-section parameters from your input file (left plot below). Click 
“Calc. & View” and you will see the image below left. Now change the saturation to ±10 bars and 
chose interpolated shading; hit  “Calc. & View” again (right panel).  

 
Mosaic, ±3 bars                         Interpolated, ±10 bars 
 

    
 
2.  You can overlay seismicity in cross-sections if you first plot the mapview with earthquakes and then 

make the section. The default setting plots seismicity within ±20 km of the section line. To change this, 
print EQPICK_WIDTH=5 for ±5 km, and so forth, in the command window. 
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3. You can also change the dip angle of the cross section by entering a non-90° value in the “Dip” box in 
the panel above; this is useful when you want to calculate stress on a thrust fault surface or a 
subduction interface. The blue dashed line is the depth at which stress was sampled in the map view. 
The red line is the intersection of the fault plane with the cross-section line.  These can be seen in map 
view, which has a blue cross-section line, a red fault perimeter, a green line where the fault projects to 
the ground surface, and a black line where the fault intersects the depth at which stress is being 
sampled. You can change the depth, and many other parameters, in the “Stress” control panel. 
 

4. You can calculate the maximum or mean values of Coulomb stress changes between various depth 
ranges. Click “Depth range” and then “Cal. & View” in the Stress control panel, you will see “Depth 
control panel”. In the Depth control panel, enter depths of the top and bottom surfaces, as well as the 
depth increment, for which you want to perform the comparisons. You can calculate either “Maximum 
values” of Coulomb stress changes over the given depth range (below left), or the “Mean values” over 
the range (below, right). The numerical output file shows the maximum value at each grid point. The 
maps below were made using the left-lateral strike-slip fault input file, Example-2(LL)-lonlat.inp.  

 
 Max stress change over a depth range           Mean stress change over a depth range 

 

       
 
5. You can plot the orientation of the ‘specified fault” strike in map view. Choose Input > Open existing 

input file > Example-2(LL).inp. Next, choose Functions > Stress > Coulomb stress change. Check 
the ‘strike line” box in the Stress control panel and, for practice, change friction to 0.0, shading to 
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interpolated and then “Calc. & View”, resulting in the following image on the left. Notice that the lines 
strike 41° as specified. Stresses and slip lines are plotted on the lower left corner of each grid box. 

 

      
 
7.8  To display principal stress axes rotated by the earthquake stress change 
Coulomb makes the tensor addition of the earthquake stress change, which diminishes with distance from 
the source fault, and the regional stress, which is assumed uniform, to calculate the total principal stress 
axes. Once the total principal stress axes are determined, Coulomb uses this and the assumed friction 
coefficient to determine the optimum planes.  
 
Choose Input > Open existing input file > Example-2(LL).inp. Then, Functions > Change parameters > 
Grid, and change the grid to 5.0 x 5.0 km so the axes are not too crowded (this is not a requirement; you 
can choose any grid spacing of interest). Now, Functions > Stress > Coulomb stress change. In the pop-
up “Stress control panel”, choose “Opt. Strike S.”, “Principal Stress”,  and “Interpolating”, and click “Calc. 
& View”. You will see the image on left below. Using Tools > Zoom In, you’ll see the right image below.  
 
                              Normal view with principal axes                           
Zoomed view 
 

               
 
The axes are not scaled by their stress magnitudes, because too many would be invisible. Notice that the 
axes rotate in 3D, not just in the horizontal plane, and so σ2 deviates from being vertical close to the source, 
as a result of the stress changes imparted by the earthquake. This means that σ2 can be seen in near the end 
of the fault. 
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7.9 Using the regional stress in optimally oriented stress calculations 
 
The regional (also called, “tectonic”) stress is used only when you choose one of the optimally 
oriented (“Opt.”) stress changes in the Stress control panel (below). Otherwise the regional 
stresses are ignored. See King and others (1994) for more on this topic.  
 

       
 

1. All of the example input files contain simple regional stress fields. The sign convention 
for S1, S2, and S3 is positive in compression (bars). Although you can assign axes that are 
neither horizontal nor vertical (in other words, they plunge at angles other than 0° and 
90°), and you can assign a vertical gradient in the stress axes, such that the stress 
magnitude increases (or decreases) with depth, we advise you to keep it simple. We 
typically make the greatest principal stress, S1, horizontal and about 100 bars and the 
intermediate principal stress about 0 bars. 

2. A reasonable regional stress must promote slip on all the faults in your area. You can use 
the P and T axes from focal mechanisms of earthquakes off the main faults, hydrofrac or 
borehole breakout information, and fault striae inversions to assess the strike of the 
greatest and least principal axes. The World Stress Map (http://www-wsm.physik.uni-
karlsruhe.de/) may also be useful for this purpose. But most important, ask yourself if 
the stress tensor you are proposing is consistent with the region’s active faults. 

3. You can build principal stress axes (which must be mutually perpendicular) by selecting 
Functions > Tools > Principal axis calculator. You can also visualize the principal axes 
by Functions > Stress > Coulomb stress change, and then by checking “Principal axes” 
in the pop-up “Stress control panel.” 

 
7.10 To display Coulomb stress changes on optimally oriented strike-

slip, thrust, and normal faults (with the fault dip fixed) 
“Optimally oriented” planes are those oriented such that the Coulomb stress change resolved on 
them is most positive (in our plots, most red). Here one assumes that aftershocks have a range of 
orientations and will be most abundant at the depth and location and have the geometry that 
most promotes failure. So at every point on our grid, we find the receiver plane on which the 
resolved Coulomb stress change is most positive. If the regional stress were zero, there would be 
a positive Coulomb stress change on some plane everywhere and at all depths. But at large 
distances from a source fault, the earthquake stress change will be much smaller than the regional 
stress, so the planes rotate very little.  
 
1. Choose Input > Open existing input file> “Example-2(LL).inp”. To calculate optimally 

oriented faults, one must specify the regional (sometimes called, tectonic) stress field in the 
input file. “Example-2(LL).inp” contains a sample 3D regional stress field. If you use your 
own input file, make sure the regional stress tensor is properly defined. To make sure that the 
directions of your regional stress axes are geometrically compatible (that is, orthogonal to 
each other), choose Functions > Tools > Principal axes calculator. You will see a pop-up 
“Coordinate axes for principal stress” window (below). 

 

http://www-wsm.physik.uni-karlsruhe.de/
http://www-wsm.physik.uni-karlsruhe.de/
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To check the compatibility of regional stress axes, first enter the strike and plunge of the 
greatest principal axis, S1 strike and S1 dip. Click “Calc”. Then enter the plunge of the 
intermediate principal stress axis, S2 dip, which should stay within the shown permissible 
range of values (“Dip range”) to ensure that three principal axes are mutually perpendicular. 
Click “Calc” again, and you will see four viable sets of combinations for the three principal 
axes. 

 
2. Choose Functions > Stress > Coulomb stress change. You will see the following in the pop-

up “Stress control panel”: 
 

 
 

In the  “Stress control panel”, the alternatives are “Opt. Strike S.”, “Opt Thrusts”, “Opt 
Normal”, and “Opt Faults”. (“Opt Faults” is an exceedingly slow grid search over the entire 
focal sphere for the receiver planes at every grid point, and so choose a coarse grid and you 
will need patience in waiting for the completion of the calculation. Try 10° for the search 
increment). Here, choose “Opt Strike S.” and click on “Strike lines”; then click “Calc. & View” 
and you will see this in the interior of the plot: 
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3.  Explanation of the Slip lines. For the “Opt Strike S.” option, the receiver faults dip vertically and 

their strikes are a function of S1 (α1) and the friction coefficient µ (FRIC in Coulomb). The right-
lateral and left-lateral optimum planes are plotted at every grid point. Their internal strike angle is a 
function only of the friction coefficient; these planes are acute to each other for high friction and 
orthogonal for zero friction. (For normal and thrust planes, the strike for the two planes is the same and 
their dip is a function of the friction coefficient). You can see large rotations of these planes very close 
to the source fault because the earthquake stress change is about as large as. the assumed regional 
stress, ~100 bars. Far from the source, the slip lines are parallel and their orientation is a function of 
the regional stress in the input file, because at these distances from the source, the earthquake stress 
changes are negligible. For thrust and normal faults, their dip is a function of the friction coefficient, 
and their strike is perpendicular to S1 (σ1) and S3 (σ3), respectively. The relationship of the angle, β 
between S1 and the dip (for strike-slip faults) or strike (for dip-slip faults) is tan 2β  = 1/FRIC.  See 
King and others (1994), which can be accessed online from the Coulomb web site at Stein’s website, 
http://profile.usgs.gov/rstein. 

 
4. For a friction coefficient of zero, the optimum planes would be orthogonal and we could compare them 

to aftershock focal mechanisms unambiguously. Then, Functions > Change parameters > Grid, and 
change the grid to 5.0 x 5.0. Then hit Functions > Stress > Coulomb stress change. In the “Stress 
control panel”, change Fric. to 0.0, check “Opt. Strike S.”, and ‘strike line”. An excerpt is shown 
below left. Repeat the process and in the “Stress control panel”, change the friction to 0.8 and hit the 
tab. You’ll see the image on the right. 

 
         Friction coefficient = 0.0          Friction coefficient = 0.8   
 

          
 

The stress changes are larger and more asymmetrical with respect to the source fault for high friction, 
and the rotation of the optimal planes near the source fault are a little greater. These aspects are 
discussed in King and others (1994). 

 
5. Strike lines for optimally oriented thrust faults. Choose Input > Open an existing file and choose 

“Example-2(TH).inp”. Then choose Functions > Stress > Coulomb stress change. In the “Stress 
control panel”, check “Opt. thrusts”, ‘strike line”, set friction at 0.4, ±3 bar saturation, and hit 
“Interpolating” (left below). You will see an image like this: 

 

http://profile.usgs.gov/rstein
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Here the two strike lines are parallel in the mapview (they would not be so in cross-section), so only 
one is visible. The rotations are greatest in the deep red and blue areas, where the stress change is large 
relative to the assumed regional stress. In this example, the fault is not quite orthogonal to the assumed 
regional stress. 

 
7.11 To resolve stress imparted to receiver faults (“Calc. stress on faults”) 
This is perhaps the simplest Coulomb calculation, and it is widely used in research. The regional stress 
information is not used, regardless of whether it is included in the input file. Coulomb permits one to show 
the resolved stresses graphically and output the numerical results. 
1. Choose Input > Open & edit input file, and select “Example-1.inp” Notice that there is a source fault 

with slip (#1) and two receiver faults (#2 and #3). Enter the fault# to see the slip: 
 

   
 
To see the variation in resolved stress along the receiver faults, you can split them into sections by right-
clicking on the fault, and selecting ‘splitting” in the “Element input panel” (below left). After you have split 
the receivers, you will see an image like that below (center). 
 

              
 

2. Now, Functions > Stress > Calc. stress on faults. A “Stress on faults” control panel will open to let 
you choose the stress component that you would like to resolve on the faults. We chose right-lateral 
faults; see the stress changes imparted by the source (fault#1) on the receivers (#2-10) in the image 
above right. Using the swivel tool, you can change the perspective; you can also change the saturation 
to bring out the along strike variations. 

 
3. If your input file used the “.inr” (rake, net slip) rather than the “.inp” (rt.lat. slip, reverse slip) format, 

then you could use the “Coulomb for individual rake” option. To switch how the input file is 
interpreted, it searches for the word, “rake,” so don’t misspell it. In the input folder, the full 1400-patch 
California Reference Database is included in various formats. “CA-fault-database-rake.inp” (and “CA-
fault-database-rake.mat”) are formatted by rake for this purpose. Because it is a large file, it takes time 
to calculate. Here are the first two sources in the database input file, with the right-lateral (rake=180°) 
Green Valley reverse (rake=90°) Mount Diablo thrust faults: 
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You can also use a subset and plot it, since all the faults have their associated names. Remember to 
make sure the “#fixed=“ in the third line of the input file is changed to reflect the number of faults in 
the input file (“#fixed= faults + receivers). 
 

4. Now try a file in the rake format. Input > Open and edit existing file > SFBay_rake.inr. Notice that 
there are fields for rake and net slip instead of strike-slip and dip-slip (below left). Now choose 
Functions > Stress > Calc. stress on faults and choose “Coulomb for individual rake” (below center). 
You will see a perspective view with the fault patches colored by their Coulomb stress resolves for the 
rake of each receiver (below right). Below, we’ve added coastlines, faults, earthquakes, made the grid 
coarser (the nodes are not used in a “calc. stress on faults” run), and swiveled the view. 

5.  

      
 
6. A complex case is the 1995 Kobe earthquake. Both a uniform-slip and a variable slip source model 

input file are included in the input file folder, in addition to about 50 surrounding faults with various 
orientations and dips. Input > Preferences > Cartesian; then Input > “Kobe-uniform-slip.inp”; then 
Functions > Stress > Calc. stress on faults. Note that a numerical output file is created each time you 
make a Calc. stress on faults run, which is very useful for further analysis and gives much more stress 
information. Two components are shown below. Using the swivel tool with files this large takes 
patience due to the time lag. 

 
Stress from the 1995 Kobe variable-slip model resolved on surrounding faults 

 

  
 
Notice that on the Kobe rupture itself, there are both red and blue patches. The Coulomb stress change is 
not uniformly negative (blue) because of the irregular coseismic slip which leaves spikes of stress increase, 
the presumed sites of along-fault aftershocks. 
 
7.12  Calculating stress change on a subdivided (tiled) receiver fault 
Often one would like to determine the distribution of stress change on a large receiver fault.  
 
1. Launch “Example-2(TH).inp”. Functions > Tools > Taper or subdivide fault slip, type fault “3” in 

the fault # box, split the source into 5 x 2 patches, and hit OK (below left). So now you have 
subdivided it into 32 patches. 
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2. Functions > Stress > Calculate stress on faults. You can zoom in and spin the view, as shown above 

right. The Coulomb stress change is colored and the rake vectors are in blue.  
 
7.13  Coulomb stress changes resolved on earthquake nodal planes 
1. If focal mechanism information is available, you may want to test whether the fault plane associated 

with each earthquake was brought closer to Coulomb failure. This is presumably a more stringent test 
than determining if earthquakes occurred in the red regions, although typically only a fraction of the 
catalog contains reliable focal mechanisms. If the friction were 0, this would be a straightforward test 
because the shear stress change on the orthogonal nodal planes is identical (such a test is used in 
Parsons, 2002). But for non-zero friction, the optimum Coulomb planes are not orthogonal, and so they 
will be different. In fact, one plane may have a stress increase and the other a decrease. You can 
sometimes infer the fault plane based on independent information, and there are published approaches 
others have taken, such as comparing the percentage of stress increases on seismicity in the region 
before and after a mainshock (Ma and others, 2005), or by using seismicity alignments. 

 
2. Using “Example-SFBayArea.inp”, Overlay > Earthquakes > In the “Earthquake catalog formats” 

window, select “NCSN fpfit (focal mech)”, and then choose the dataset with this name from the folder. 
Earthquake circles plot on the map. Now, Functions > Stress > Calc. stress on nodal planes. If the 
focal mechanism file only includes one set of nodal planes, Coulomb asks you if you want it to 
generate the other set, so answer “yes.” A window appears to ask you which set (Nodal set 1 or set 2, 
which are usually arbitrarily ordered in a catalog, the maximum of each pair, or Shuffle—random 
selection of set 1 or 2). It will assign colors to each earthquake according to how much the nodal 
planes were brought closer to or farther from failure. It does not plot beachballs (the focal mechanism 
orientations). You should see this plot: 
 
                       Raster image (default)          Vector version (set 
IVECTOR=1) 
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You can plot each set (Nodal plane 1 or Nodal plane 2) separately, choose the nodal plane on which the 
Coulomb stress change is most positive (“Max. values” or most negative, “Min. values”), shuffle them 
randomly. You can edit the catalog in an editor to make set 1 the likely fault planes. The numerical output 
file also calculates the maximum (most positive) Coulomb stress on each nodal plane and gives the 
corresponding optimum rake. 
 

 
 

The default file is a raster image (above left), but if you write “IVECTOR=1” in the MATLAB Command 
Window, and then save the file, you will get a vector image like the one above right. To change the circles 
to disks of colors, just select all circles and increase the stroke thickness. You do not need a fine grid 
increment (olive green lines in the above images), because these are ignored for this calculation. We 
suggest you use a course grid such as 0.5° lon. x 0.5° lat.  
 
Here, below, is an example from a recent paper of ours (Toda and others, 2011). The source fault slip, in 
grayscale, is from Grid > 3D view (click on swivel tool, and then rt.click and choose “Go to x-y view”), 
and then we used the “Max. values” option of Stress > Calc. stress on nodal planes. We use the ratio of 
the percent of positive mechanisms of the aftershocks (the “test” group) to the percent of positive 
mechanisms of the background (pre-mainshock) earthquakes (the “control” group) to test the Coulomb 
hypothesis and the source model. Here, we tested 6 source models and 3 values of friction (0.0, 0.4, and 
0.8) to find the best case. 
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7.14  Coulomb stress at a point, from lat/lon, x/y, or a mouse click 
Sometimes you want to probe the calculated stress changes at a given point, rather than over a regular grid 
or on receiver faults. This is easy to do in Coulomb by using the mouse or by entering a lat/lon or UTM 
coordinates.  
 
1. Functions > Stress > Calc. stress at a point.  A “Stress calculation on a point” window pops up. You 

can enter the coordinates and depth of interest, and you can also enter the receiver fault geometry. The 
output is numerical, and appears in the “Output” portion of the window, with blue numbers when 
negative and red when positive (as below).  

 

 
 
2. When using the Calc. stress at a point option, you can change the assumed friction coefficient in the 

same manner that you can for other stress calculations, by choosing Functions > Change parameters 
> Change Coefficient fric.. If you want to use x/y values, change to Cartesian coordinates in the 
Preferences menu. Then return to the Calc. stress at a point selection and use the “Stress calculation 
on a point” window. The lat/lon vs. Cartesian options are highlighted above in the red box. 
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Chapter 8 
 

Magmatic Sources, Google Earth Displays, Polygon Digitizing 
 
At this point we assume that you are now familiar with the typical steps and menu options in Coulomb, and 
our instructions will be more abbreviated, but still accurate. 
 
8.1 Point shear sources for small quakes or curved faults (Kode 400) 
1. If you specify Kode 400 rather than 100 in the input file, Coulomb will interpret it as a point source 

with right-lateral and reverse slip components. The location of the point source is defined by the 
rectangle in the input file. The point is located at the center of the rectangle: at the midpoint of the start 
and end positions and at the mid-depth of the top and bottom positions. The plane defined by this 
geometry is used for strike and dip of the point source. This is a simple way to represent small shocks. 

2. Another use of Kode 400 sources is if you have a very crenulated or curved fault, the overlap and 
underlap of the rectangles can be avoided by making a mesh of point sources (shown schematically 
below left). But don’t sample the stress closer to the fault than the point spacing, or you will see 
numerical noise (aliasing). 

 

              
 
3. We provide an input file with a single point source, “Example-Kode400.inp”. Note that the right-

lateral and reverse units are in potency (m3), not in slip (m), since a point has no area (see above right, 
from open & edit input file). Potency, or the geometric moment, is seismic moment/shear modulus 
(see boxed equation in Chapter 3 to calculate G from E and PR). 

 
8.2 Crack opening or closing (Tensile Kode 200 and 300 sources) 
Many magmatic intrusion problems involve a tabular body, such as dike or sill, undergoing expansion or 
contraction. Here we introduce the deformation and stress change caused by a tensile component of 
displacement, such as the opening or closing of a tabular or crack-like body, using the equations of Okada 
(1992). For simplicity, the input file format for Coulomb has only two slip components, labelled “rt.lat” 
and “reverse” or “rake” and “netslip”. So, when you change the Kode of the source to 200 or 300, the first 
of these slip components takes on a tensile-displacement interpretation by the program, as described below.  
 
1. Kode 200 permits tensile (opening) displacement and strike slip to be input. (dike opening is positive; 

unit = meters), “Example-6(200Kode).inp”. Here’s how a Kode 200 source appears in the Functions > 
Open & edit input file window, 

 

 
 
2. Kode 300 permits tensile (opening) slip and dip-slip to be input. For Kode 300, put tensile slip in 

the “rt.lat.” column (again, dike opening is positive), and put reverse slip in the “reverse” column.  
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3. If the element has three components of slip (strike-slip, dip-slip, and tensile-slip), you can accomplish 

this by including both Kode 200 and a Kode 300 sources in the input file as shown in the file below, 
“Example-7(200-300kode).inp”.  

 
6. Define the dike geometry (endpoints, dip, and top/bottom depth) as you do for faults. Unfortunately, 

the way we define sources and receivers does not permit one to put in a strictly horizontal plane, since 
the top and bottom depths would be identical, but you can put a tiny dip (~1°), and it will work fine. 

5. Uniform opening or closing of a dike is likely to be unrealistic. Just as you can for faults, you can taper 
the displacement toward the edges by Functions > Tools >  Taper. 

6. Select the file, Example-8(dike).inp, and then choose Functions > Displacements > 3D Vectors. You 
will get the image shown on the left. Now, Functions > Change Parameters > Vertical 
Exaggeration > 25000, and change Calculation depth to the surface (0.0 km). You will get the image 
on the right. Experiment with view angles. 

 
         3D Vectors at 10 km depth for a dike             3D Vectors at the free 
surface for a dike 
 

     
 
 
8.3 Point source of deflation or inflation (Kode 500) 
We have implemented the formula of Okada (1992) for a buried point source of expansion or contraction. 
Of course, the calculated stress changes very close to such a point source are infinite and are thus 
unreliable, but at larger distances, this source is useful for magmatic intrusion problems, such as studying 
how an intrusion event may bring other faults or dikes closer to failure. An example of this is Nostro and 
others, 1998, available at http://profile.usgs.gov/rstein. As with the dike or sill source, we have created two 
“kodes” for mixed volumetric and shear displacements. 

 
1. The unit for deflation or inflation is potency (m3), the volume change associated with the evacuation or 

expansion of a spherical magma chamber. Expansion is positive. The unit for the strike or dip slip is 
meters, as usual. One designates the source as Kode 500. 

2. Kode 500 permits both a dike and point source of expansion to be input. Put the tensile opening in the 
first (“rt-lat.”) column (units are m3; right-lateral is positive), and put the point source in the “reverse” 
column (units are m3; expansion is positive).  

3. The location of the point source is defined by a plane in the input file. The point is located at the 
midpoint of the start and end positions and at the midpoint of the top and bottom positions. The plane 
defined by this geometry is used for the dike opening. So if you only calculate the point-source 
expansion, the length and width of the plane are unimportant; only if you also want to consider 
opening or closing of the planar dike do these dimensions get used in the calculation. The point source 
is indicated in graphic output files as a small black circle. 

 

http://profile.usgs.gov/rstein
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The figures below left were made using “Example-9(Kode500).inp” with two different Displacement 
options selected. The surface projection of the dike is the short green line. 
 

 Vertical displ.    3D image drape                    Stress change on optimal 
normal faults 

 
 

         
 
In the example above right, we have chosen Stress > Coulomb stress change > Opt Normal, with a 1 x 1 
km grid, friction=0.8, depth of 8 km, and color saturation of ±0.25 bars: 
 
8.4 Displaying Displacement, Stress, and Overlays in Google Earth 
Google Earth offers wonderful opportunities to drape Coulomb files on satellite images and DEMs. You 
need to download and install Google Earth on your computer before following these steps. In addition to 
this, you will need Adobe Illustrator or any good graphic application. 
 
1. Make sure that you have selected the “lon. & lat.” Coordinate option in the Preferences. 
2. Run any horizontal displacement function, such as Horizontal displ. (vectors) or Horizontal displ. 

(wireframe). Add the Overlay options that you would like in the plot. When the final plot appears in 
the Coulomb 3.3 window, type “coulomb2googleearth” in the MATLAB Command Window, and hit 
return. You will get messages in the command window once files are saved.  

 
 

3. Then, you can drag the kml files onto the Google Earth icon on your computer dock or desktop, or you 
can open the files from the Google  Earth menu. 
 

 
 
 

 
Above we used “Landers-uniform-slip.inp” and Displacement > Horizontal Displ. (Vectors). 
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The figure above was made for the 2010 M=7.2 El Major-Cucapah, Mexico, earthquake using the input 
file, “Baja_CA_2010_eq.mat” and choosing surface Displacement Vectors. We have tilted the scene for 
perspective and exaggerated the relief to the maximum 3-fold level in Google Earth. 
 
4.  For color gradient images such as are created in the Coulomb stress change, Shear stress change, 

Normal stress change options, or the Vertical displacement (color) options File > Save As... pdf 
using the commands, renaming them. 

5.  Open the .pdf files in Illustrator or the graphics software you are using, and remove all the text and 
lines, keeping only the color (raster) image. Save the color image as .jpeg file, and name it  
“coulombmap.jpg” in the Coulomb directory. 

6.  Type “coulomb2googleearth” in the command window. This calls a script that is run by Coulomb. 
You will get the overlay kml file. 

 

 
 
In the preceding image, a Coulomb stress change image was added. Google Earth also lets you control the 
translucency of the jpeg. 
 
7. The full plugin script can be found in the “plugins” folder in the Coulomb33 folder. See the figure on 

the next page to see a color gradient map plus vcctor information. 
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8.5  Digitize Polygon Function (to create a lat/lon file of an arbitrary area, 
such as a stress-change contour)  

The “Digitize Polygon” function is useful for comparing a zone of Coulomb stress change with aftershocks 
or the seismicity rate change as calculated from the independent MATLAB program, ZMAP. 
 
1.   Make sure that you have selected the “lon. & lat.” Coordinate option in the Preferences menu. 
2. Run any 2D map view function in Coulomb, and then type “digitize_polygon” in the MATLAB 

Command Window, and hit return. Here, we have used “Example-SFBayArea.inp” selected a 
Coulomb mapview, and digitized a -3 bar stress shadow contour. 

 

 
 
3. The mouse becomes a digitizing cursor in the Coulomb main window. You will see a large “+” over 

the map (above left). To digitize, make multiple left-button clicks to circumscribe an area. Finalize 
and close the area by using a right-button click; the graphic will then show the completed area (above 
right). A window (left below) asks if you intend to digitize multiple areas; hit “no” if this is all you 
will do. The digitized file is saved in the Coulomb33 folder as “polygons1.dat”, etc. The first 8 lines 
are shown below at right; it is in lat/lon coordinates; western longitudes are negative. 

 

       
 

4. In ZMAP, you can move the file to the ZMAP folder and read it from the area selection function. For 
Stefan Wiemer’s ZMAP,  see http://www.earthquake.ethz.ch/software/zmap 

http://www.earthquake.ethz.ch/software/zmap
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Chapter 9  
  
Input File Structure 
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Numerical Output Files 
 
In addition to Coulomb’s internal graphics, you may want to analyse or plot the underlying numerical 
output, so all Coulomb graphics calculations produce a numerical output file with useful headers. These can 
be opened in Excel or brought into a rasterizing program for replotting. 
 
9.1  Map view displacement output file 
Every time when you click “Cal. & View” in the Displacement control panel, a text output file called 
“Displacement.cou” will be created or updated and saved in the sub-folder you designated in the Coulomb 
preferences menu (the default is “output_files”). When you want to save your latest runs, remember to 
rename the “Displacement.cou” file within the “Output files” sub-folder; otherwise it will be overwritten by 
your future calculations. Here is an example of “Displacement.cou” text output file. 
 

 
 
9.2 Map view strain output file 
Every time when you click “Cal. & View” in the Strain control panel, a text output file called ‘strain.cou” 
will be created or updated and saved in a sub-folder called “output files” within the “Coulomb 3.3 folder”. 
When you want to save your latest runs, remember to rename the ‘strain.cou” file within the “output files” 
sub-folder; otherwise it will be written over by your future displacement calculations. Following is an 
example of ‘strain.cou” text output file. 
 

 
 
9.3  Cross-section dilatation output file 
When you click “Cal. & View” in the Strain control panel and have selected the “Dilatation cross section” 
option, a text output file called “dilatation_section.cou” will be created or updated and saved in the sub-
folder.  
 
9.4  Map view Coulomb stress output file 
Every time when you click “Cal. & View” in the Stress control panel, a text output file called “dcff.cou” 
will be created or updated and saved. “Dcff” is an abbreviation for the change in the Coulomb failure 
function. When you want to save your latest runs, remember to rename the “dcff.cou” file within the 
“Output files” sub-folder; otherwise it will be written over by your future calculations. Following is an 
example of “dcff.cou” text output file. 

 
 
9.5 Cross-section Coulomb stress output file 
Every time when you click “Calc. & View” in the Cross section control panel, a text output file called 
“dcff_section.cou” will be created or updated. Remember to rename it if you want to save the latest cross 
section run, because “dcff_section.cou” will be overwritten. The following is an example of 
“dcff_section.cou” text output file. 
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9.6  Element Conditions stress output file for “Calc. stress on faults” option 
Every time when you select “Calc. stress on faults”, Coulomb produces an “Element_conditions.csv” file 
with the results in tabular form. It includes not only the specified rake you selected for the calculation, but 
also the maximum (most positive) Coulomb stress change and the associated rake for this maximum. 
 

 
 
9.7 Numerical output file for Focal mechanism calculations, 

Focal_mech_stress.csv 
Here is sample output of the focal mechanism file; you will see that it contains considerably more 
information than is contained in the graphical output. 
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