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Abstract

Introduction

The Tree Cover Mapping (TCM) tool was developed
by scientists at the U.S. Geological Survey Earth Resources
Observation and Science Center to allow a user to quickly map
tree cover density over large areas using visual interpretation
of high resolution imagery within a geographic information
system interface. The TCM tool uses a systematic sample grid
to produce maps of tree cover. The TCM tool allows the user
to define sampling parameters to estimate tree cover within
each sample unit. This mapping method generated the first
on-farm tree cover maps of vast regions of Niger and Burkina
Faso. The approach contributes to implementing integrated
landscape management to scale up re-greening and restore
degraded land in the drylands of Africa. The TCM tool is easy
to operate, practical, and can be adapted to many other applications such as crop mapping, settlements mapping, or other
features. This user manual provides step-by-step instructions
for installing and using the tool, and creating tree cover maps.
Familiarity with ArcMap tools and concepts is helpful for
using the tool.

Accurately mapping and monitoring tree cover over
vast areas represent a real challenge. There are a variety of
satellite-derived data that provide information about tree
cover over broad spatial extents, but most data are based on
satellite sensors with resolutions too coarse to observe isolated
trees or regeneration of trees or both. In dryland areas like
the Sahel, Africa, where trees are rare and sparse, satellitederived methods, such as automatic or semi-automatic spectral
classifications, are not effective to accurately map tree cover.
The Tree Cover Mapping (TCM) tool is a ArcGIS Add-In that
was created to facilitate tree cover mapping at a large scale
using visual interpretation of high resolution imagery. The tool
provides the infrastructure for a user to estimate tree cover
(in percent) within a defined sample frame. The TCM tool
aims to (1) facilitate panning and zooming to each sample,
(2) help estimate tree cover within a defined sample frame by
creating a calibrating dot grid over each sample, (3) enable
ArcMap extent to synchronize with Google Earth, and
(4) generate a map based on sample points. This user manual
provides step-by-step instructions for installing and using
the TCM tool, including creating raster maps. The manual
also presents examples of output products and illustrations of
additional applications.

Disclaimer
This software has been approved for release by the U.S.
Geological Survey (USGS). Although the software has been
subjected to rigorous review, the USGS reserves the right to
update the software as needed pursuant to further analysis
and review. No warranty, expressed or implied, is made by
the USGS or the U.S. Government as to the functionality of
the software and related material nor shall the fact of release
constitute any such warranty. Furthermore, the software is
released on condition that neither the USGS nor the U.S. Government shall be held liable for any damages resulting from its
authorized or unauthorized use.
The user of this software must acquire high resolution
imagery before using the tool.
SGT Inc., Contractor to the U.S. Geological Survey, Contract G15PC00012

1

Overview
The Tree Cover Mapping tool (hereinafter tool) is developed for the ArcGIS 10.x software by Environmental Systems
Research Institute (Esri). The tool was created in VB.NET
using Microsoft Visual Studio as a custom Add-In for ArcMap.
It was developed and tested on systems running Microsoft
Windows 7. The tool should function with other operating
systems supported by ArcGIS 10.x. The TCM tool is simple to
install and use, but requires creating a point grid feature layer
before mapping. Before using the tool, the user must create
a point sample grid, which will be used through the mapping
process using the TCM tool and high resolution images. After
all the samples are attributed, the user can convert the sample
grid to a raster map.
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Add-In Installation

Define sampling parameters
 Sampling interval
 Size of the sample frame
 Scale of work

Tool
requirements

1.

Double-click on the “TreeCoverMapping.esriAddIn”
file. The TCM Add-Ins are available from the authors
upon request.

2.

Click “Install Add-In” on the Esri ArcGIS Add-In Installation Utility screen.

3.

Click Ok at the Installation succeeded prompt.

Create sample grid
Point layer (shapefile)

Mapping

Output
and
data analysis

TCM Tool

High resolution
imagery

Final map

 Raster
 Heat -map (density map)

Figure 1. Overview of the Tree Cover Mapping (TCM) tool
process flow.

Software Requirements
ArcGIS 10.1 or higher and Google Earth are required
to use the TCM tool. Individual TCM Add-Ins are available
for each version. The TCM tool will automatically open and
synchronize ArcGIS’s window extent with Google Earth’s
imagery. The tool is most effective when using high resolution
imagery sources from Arc2Earth, Esri’s World View image
service, ArcBruTile, but other high resolution imagery sources
work as well. The TCM tool was tested with Arc2Earth.
Arc2Earth is an extension used to display Google
and Bing base maps in ArcGIS, created by the company
Arc2Earth, LLC. The extension is simple to install and adds
a Google and Bing toolbar to ArcGIS. The extension requires
a monthly subscription and can be purchased online at http://
www.arc2earth.com. Arc2Earth creates tile caches on the
user’s local hard drive, which allows the images to draw and
refresh quickly.
The TCM tool seems to perform best when using the
locally stored tile caches. The TCM tool was tested with other
high resolution imagery sources such as Esri’s image services,
but they did not perform as well because of the absence of
tile caching.

Figure 2. ArcGIS Installation Utility.

Installed Add-Ins are stored in the folder:
C:\Users\User Name\Documents\ArcGIS\AddIns\
Desktop10.x.ArcMap automatically locates the Add-In in this
folder upon opening.

Tool Installation in ArcGIS
1.

Open ArcMap.

2.

Choose Customize > Customize Mode.

3.

Select the Commands tab, under the Categories section,
choose “Resiliency Tools”.

4.

Under the Commands window a “Tree Cover Mapping”
item will appear. Left click and hold the “Tree Cover
Mapping” item, and drag it to the ArcMap toolbar
(fig. 3).

5.

Right click on the tree icon and a menu will appear.
To view text and your tree icon, choose the Image and
Text item.

Installation
The TCM tool is an ArcGIS Add-In that provides custom functionality to ArcMap. Before installing the Add-In, close all
open ArcMap applications.
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to create a map of tree cover density. In systematic and grid
sampling, samples are taken at regularly spaced intervals. The
sample grid, which is a point shapefile, defines the precision of
the analysis and the resolution of the output map.

Defining the Sample Grid Sampling Parameters
As mentioned in the “Mapping Requirements” section,
the user must define the sampling parameters of the sample
grid. Because tree cover mapping must be done using high
resolution imagery to be able to see the trees, the mapping
scale usually ranges from 1:6,000 to 1:2,000. The user must
find the balance between the number of samples desired for
the mapping analysis, the level of precision of the output map
(final resolution), the desired confidence level, and the level of
effort that can be dedicated to the mapping exercise.

Figure 3. Add Tree Cover Mapping button to toolbar.

1.

The sampling interval is the distance between each sample (point) that will define the resolution of the output
map. The sampling interval also influences the number
of samples over the study area.

2.

The size of each sample frame in which the user estimates tree cover. The size of the frame depends on
the mapping scale. For instance, at a mapping scale of
1:6,000 to 1:2,000, the frame has to be between 0.1 and
2 square kilometers (that is, between 310 and 1,300
meters in length).

3.

The scale of work (mapping scale).

View or Delete Add-Ins Loaded in ArcMap
Project
1.

Choose Customize > Add-In Manager.

2.

In the Add-In Manager window you can view and delete
all the Add-Ins installed under your project.

Creating the Sample Grid

Tool Requirements
Ensure Google Earth is open and running. Google Earth
will automatically synchronize its location and extent with the
ArcMap’s extent.

Mapping Requirements
The approach to tree cover mapping is sample based. The
user must create a systematic sample grid over the study area

1.

In the ArcToolbox, choose Data Management Tools >
Feature Class > Create Fishnet (figs. 4 and 5).

2.

Enter a name for your sample grid (Output Feature
Class).

3.

Choose a template extent, to define the study area
over which the sample grid will be created and used
for mapping. The extent can be entered by specifying
coordinates in the “Fishnet Origin Coordinate” boxes or
using a template dataset.
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4.

Enter the cell size in meters, which is your sampling
interval. No need to specify the number of rows or
columns.

5.

Check “create label points”. The resulting point layer is
the systematic sample grid layer to use for the mapping.

6.

Select the Environments tab > Output Coordinates, make
sure the “Output Coordinate System” is in meters. The
sample grid layer must have a Projected Coordinate
System (in meters), for example Universal Transverse
Mercator (UTM). Unprojected or Geographic Coordinate Systems will not work.

7.

Click “OK.”
Two layers will be created over the study area: a point
layer, which is the sample grid, and a polygon or polyline layer that can be deleted.

8.

The last step is to create a “Tree Cover” field in the attribute table of the sample grid layer where the tree cover
value will be recorded, for each sample. This new field
must be an integer. Open the sample grid layer’s attribute
table, click on the Table > Add Field. Specify a name,
select Short Integer for the Field Type and click “OK.”

How to Use the Tool
For the tool to work properly, the coordinate system of
the data frame and the sample grid layer must have the same
projected coordinate system.

Figure 4. Inputs required to create a systematic sample grid
using the “Create Fishnet” ArcToolbox.

1.

Click on the “Tree Cover Mapping” tool button in the
ArcMap toolbar.

2.

In the “Tree Cover Mapping” tool window, select the
sample grid layer and the sampling parameters (fig. 6).

Western Focus Zone

NIGER

N

NIGERIA
0
0

50
25

100
50

200 Kilometers
100 Miles

Figure 5. Example of a 4-kilometer systematic sample grid over a study area in south
central Niger.
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3.

Before attributing the first sample point in ArcMap,
the tool needs to be initiated. The user must manually
SELECT and zoom in to the first sample point to the
mapping scale, and enter the first tree cover value in the
“Tree Cover Value” box. Then, click “Next” or press
the “Enter” key. If the first tree cover value needs to be
reviewed, click on “Previous”.
A FormInputData.txt text file is automatically created
in the same directory as the sample grid layer. This text
file records the input data and the last sample that has
been attributed. DO NOT DELETE the FormInputData.
txt. When mapping a new project for the first time, if the

FormInputData.txt file exists, delete it. The .txt file will
be created after the first sample point is attributed.
4.

In each sample, the user estimates the tree cover value
based on the number of dots (red dots of the calibrating
grid) that touch the canopy of a tree. This value is an
estimate of the percent of tree canopy cover within each
sample frame (figs. 7 and 8).

5.

After clicking “Next”, the tree cover value entered by
the user is saved in the attribute table of the sample grid
layer in the “Tree cover” field. A new field, “Attributed”,
is automatically created in the sample grid attribute
table. The “Attributed” field records which samples have
been attributed and which have not. The number “1”
represents attributed samples (fig. 9).

Figure 6. Tree Cover Mapping tool.

Figure 7. Example of a sample frame
and the calibrating dot grid (graphic)
over high resolution imagery.
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Figure 8. Examples of tree cover density classes. The user must define the categories based on the needs and characteristics
of the study area.

From the Sample Grid to the Tree
Cover Map
Once all the points of the sample grid are attributed, the
user can convert the systematic sample grid to a raster.

Figure 9. Sampling parameters and corresponding
fields in the sample grid attribute table.

Figure 10. Feature to Raster Inputs.

1.

In the ArcToolbox, choose Conversion Tools > To Raster
> Feature to Raster (figs. 10 and 11).

2.

Choose the sample grid layer from the Input features
drop down box.

3.

Select the Field from which the raster will be created
(the “Tree Cover” integer field).

4.

Select the “Output cell size”, which is the sampling
interval (that is, the resolution of the output map).

Because the sample grid is a systematic point layer,
additional geographic information system (GIS) analysis
can be done, such as Zonal Statistics and heatmaps
(using Kernel Density or Point Density functions) (see
application examples).
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Figure 11. Example of a 4-kilometer tree cover density raster map from a systematic sample grid (1
sample every 4-kilometers) over a study area in south-central Niger.

Application Examples
Application 1—Tree Cover Mapping
Title: On-farm tree cover mapping in Burkina Faso and Niger
Purpose: Baseline mapping of on-farm tree cover in some
regions of Burkina Faso and Niger to support the U.S.
Agency for International Development/ Sahel Regional
Office (USAID/SRO)—Resilience In the Sahel Enhanced
(RISE) program.
Study Area: 175 communes covering 235,200 square kilometers

Imagery source: Bing maps and Google Earth from
Arc2Earth (2012 to 2014)
Sampling Parameters:
• Sampling interval: 2,000 meters
• Size of the sample frame: 330 meters
• Mapping scale: 1:3,000
• Total number of samples: 29,757 points
Mapping time: About 1 month
Output maps: (figs. 12, 13, and 14)
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Figure 13. Example of average on-farm tree cover map by commune in the RISE zones of Niger and Burkina Faso.
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Figure 14. Example of a heat map of on-farm tree cover in the RISE zones of Niger and Burkina Faso.
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Application 2—Settlements Mapping

Similarly to trees, settlements in rural areas can be
challenging to map using automated/semi-automated
classifications of spectral images. The TCM tool facilitates
using visual interpretation of high resolution imagery to estimate settlements density over large areas.
Title: Settlements mapping in Unity State in South Sudan
Purpose: Baseline mapping of settlements density in a conflict
area in South Sudan, in support of the U.S. Geological Survey/
Famine Early Warning System program.
Study Area: 4 communes in Unity State, South Sudan:
12,500 square kilometers
Imagery source: Bing maps and Google Earth from
Arc2Earth (2011 to 2014)
Sampling Parameters:
• Sampling interval: 2,000 meters

• Size of the sample frame: 2,000 meters

• Mapping scale: 1:9,400

• Total number of samples: 3,242 points

Mapping time: 6 hours
Output raster map: (fig. 15)

GUIT

KOCH

Settlements density

EXPLANATION

No settlements

1–5%

5–10%

20–25%

MAYENDIT

LEER

10–15%

15–20%

>25%

N

Figure 15. Settlements coverage in Unity State, South Sudan.
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FAQ—Troubleshooting
Why does my ArcMap project crash?
Sometimes creating the calibrating grid causes ArcMap to
crash because of a projection issue. Make sure the data frame
and the sample grid layer are projected (in meters), for example in a coordinate system Universal Transverse Mercator
(UTM).
Find more about projecting data in ArcGIS at http://support.
esri.com/de/knowledgebase/techarticles/detail/20118.
Make sure Google Earth is open and running before using
the tool.

I received a new version of the Tree Cover Mapping
(TCM) tool, how do I install it?
Delete the old Add-In before installing the update. In ArcMap,
choose Customize > Add-In Manager > Add-Ins tab. Select the
Add-In to delete and click on the “Delete this Add-In” button.
Then, install the new Add-In as described in the instructions
(see Installation section).

I get an Inputs Unhandled Exception Error, how do I fix it?
Click on the “Continue” button and make sure Google Earth is
running before using the TCM tool.

Why doesn’t the Calibrating Grid draw?
The calibrating grid does not draw as soon as the checkbox
in the TCM tool is clicked. It only draws when the “Next” or
“Previous” buttons are clicked.

Can the calibrating dot grid and frame generated around
each sample point be disabled and re-enabled, that is,
turned off and on, and if so, how?
The calibrating grid (red dots) can be turned off by unchecking
the “Calibrating grid” checkbox in the TCM tool.
The black frame is always visible and cannot be turned off, but
because it is a graphic it can be selected and deleted manually.

Can I return to the last sample point I attributed?
Yes, use the “Previous” button located near the “Next” button.
The “Previous” button will take you to the previous sample
and the value that you previously attributed. The sample value
is visible under the “Existing Tree Cover Value” text.

Is it possible to reorder the samples?
Yes, first create a new integer Identifier (ID) field in your
sample grid attribute table. Toggle the sample grid layer into
editing mode. Then select your samples over one image and
manually change their ID (from 1 to 20 for example). You
can also use the Field Calculator from the sample grid layer

attribute table and automatically generate an ordered ID as
described here: http://support.esri.com/en/knowledgebase/
techarticles/detail/38517.
The ID field must be ordered in a numeric sequence for the
tool to work efficiently.
Change your “Sample ID” field on the TCM tool input form.

Is it possible to attribute a temporary value in the
Tree Value field? Or to jump to one sample ID without
inserting a value, or to signal that the sample ID must be
reanalyzed?
Yes, it is possible as long as the entered value is a number. For example, use 99 or 999. Then you can easily find
these samples in the attribute table and query them.
See select records by attribute: http://help.
arcgis.com/EN/ARCGISDESKTOP/10.0/HELP/index.
html#//001700000071000000.

Can I change the map scale on the TCM tool input form?
Yes, the scale value can be changed on the TCM tool input
form, see How to Use the Tool section.

Do all of my layers in the ArcMap document need to
be projected?
No, only the data frame projection and the sample grid layer
projection are required to be in meters for the TCM tool to
work properly. The UTM projection is an example of a coordinate system stored in meters.

Why does it take so long to move from one point to
the next?
The imagery source may be causing the TCM tool to perform
slowly. A tiled imagery source or image base map is recommended. The tool was tested with Google and Bing services
from Arc2Earth.

Where can I learn more about Arc2Earth?
Arc2Earth is an extension used to display Google and Bing
base maps in ArcGIS, created by the company Arc2Earth,
LLC. The extension is simple to install and adds a Google
and Bing toolbar to ArcGIS. The extension requires a
monthly subscription and can be purchased online at http://
www.arc2earth.com. Arc2Earth creates tile caches on the
user’s local hard drive, which allows the images to draw and
refresh quickly.

Can I use my own high resolution imagery with the
TCM tool?
Yes, the TCM tool has been tested using only Arc2Earth,
but is intended to accommodate other imagery such as Esri’s
World View image service, ArcBruTile, as well as any high
resolution imagery sources.

FAQ—Troubleshooting  11
In ArcGIS 10.0 or later versions, high resolution imagery
display performance can be enhanced by adding your imagery
into a basemap layer. See the link below for more information:
http://help.arcgis.com/En/Arcgisdesktop/10.0/Help/index.
html#//00s500000017000000.

The Tree Cover Mapping button disappeared from
ArcMap. How do I get it back?
To view or delete an Add-In from your ArcMap project,
choose Customize > Add-In Manager > Add-Ins tab. Select the
Add-In to delete and click on the “Delete this Add-In” button.
Then, re-install the Add-In as described in the instructions (see
Installation section).
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