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Abstract
The handbooks and synchronized MP4 recordings 

provide hands-on instruction for creating and analyzing 
vegetation live fractional cover (LFC) maps. The methods 
and protocols used in the instruction materials follow those 
developed and recorded in Rangoonwala and Ramsey (2019). 
The LFC mapping and geographic information system (GIS) 
analyses highlight the consortium of rangeland conservancies 
covering the semiarid central region of Kenya (approximately 
44,000 square kilometers). 

The instruction materials are separated into two parts: 
processing and map-product creation based on remote-sensing 
images and GIS analyses of the created maps for rangeland man-
agement. The image processing is conducted using the advanced 
and professional software package SeNtinels Application Plat-
form (SNAP) that is supported and maintained by the European 
Space Agency. SNAP is a free image analyses software pack-
age available for download. It is largely icon driven but offers 
simple to advanced program inserts and batch processing. The 
GIS analyses are conducted using the software package Quan-
tum Geographic Information System (QGIS), another free and 

downloadable software. QGIS is compatible with numerous soft-
ware, including the Esri suite of ArcGIS software and database 
structure. The image data includes both high-spatial-resolution 
Sentinel-2 optical data and Sentinel-1 synthetic aperture radar 
(SAR). Both datasets are freely available via a public portal that 
is maintained by the European Space Agency.

The image-processing instruction handbook covers all 
aspects of acquiring and processing satellite-image data and 
importing vector-data sources into SNAP. The GIS analysis 
handbook covers final creation of map products from the maps 
created in SNAP and creation of GIS procedures in QGIS that 
are needed to manage the rangeland resources for wildlife and 
pastoral grazing. Although focused on the Kenyan conservan-
cies and their semiarid environment, the processing methods 
and procedures are applicable for similar environments and 
management, and to a large part, even for integrated mapping 
and GIS functionality of any managed landscape resource. 

The instruction handbooks are synchronized to MP4 
training videos created with U.S. Geological Survey-licensed 
Camtasia 9 software. 

The workbook and MP4 video combinations are suitable 
for a single user or a workshop setting. 





Section I—Image Processing Training  
Workshop

Mapping Live Grassland Cover with SeNtinel’s  
Application Platform (SNAP) Processing of  
Satellite Optical and Synthetic Aperture Radar  
(SAR) Image Data

This Remote Sensing workshop is designed for spatial analysis personnel for creating live 
vegetation fractional cover maps with SeNtinel’s Application Platform (SNAP) software. The 
workshop provides the skills needed to: 

•	Search and import Optical and Synthetic Aperture Radar (SAR) image data. 

•	Use the image processing toolset to transform the satellite optical image data to maps 
that represent live vegetation cover.

•	Use the specialized SAR image processing toolset to create maps from satellite SAR 
data indicating the vegetation cover density. 

•	Add value to the produced maps by portraying thematic information with color rendering.

Objective: 

•	Although the procedures learned can be applied to remote sensing processing of any ras-
ter image, this course is specific to the production of live cover status and change maps 
in the management of the Northern Rangelands Trust (NRT) natural resources.

Sera Conservancy landscape along a section of A2 
highway within the Northern Rangelands Trust (NRT) 
Conservancies, Kenya. June 22, 2018. Photograph by 
Elijah Ramsey, III, Oceanographer; U.S Geological Survey.
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Optical image data processing—
Sentinel 2 
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1. Downloading Sentinel-2 image data using Copernicus Open Access Hub.  
Note that the image data can be downloaded from the ESA “Copernicus Open Access Hub” NOT the 
“Copernicus data service Hub” site. Registration is required to download data. 
https://scihub.copernicus.eu/dhus/#/home 
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Once the image is loaded in SNAP, right click on the product file and select open RGB window; 
select false color infrared from the drop down in the Select RGB channels dialog box. 

Example shown for one image; open all other required 
images you have downloaded, and apply  
RGB rendering.  

2. Open image data in SNAP. 
Open SNAP software. Go to Menu>File>Import>Optical Sensors>Sentinel 2. Select S2-MSI-L2A; 
the dialog window shown below and go to the folder where the data resides; select the *.xml file 
(MTD_MSIL2A). 



Section I—Image Processing Training Workshop﻿    5

 

 

 

 

  

Apply this resampling process to all images.  

3. Resampling and mosaicing the images. 
3A. Resample images to be used in the mosaic.  

Menu>Raster>Geometric Operations>Resampling. 
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Click to open Band Chooser Window 

3B. Mosaic images. 

Go to Menu>Raster>Geometric Operations>Mosaicing. 
Select the two resampled images for mosaicing. Follow the steps shown below. 

 
2 

Zoom into world view to see 
mosaic overlay. 

Click the + symbol to add product. A new 
dialog window opens; navigate to target 
directory and select the *.dim file. Click 
Enter to add file to input product list in 
SNAP.  

1 

3 

Variables and Conditions Window 

Click Run after completing 1, 2, 3, and 
4.  

4 
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Run Band Maths for both B4 and B8.  

4. Creating modified soil-adjusted vegetation index 2 (MSAVI2). 
4A. Multiply B4 and B8 by 100.0 to scale output.  

Right click on the mosaic product to get Band Maths dialog box.  
 

 

4B. Calculate MSAVI2 with Band Maths. 

MSAVI2 equation from Qi and others, 1994. 
(2* n100B8+1- sqrt(sq(2* n100B8+1)-8*(n100B8- n100B4)) )/2.0 
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4B. Continued. The MSAVI2 processor in SNAP gives the same result as in Rangoonwala and 
Ramsey (2019), who used the equation based on Qi and others (1994). 
Menu>Optical>thematic land processing>vegetation radiometric indices.  

4C. Optical Image Calibration.  

 Using the developed model discussed in Rangoonwala and Ramsey (2019) (page 16, equation 4), to 
convert satellite MSAVI2 to Field MSAVI2 (MSAVI2_2018+0.0018)/0.877). 
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After the convert process finishes, open the *_Cnv.data folder. The name of the *.img will 
be the name of the band converted with the *.img extension. This Veg map *.img file will 
be used in QGIS. 
 

5B. Convert the VegMap from decimal format to integer (8U) format.  

Menu>Raster>Data Conversion>Convert Datatype. 
 

Note: Use the same procedure to calculate the 2019 VegMap (LFC). 

 

5. Creation of Live Vegetation Fractional Cover Map. 
5A. Using the developed model in the OFR as stated in 4C.  

Use equation 3 on page 16 of Rangoonwala and Ramsey (2019) to convert Field MSAVI2 to Field 
Web Cam LFC (VegMap) (103.89*MSAVI2Sat2Field), while multiplying the VegMap by 2.55 to 
stretch the 0–100 percent range to the full 8U range of 0–255.  
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Copy Mosaic_Tile5_8_May2019Veg to Mosaic_Tile5_8_June2018Veg  
Important: Save the session. Otherwise, problems may occur when 
opening files. Message appears in SNAP when copying 2019VegMap 
using band math.  

6. Create the 2019-2018 Difference VegMap map. 
6A. To copy an image in another SNAP product image using Band Maths.  

To create a difference image, it is important that both the 2018 and 2019 vegetation maps be in the same 
SNAP product (SNAP database). Follow the screen captures below. 
 

6B. Calculate the 2019Veg-2018Veg Difference.  

 

Change 0.0 to NaN 
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6C. Transforming the decimal VegDiff image to an integer format. 

Small differences (1–2 percent) were noticed between the VegDiff map created in SNAP and the same 
VegDiff map created in PCI Geomatica, another image processing software. The difference arises 
because SNAP processes all image data as real, while other software provide signed and unsigned 16-
bit processing.  

6D. Limit the upper VegDiff to 100 percent.  

The actual upper limit of the difference was 113 and the lower limit −114. The upper limit is cut off 
at 100 percent LFC difference. 
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255)

6E. Scale the 16S image from 0 to 100 to 0 to 255.  

Scale the image using the min and max −114 and 100 to 0 to 255 (16Sto255_DiffVeg2019-2018). 
See Band Maths expression above [((B3--114)/(100--114))*255]. B3 is the 16S image data input 
per pixel and −114 and 100 are the 16S min and max. The equation converts the 16S image values 
from 0 to 1 so multiplication by 255 outputs an image with a 0–255 range.  

Although rounded as shown in 6E, the 16S image is still in a float or real format. The SNAP 
Convert Datatype outputs the data as a 0–255 8-bit unsigned image. The conversion to the 8U 
from the 16S format provides a less complex data structure for color renditions and GIS 
analyses.  

6F. Convert the 16S band to 8U numerical format.  

 Menu>Raster>Data Conversion>Convert Datatype. 
Convert Datatype creates a separate product with a *.Cnv extension. 
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After export, save the product in 
SNAP. Navigate to the directory 
and find the *.nc.data folder.  

Open the directory. There will be an 
*.img file. The name of the *.img is 
the name of the band exported with 
the *.img extension.  

Navigate to Directory to store exported 
files. SNAP will create a directory at 
that location with the SNAP project 
name and the *.nc.data extension.  

7. Export of the black and white VegDiff map. 
 

Click the b_w16Sto256_DiffVeg2019-2018 file 
that was created by Convert Datatype. Click File in 
the header information; drop down to Export and 
choose the NetCDF4-CF option for export format.   
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8A. Creating a color ramp in SNAP. 

View the black and white target image in SNAP. Click Color Manipulation as shown below. Click on 
100 percent in the set of icons to the right of the histogram. To add sliders, right click on the black 
and white color bar below the histogram and an Add New Slider message box appears. Add slider. 

8. Create a color ramp in SNAP for the LFC status and change maps. 
The color rendering of the LFC maps in SNAP provides a first check on the created products. To 
provide that assessment, we will develop and apply a color ramp to LFC status and difference maps.  

Next, set slider color by clicking 
on the slider triangle; click RGB 
on the popup Select Color 
dialogue box. Set the Red, Green 
and Blue color values or use 
color code. Click OK.  
For Vegetation Status Map:  
Set Color for lower limit RGB 139, 
69, 19; color code # 8b4513. 
Set Color for upper limit RGB 154, 
205, 50; color code # 9acd32. 

A color ramp was customized for 
the vegetation status maps; the 
upper and lower sliders 
(breakpoints) were defined to keep 
a uniform color lookup table. 

100%  
Click here 

Color  
Manipulation 

Slider positions 
initially set 
automatically. 
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Colors 0–100 Break Points 0–255 Break Points Red Green Blue Hexadecimal 

Blue −44.0 83.41 0 0 255 0000ff 

Cyan −26.35 104.44 0 255 255 00ffff 

Green −8.35 125.89 0 255 0 00ff00 

Yellow 9.65 147.34 255 255 0 ffff00 

Red 27.65 168.79 255 0 15 ff000f 

Pink 45.29 189.81 255 160 255 ffa0ff 

The example below shows the slider color changed after clicking OK on the screen 
capture shown above. The box shown to the right of the slider (highlighted) contains the 
present slider position on the color ramp. Change this number to position the slider to 
breakpoints as shown in 8B. 

8B. Convert the 0–100 percent breakpoints to 0–255 percent breakpoints (two-tile breakpoints). 

Convert the 16S breakpoints to 8U breakpoints in Excel (recommended), if available (or an open 
source workbook), for example ((−44--114)/(100--14))*255=83.41. 
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9. Color renditions across raster files with different data types. 
The examples below created in SNAP show the different color renditions when applying 
breakpoints from a 16S color rendition to the same image converted to an 8U data type.  

 9A. Application of real data format (32-bit or 16-bit) breakpoints to 8U image data format. 

9B. Application of the 8U breakpoints to the 8U image data format.   
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Notes on applying color ramp in SNAP and QGIS: To retain the color rendering from image to image and 
from software platform to platform, the same breakpoints must be set at the same positions and colors. If 
applying a color rendition taken from a 16S data format to one with an 8U format, prescaling of the data 
and breakpoints is necessary. Even with scaling, application of color rendering from one data format 
(source) to another (target) may require adjustment of the target range to get the rendition of the target to 
exactly mimic the look of the source rendition.  
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Save Sen2Cor to the Program directory. 
Open the DOS cmd window. 
C:\> cd data 
C:\Data>cd Sen2Cor 
C:\Data\Sen2Cor>cd Sen2Cor-2.4.0-win64 
C:\Data\Sen2Cor\Sen2Cor-2.4.0-win64>L2A_Process.bat –help 
 

10. Atmospheric correction of Sentinel-2 images using ESA software.  
 Note: The ESA hub does not have all scenes atmospherically corrected (MSIL2A). Therefore, MSIL1C 
files must be atmospherically corrected using a DOS-based software called Sen2Cor from ESA. 

 10A. Install Sen2Cor (SNAP atmospheric correction software). 

Go to http://step.esa.int/main/snap-supported-plugins/sen2cor/. 
 

Arrow shows the 
command typed 
to execute the 
L2A_ Process.  

10B. The atmospheric correction process. 

Note: Run the full atmospheric process (that is, L2A_Process) for all resolutions as the cloud mask and 
land classification are created for 20-m resolution. The command in CMD window for L2A_Process is 
C:\Data\Sen2Cor\Sen2Cor-2.4.0-win64\L2A_Process D:\Data\i\KENYA_2017\ Sentinel2A\June2017\ 
Tile 5\Sen2Cor\ 2A_MSIL1C_20170628T075211_N0205_R092_T37NCB_20170628T075749.SAFE  
Note: L2A_Process will process all spatial resolution images and all ESA produced ancillary products. 

Note: The atmospherically corrected output file will have a similar name, except that MSIL1C is 
changed to MSIL2A created output file name listed below:  
S2A_MSIL2A_20170628T075211_N0205_R092_T37NCB_20170628T075749.SAFE 
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Synthetic Aperture Radar (SAR) 
image data processing—Sentinel 1 
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11. Sentinel-1A SAR image data. 
 11A. Opening the SAR image in SNAP. 

After downloading the SAR images, unzip the download folders and Import in SNAP the 
*.manifest.safe file.  

 11B. Calibrate the SAR image data to sigma naught. 

Menu>Radar>Radiometric>Calibrate. Next, set I/O Parameters and Processing Parameters in the 
Calibration dialog box. In I/O Parameters, create a new output directory for the SNAP output files. 
Enter that folder name under Target Product> Directory and the product filename under Name. In 
Processing Parameters, select both VH and VV Polarisations and click Output sigma0 band.  

SNAP creates a pointer file *.dim that is saved in the output directory containing the 
calibrated image data.  
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11C. Perform terrain correction and spatial resampling of the calibrated SAR image. 

Go to Menu>Radar> Geometric>Terrain correction>Range-Doppler. 

This process takes more than 1 hour to complete. 

11D. Perform Speckle Filtering of the Calibrated and Terrain Corrected SAR image. 

Menu>Radar >Speckle Filtering>Single Product Speckle Filter. 
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12. Create mosaic of the four radar scenes processed with speckle filter. 
 (for example, S1A_IW_6Dec2019_1064_Cal_TC_Spk.dim)              
Menu> Radar>Geometric>SAR-Mosaic. 

It took 35 mins to complete the mosaic process 

To view the mosaic, double click on one of the bands to view it. Because it is a large file, it 
will take about 10 minutes to bring up the image.  



﻿  Synthetic Aperture Radar (SAR) image data processing–Sentinel 1    23

 

 

 

 

 

 

 

 

 

 

 

  

13. Pixel value extractions. 
13A. Input Image data file.  

Working on the same mosaic file created on preceding page (section 2, page 22).  
Menu> Raster>Export>Extract Pixel Values. In the dialog window Pixel Extraction under Input/Output 
tab (screen capture 1), Source Path is defined as the mosaic image that is already opened in SNAP; 
specify the path of the output directory and a prefix for the output filename. Next, click the Parameters 
tab and use the parameters specified in screen capture 2.  

1 2 

The output for a 3X3 window is shown above. The upper left pixel in the 3X3 window is 
highlighted in the graphic. Check the highlighted pixel position value in the image and the top 
value (1 of 9) in the output table shown above. Sigma VH and sigma VV should match in the 
table and in the image.  
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Menu>Raster>Export>Extract Pixel Values. 
Fill out Extract Pixel Values dialogue boxes as shown below and click on Extract.  

13B. Input coordinate file.  

Create an Excel data sheet following the format shown on the Excel sheet below. Save the Excel 
file as a Text tab delimited (*.txt) file. The text input with latitude/longitude coordinates can be 
input in the Pixel Extraction Parameters dialogue box shown on right. Click on the + icon in the 
Coordinates section and select Add coordinates from file …; navigate to the saved tab delimited text 
file and load file into the Coordinates dialogue box as shown below on the right.  

Excel Text 

Input 
Coordinate 
Text 
tabular file. 
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14A. Using SAR data as an indicator of vegetation density. 

- Load the 2019 SAR image mosaic of core-NRT.  
- Use the RGB function to create a color rendition of the VV and VH SAR bands. 

Put VH in the red and green color band and the VV in the blue color band.  
- Apply the leaf area index (LAI, density indictor) calibration to the SAR VH/VV 

ratio image. LAI = 6.02 * VH/VV – 0.40. (This equation is provided in the OFR, 
page 82, figure 42; https://pubs.er.usgs.gov/publication/ofr20191037). 

- The upper limit of the calibration equation is 3.2 LAI. Use SNAP tools to exclude 
mapped LAI values greater than 3.2. 

 

14. Create a ratio band VH/VV.  
The VH return is a mixed polarization return of the VV send amplitude. The vegetation 
normally is typified as a mixed orientation of elements (plant leaves and stalks) that scatter a 
portion of the like (linear) polarizations (VV) into nonvertical or horizontal orientations, 
typified as VH. The ratio indicates vegetation component of scatter. 
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15. Create a subset to match the subset of the 2018 S1A mosaic. 
This section illustrates the steps required to create a subset; how to note the coordinates of the 
reference image (here subset 2018 S1A mosaic); and how to use these for subsetting the 2019 S1A 
mosaic image. To note the geocoordinates of the 2018 subset, go to Menu>Analysis>Geo-Coding. 
Note the upper right latitude, upper right longitude, lower left latitude, and lower left longitude. These 
will be used to make the subset. The dd mm ss must be converted to decimal degrees.  

Menu>Raster>Subset. In the Specify Product Subset dialog box, under 
Spatial Subset north latitude=upper right latitude (from the Geo-Coding window 
above), west longitude = lower left longitude, south latitude= −lower left latitude, east 
longitude = upper right longitude. Next, under Band Subset, select both Sigma0_VH, 
and Sigma0_VV, under Metadata Subset click Select all. 
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Section II—Geographic Information System 
Training Workshop

Quantum Geographic Information System (QGIS)  
Analysis of Grassland Live Fractional Cover  
Maps for Management of Wildlife and Pastoral  
Grazing

This GIS workshop is designed for resource managers as a beginner level hands-on training 
course. The workshop demonstrates the application of basic procedures in GIS:

•	Import, connect, and explore geographic information of various formats.

•	Create and edit geographic information.

•	Query, analyze, and present geographic information.

Objective: 

•	Although the procedures learned can be applied to GIS analyses of any raster or vector 
data, this course is specific to the use of Live Fractional Cover (LFC) status and change 
maps in the management of the Northern Rangelands Trust (NRT) natural resources.

Typical Leparua Conservancy landscape within the 
Northern Rangelands Trust (NRT) Conservancies, 
Kenya. December 3, 2019. Photograph by Elijah 
Ramsey, III, Oceanographer; U.S Geological Survey.
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Download QGIS from: http://www.qgis.org/. 
Install the 3.8 Zanzibar version or the latest available 3.10. 
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Map canvas 

1. Setting up QGIS.  
 
1A. Getting started.  

Set up the browser and layer: Menu>View> Panels. Click browser, layer, and processing toolbox. 

1C. Save project.  

Menu>Project>Save As. Go to the relevant folder (QGIS_workshop) and save as *.qgz. 

1B. Set language. 

Settings > Options > General. Set to English and do not change the default options which are 
already clicked.  
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EPSG: 3857 covers a larger 
area. 
https://maps.omniscale.com/
en/openstreetmap/crs  
[Click the CRS to get more 
information; this shows the 
areas covered by the 
respective CRS.] Also, the 
open street map and Google 
layers use the EPSG:3857. 
These layers are 
transformed to the CRS 
selected for the project. 
 

 Click OK.  

1D. Set Coordinate Reference System.  

Menu>Project>Properties. Select the projection for Kenya at: 
http://downloads.gvsig.org/download/geodata/EPSG_codes/Projected_Coordinate_Reference_Systems.pdf. 
EPSG: 32637  WGS 84 / UTM zone 37N.  Filter 32637 or Select EPSG: 32637 
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2. Add Google Maps layers (Google Earth) in QGIS. 
Adapted from https://geogeek.xyz/how-to-add-google-maps-layers-in-qgis-3.html. 
To add the Google Maps Tile Map Service (TMS) in QGIS, go to XYZ Tiles in the Browser 
panel. Click  New Connection; right click  XYZ Tiles. 
 

Enter the name: for example, Google Satellite. Copy and paste one of the Google Maps TMS 
listed on page 33 into the URL. Adjust the maximum zoom level (19). Click OK. 
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Once all layers are added to the XYZ Tiles in the Browser window, right click the applicable 
layer and select Add Layer to Project. Save the project.  

Links to download the Google map layers: 
Google Maps: https://mt1.google.com/vt/lyrs=r&x={x}&y={y}&z={z} 
Google Satellite: http://www.google.cn/maps/vt?lyrs=s@189&gl=cn&x={x}&y={y}&z={z} 
Google Satellite Hybrid: https://mt1.google.com/vt/lyrs=y&x={x}&y={y}&z={z} 
Google Terrain: https://mt1.google.com/vt/lyrs=t&x={x}&y={y}&z={z} 
Google Roads: https://mt1.google.com/vt/lyrs=h&x={x}&y={y}&z={z} 
 

- To open the Python Console, go to Plugins Menu >> 
  

- In the Python Console window, paste in the script that you copied from the URL link above. 
Run it and you will see a list of base maps under the XYZ Tiles in the Browser panel. 

Link for Python scripts: 
https://raw.githubusercontent.com/klakar/QGIS_resources/master/collections/Geosup
portsystem/python/qgis_basemaps.py 
 

One can also bring in the Google layers using python code.
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2A. The Open Street Map is provided as a default XYZ tile or is available in the plugin in 
QGIS 3 versions. 

If the OpenStreetMap raster tile is not available, follow the next steps: 
Go to https://wiki.openstreetmap.org/wiki/Tile_servers. 
Here, you will find a list of online raster tile servers based on OpenStreetMap data. 
Select an OpenStreetMap Standard tile layer and copy the URL: 
https://a.tile.openstreetmap.org/${z}/${x}/${y}.png. 
Go to XYZ Tiles > Right click > New Connection > Name (we will call it OpenStreetMap)> URL 
(Paste the URL; do not forget to delete the “$” signs when pasting the URL). Click OK. 
 

URL for open topo map: 
https://tile.opentopomap.org/{z}/{x}/{y}.png. 
Add another useful plugin QuickOSM*. To add plugin follow the steps as shown in 
https://www.qgistutorials.com/en/docs/3/downloading_osm_data.html. 
 

https://www.qgistutorials.com/en/docs/3/downloading_osm_data.html
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2B. Add vector layer.  

For this workshop, the following folder has been created:  
\Data\QGIS_Training\ Feb2020_QGIS_WorkshopKenya\ShpFiles.  
Menu>Layer>Add Layer>Add Vector Layer. 
 

Geospatial 
Data 
Abstraction 
Library 
(GDAL) is 
used in QGIS 
for reading and 
writing raster 
and vector 
geospatial data 
formats. 

Menu>Layers>Layer 
Properties. Click 
Simple line and set 
Color and Stroke width.  
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OR  
Drag and drop the *.img file.  

Browse to the relevant folder 
and add the 2 years of 
vegetation status maps created 
in SNAP.  

2C. Add raster layer. 
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Next, save Color Ramp; see screen capture 
4 on page 38. 

 

3. Color rendering raster layer.  

Go to Menu>Layers>Layer Properties>Symbology>Band Rendering>Renderer> Singleband 
pseudocolor. Drop down on the Color ramp and select Create New Color Ramp; select Gradient, 
set Color 1 and Color 2 by using the drop down to choose a color. Set the RGB colors by entering the 
value to the right of each color (0–255) or by entering the hexadecimal equivalent in the HTML 
notation. Repeat these steps for setting the second color (follow screen captures 1, 2, 3, and 4). 

 

Set Color1 RGB 139, 69, 19; HTML notation 
#8b4513 
and Color2 RGB 154, 205, 50; HTML notation 
#9acd32. 

2 3 

1 
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Save color ramp; Menu>Layers>Layer Properties>Symbology.  
Drop down Color Ramp; Save Color Ramp and click Apply; Type Name and Tag, click Add to 
Favorites and Save.  

Created Color Ramp applied to the image target. 
 

4 

Applying the color ramp sometimes brings up extra zeros and (or) 255.  
To delete one of the two 255 stops, highlight the last 255 stop and click 
the red minus sign and Apply. Click OK. 
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To make the 
background black 
transparent  

Click Layer> Layer Properties>Symbology. Set minimum to the SNAP minimum>double 
click the minimum value and set opacity to zero. See screen capture below. 

3A. Make color transparent.  
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 Two-tile mosaic breakpoints Nine-tile mosaic breakpoints     
Color 8U-16S -255 8U–100% 8U-16S -255 8U–100%  Red Green Blue Hexadecimal 
Blue 83.41 32.6 0 0 0 0 255 0000ff 
Cyan 104.44 40.8 50.0083 19.61 0 255 255 00ffff 
Green 125.89 49.2 101.0083 39.61 0 255 0 00ff00 
Yellow 147.34 57.6 152.0083 59.61 255 255 0 ffff00 
Red 168.79 65.9 203.0083 79.61 255 0 15 ff000f 
Pink 189.80 74.1 252.9883 99.21 255 160 255 ffa0ff 

3B. Color rendering raster layer with gradient stops. 

Add the vegetation difference image created in SNAP(b_w16Sto256_diffVeg2019-2018): 
Menu>Layers>Layer Properties>Symbology>Band Rendering>Render type>Singleband 
pseudo color. Drop down on the Color ramp and select Create New Color Ramp select 
Gradient, set Color 1 and Color 2 by using drop down to choose a color. Color 1 RGB–0, 0, 
255; hexadecimal # 0000ff; Color 2 RGB–255, 160, 255; hexadecimal # ffa0ff. 

Next, set the gradient colors. Double click 
the top gradient color bar to add a 
Gradient Stop. For this pseudocolor table 
(PCT) we need six gradient stops plus the 
two endpoints, Color 1 and Color 2. Set 
the RGB or hexadecimal values for the 
color. 
Set the relative position of the stop under 
Gradient Stop. The gradient bar only 
extends from 0 percent to 100 percent. 
Divide your 0–255 breakpoints by 256 to 
get the 0 percent to 100 percent estimate 
and use those to set the relative position. 
QGIS will automatically convert these to 
0–255 equivalents. The relative position 
values are given in the table below. 
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Note: Bringing up the color ramp adds extra 0 and 255 gradient stops.  

To delete one of the two zero 
stops, highlight the first zero 
stop and click the red minus 
sign. Click Apply, then OK. 

delete 

Tip: For adding or deleting Tags, Smart Groups, or a Color ramp, go to Settings 
and open Style Manager. In the Style Manager, right click the tag you want to 
delete then remove the tag. You can also add a tag in the same way. Go to All in 
the Style Manager to remove or edit all items.  

After finalizing and saving the color 
ramp, make sure that the Band 
Rendering>Render type is Singleband 
pseudocolor, then click Apply.  

After creation of the color ramp, it is 
important to save it by clicking on 
the Color ramp drop down and 
clicking Save. This adds the created 
color ramp to the color ramp library. 
When saving, it will prompt for a 
tag, which is a descriptor used to 
describe and identify the color ramp. 

3C. Save the created color ramp and apply it to the black and white image. 

Example shows 
break points for 
two-tile mosaic. 
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Change Render type at the top of the box to Singleband pseudocolor.  

To load and attach a color ramp to a black and white, singleband image file, open the Layer 
Properties dialogue box. Click the Menu Layer link, then the Style button at the lower left corner 
of the box and Load style [*.qml]. The created color ramp can also be saved in this box as a 
[*.qml]. Click Apply at the bottom of the dialogue box. To save the color ramp as a text file, click 
the disc icon at the bottom of the Min/Max Value Settings on the same dialogue box. To load a 
text color ramp, click the folder icon located left of the disc icon.  

3D. The color ramp can also be saved as a *.txt and a *.qml.  
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4. Create a New Shape File.  

Menu>Layer>Create layer>New Shape File Layer. 
Filename: Select the browser where the file will be saved, and type in a name (for example, 
New Tracts).  
File coding: UTF-8 (UTF-8 requires 8, 16, 24, or 32 bits [one to four octets (bytes)] to encode a 
Unicode character; it is commonly used). 
Geometry type: Drop down and select line; there are other options such as point, polygon, and 
so forth.  
Select coordinate system. 
New Field options: Status. 
Type: Select text data. Click Add to Fields List.  

Next, create another *.shp file with File 
name LFC; File encoding UTF-8; 
Geometry type as polygon; attributes 
identifier (id) as LFC, BioWt, and 
VegType. Click Add to Field List as you 
create each id.  
We created two empty datasets, one a line 
*.shp file and the other a polygon *.shp 
file. 
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4A. Populating the empty line shape file. 

Select the empty shape file layer New Tracts created in step 4. Create a New Shape File. Click the 
pencil icon and vector editing tool. A digitizing tool appears. Zoom into the area of interest and start 
digitizing. When complete, right click to save the attribute information. In the dialogue box that 
appears, type in the identification (id) and status then click OK (screen capture 2). 

1 

2 
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4B. Populating the empty polygon shape file. 

Select the LFC polygon shape file layer created in step 4. Create a New Shape File. Click the 
pencil icon and the polygon editing tool. A digitizing tool appears. Zoom into the area of interest 
and start digitizing. When complete, right click to save the attribute information. In the dialogue 
box, type identification (id) and status; click OK (as shown in screen capture 2 on page 44). 
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  4C. Edit or delete attributes saved.  

Always click the edit toggle icon (yellow pencil) then right click on the *.shp layer open 
attribute table; select the layer you want to delete and drop the selected layer in the trash bin. 
To edit numbers or text, click the item and type the new numbers or text.  

The attributes have been made arbitrarily. LFC percent cover attribute was determined from the 
map. Take an approximate value of the LFC cover using the identity icon. Note that the values 
are from 0 to 255. To obtain 0–100 percent, divide the identity value X/2.55. 

Tip: To delete field 
(column), click on the 
delete field icon. 

4D. Creating a point shape file. 

Create another *.shp file: Menu>Layer>Create Layer>New Shape File Layer.  
File name: Livestock; Geometry type point; attributes identifier (id) as Owner, Cattle, Goats, 
and so forth, and Count; Add each to Field List that was done when creating the vector line and 
polygon *.shp files. Right click the layer. Open attribute table; the screen capture below shows 
the attribute table of the point shape file created.  
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5. Change Attribute Type. 

https://wiki.tuflow.com/index.php?title=QGIS_Change_Attribute_Type 
Review the current field and data types in your table by right clicking on the layer in your 
layers panel and selecting Properties. 
Click the fields panel on the left-hand side of the Layer Properties window. The default 
pBlockage data type generated by TUFLOW is type 'double.' 

To change the datatype, use the refactor field tool located within the QGIS processing toolbox. 
To find the toolbox, click the Processing dropdown menu and select toolbox, as shown below. 

In the Processing toolbox, click Vector Table > Refactor Fields. On the Refactor Fields dialog 
box, set the formats of the field variables, as shown on the screen capture of the Refactor Fields 
dialog box. Click Run; the fields will be formatted according to the format entered. The format 
will not be applied to new fields added to the tables after the Refactor Fields run.  
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6. Working with shape files.  

6A. How to formulate query expressions. 

Select the applicable *.shp file. Open attribute table; click the Expression icon (Ɛ) shown by the red circle 
on screen capture (below, right). In the Expression dialog box shown on the left, expand Field and 
Values. Double click Owner. Next, click Operators in the same panel and click <>. In the next panel, 
select All Unique and then select Kieran. In the attribute table to the right, all owners not Kieran are 
highlighted. For string variables use “Owner” <> ‘Kieran' (note: single and double quotes). Similarly, 
two more expressions are shown in screen captures 2 and 3. Follow instructions shown on 2 and 3.  

"Owner"  <>  'Kieran'  AND   "Sheep"   <=   50 

2 

("Cattle” >= 35 OR "Sheep" >  50) 
AND  "Count"  >= 200 

3 

"Owner"  <>  'Kieran'   

1 
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6B. Sample raster values with selected points.  

Objective: Retrieve LFC at three livestock points. 
On the QGIS menu, click the Feature Selector icon (located by arrow). Select 
single or multiple points. Once livestock points are selected (shown in screen 
capture 1), go to Menu>Processing>Toolbox>Processing Toolbox>Raster 
Analysis>Sample Raster Values. A new layer (Sampled Livestock LFC 2019) is 
created in QGIS Contents Panel. Right click the Sampled Livestock LFC 2019 
layer and open the Sampled Livestock LFC 2019 Attribute Table shown in screen 
capture 2. 

1 

2 
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7. Clip raster, raster calculation classification. 

7A. Clip raster covering the area of interest for queries.  

Menu>Processing>
Toolbox. 
Processing 
Toolbox>GDAL>
Raster extraction> 
Clip raster by 
extent. Follow 
steps shown in the 
screen captures.  
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7B. Convert map range. 

 To convert 0–255 from SNAP to 0–100 for direct interpretation of live vegetation fractional 
cover status and change. 
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7C. Raster calculator, selecting pixels with LFC coverage with user defined range.  

Processing tools>Raster analysis>Raster calculator. 
 

“Clipped (extent) @1”>50 AND “Clipped (extent) 
  The result of the query, areas >50 and <80, are shown in white. 

“Clipped (extent) @1” >=30 AND “Clipped (extent) @1” 
 

The result of the query, areas >=30 and <=50, shown in white. 

“Clipped (extent) @1” >=40 AND “Clipped (extent) @1” 
 The result of the query, areas >=40 and <=50, shown in white. 
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8. Creating buffer zones. 
8A. Buffer zone of Kenya protected areas.  

Example of a buffer using Kenya protected areas 1998. Download from internet 
https://www.wri.org/resources/data-sets/kenya-gis-data; scroll down to Base data and download 
ke_protected-areas.zip; open the *.shp file in QGIS, then click the select feature (shown by red arrow); 
the selected areas are highlighted in yellow in screen capture 1. Next, Menu>Vector>Geoprocessing 
tools >Buffer.   OR  
Menu>Processing>Toolbox>Processing Toolbox>Vector geometry>Buffer.  
Use the parameters in the Buffer dialog box; only a temporary file is created, which can be saved.  
 

1 

Click to save file.   

2 

The buffered areas are shown in rust color in screen capture 3 below. The file was 
opened in QGIS, as specified in the buffer dialog box 2 above.  

3 
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8B. Buffer created on point shape file. 

Following is another example of a buffer created with selected features on the Livestock *.shp file. 
Follow the parameters shown in the buffer dialog box. Save the file (shown by red arrow).  

Livestock 

Opacity tab to set transparency 

Color and opacity can be changed 
by selecting the symbology icon. 

The buffered areas are shown in cyan in the screen capture below. The file was 
opened in QGIS as specified in the buffer dialog box above.  

Click to save file.   
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9. Data export and presentation. 

9A. Export shape file data to Excel.  

Example Livestock: Right click the layer, Open attribute table. Click the upper 
left corner of the identifier (id) column (arrow 1). All fields will get selected; 
click the copy icon (arrow 2).  

1 

2 

Open a blank Excel sheet and paste copied cells; adjust row height then 
save in Excel format.  
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9B. Data export to view in Google Earth Pro. 

Exporting the *shp file data to Keyhole Markup Language *.KML (screen capture 1). Example 
is Livestock shape file. Right click the layer; select Export> Save selected features as. In the 
dialog box Save Vector Layer select Format as KML; navigate to the folder and select file 
name; select the parameters shown in screen capture 2 then click OK.  

Navigate to 
folder and 
name the file. 

2 

As shown in screen capture 3, Open Google Earth Pro; drag and 
drop the *.KML file that was created above.  

3 

1 
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9C. Data presentation. 

To make a map layout, select Menu>Project>new print layout; type name of the layout then click 
OK. 

Right click on 
the map layout 
to get page. 

 

Select what you want to display on the layout in the QGIS project window. Use icon 1 to 
set the map window; icon 2 to resize this area (expand at the arrow) and to move the map 
window, and icon 3 to zoom in and out the map data.  

1429194 

1 

2 
3 
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9D. Add legend, scale, and north arrow. 
To add a legend, click the icon shown by the red rectangle. 
To rename the legend entries, click on the name type in dialog box.  
To remove an entry, unclick the radio button Auto update. Highlight the entry to 
delete and click the minus sign symbol. 

To insert Scale on the map layout, click the scale bar icon shown by the red 
rectangle and position the scale on the map layout.  
To change the style, select desired style from the drop down. Both segments and 
units can be changed. 

Add north arrow and 
company logo. Map 
layout can be exported as 
a *.pdf or an image; go to 
Menu; click Layout and 
select the format for 
export.  
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 10. Calculate distances.  

Go to plugins and search openrouteservice (ORS), then click install. This is a very helpful 
tool but does not currently work with the towns in central Kenya (NRT conservancies) as 
the open street road map available does not have a detailed road map for these areas. 

Get API key from: 
https://openrouteservice.org/sign-up/. 
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