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Digital-Image Processing and Image Analysis of Glacier Ice

by Joan J. Fitzpatrick

Beyond the utility of physical properties measurements to 
the paleoclimate- reconstruction community, the characterization 
of grain growth and recrystallization behaviors can also inform 
ice sheet modeling efforts, because the large-scale deformation 
behavior of an ice body depends on the accommodation of stress 
at the microscopic scale. Careful characterization of the evolu-
tion of grain size and shape distributions and nearest-neighbor 
relations (“texture”), coupled with observation of fabrics and 
microstructures revealed in thin section, provides direct evidence 
of the mechanisms of dynamic recrystallization operating within 
specific depth intervals in the ice body. These mechanisms ulti-
mately control flow-law behavior.

The analysis of thin sections from an ice core proceeds 
in three separate phases: image processing, image analysis, 
and postprocessing (fig. 1). These three phases are described 
in this document, along with specific inputs and outputs. There 
are many intermediate steps in this process, and maintaining 

Abstract
This document provides a methodology for extracting 

grain statistics from 8-bit color and grayscale images of 
thin sections of glacier ice—a subset of physical properties 
measurements typically performed on ice cores. This type of 
analysis is most commonly used to characterize the evolution 
of ice-crystal size, shape, and intercrystalline spatial relations 
within a large body of ice sampled by deep ice-coring projects 
from which paleoclimate records will be developed. However, 
such information is equally useful for investigating the stress 
state and physical responses of ice to stresses within a glacier. 
The methods of analysis presented here go hand-in-hand with 
the analysis of ice fabrics (aggregate crystal orientations) 
and, when combined with fabric analysis, provide a powerful 
method for investigating the dynamic recrystallization and 
deformation behaviors of bodies of ice in motion.

The procedures described in this document compose a 
step-by-step handbook for a specific image acquisition and 
data reduction system built in support of U.S. Geological 
Survey ice analysis projects, but the general methodology 
can be used with any combination of image processing and 
analysis software. The specific approaches in this document 
use the FoveaPro 4 plug-in toolset to Adobe Photoshop 
CS5 Extended but it can be carried out equally well, though 
somewhat less conveniently, with software such as the image 
processing toolbox in MATLAB, Image-Pro Plus, or ImageJ.

1.	 Introduction
The reconstruction of paleoclimate records from ice 

cores requires (1) a multiplicity of chemical, isotopic, and 
electrical measurements which are then related to a depth-
age framework that assumes continuous deposition of snow 
at the glacier surface in the past, and (2) that the geologi-
cal principles of superposition and original horizontality 
apply, unless proven otherwise. The physical properties of 
an ice core can be of great value in evaluation of the “proven 
otherwise” assumption. The scientist who examines the visual 
stratigraphy of an ice core, and thin sections made from it, 
is commonly the first one to detect signs of trouble with this 
assumption. By alerting other scientists working on the same 
core to specific depths at which discontinuities in the depth-
age relation in the core may be present, the physical properties 
specialist can prevent the misinterpretation of artifacts due to 
ice deformation as climate transitions. Figure 1.  Analytical flow chart of the three phases of analysis.
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•  Signal Extraction
 Enhance Contrast
 Find Edges
 Threshold
 Reject unwanted features
 Morphological adjustments
 Correct coarse grain mesh
 Skeletonize and recheck

Image
Processing

•  Generate global measurements
•  Generate master data table
•  Generate statistics

Image
Analysis

Post-
Processing

•  Register data to depth/age relationship
•  Build derivative data tables
•  Generate population statistics
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consistent file structures and file naming conventions is 
imperative. Examples of images are provided for each step in 
the processing and analysis (appendix 1) and of file-naming 
conventions (appendix 2). For the sake of clarity, throughout 
the rest of this document Photoshop CS5 Extended commands 
and menu choices are indicated in blue and FoveaPro com-
mands and menu choices are indicated in red.

2.	 Image Processing

2.1	 Sample Preparation and Digital 
	 Photography of Thin Sections

The starting place for these analyses is the digital image 
of the thin section. A description for preparing these thin 
sections from an ice core is beyond the scope of this document, 
but some special conditions apply to ice thin sections and 
images prepared from them for grain analysis, and these will 
be mentioned here.

To optimize samples for image analysis, use thin sections 
that are thinned to display nothing higher than low second-
order interference colors (fig. 2A). Sections that produce high 
second-order or third-order colors will display geometrically 
complex grain boundaries with multiple birefringence minima 
that can be difficult to interpret (fig. 2B). Bear in mind that 
as work proceeds down the core, it may become necessary to 
adjust the size of the thin section or the sampling interval to 
ensure that a sufficient number of grains is available for the 
analysis to be statistically meaningful.

For high-resolution work, it is usually necessary 
to take multiple frames of an individual thin section and to 
merge the frames into a single image file at the beginning of 
processing. One of the frames must contain the image of a 
ruler or other scale mark to facilitate the direct measurement 
of a scale factor.

Photograph samples in at least two optical orientations 
to avoid ambiguity when grain boundaries in extinct grains 
are located. Multiple images can be superimposed in adjacent 
layers in Photoshop at the beginning of the analysis to 
facilitate comparison of the appearance of individual grains 
under variable extinction conditions.

2.2	 Work Flow—General

Processing the image to prepare it for analysis and post-
analysis proceeds in two steps.

2.2.1	 Intake and Calibration 
These steps assemble the image and provide a spatial 

calibration. They result in a layered composite red-green-blue 
(RGB) image (if the image is a composite of several frames) 
and an optimized, flat RGB image that is spatially calibrated 
both in Photoshop and in FoveaPro.

2.2.2	 Signal Extraction

These steps use image-processing algorithms to separate 
the target spatial features (for example, grain boundaries or 
bubbles) from the rest of the information in the image. In grain 
images, these steps produce two results:

•	 a multilayered red, green, blue (RGB) image (hereafter 
referred to as the “RGB stack”) that contains, at the 
least, the two aligned starting RGB images, the coarse 
grain-boundary mesh, and the final, fine grain-boundary 
(1 pixel) mesh used for analysis; and

•	 a multilayer grayscale image file (hereafter referred to 
as the “edge stack”) containing, at the least, the starting 
principal components analysis forward transform of the 
RGB image, or a similar contrast-maximized treatment 
of the RGB image; the result of the edge-finding 
algorithm; the thresholded edge image; and the final 
coarse and fine edge grain-boundary meshes.

Figure 2.  Two photomicrographs of ice thin sections; cross-
polarized light. A, Thickness optimized for grain analysis at about 
120–140 micrometers. B, Thin section is too thick, making it 
difficult to locate grain boundaries.

A

B
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It is important to develop file-naming conventions (see 
appendix 2 for recommended file-naming conventions) and 
directory structures that are meaningful and that will permit 
the analyst to maintain consistency and to easily navigate 
the many intermediate files and images that will be produced 
during the processing and analysis procedures. At a minimum, 
maintain separate directories for the original image frames and 
composites built from them, for the RGB and grayscale image 
stacks that will be created, and for the analytical results that 
will be generated for each image of each sample.

To create the composite image, choose File>Automate 
>Photomerge from the topmost menu bar in Photoshop, 
select “Collage” and “Blend Images Together” and browse 
to the directory containing all of the frames required for the 
composite image. Load all the required frames into the source 
file frame and select “OK” (fig. 3). You will be able to follow 
the progress of the compositing process in the Layers Panel 
that will open automatically.

•	 Once the composited image has been assembled, save 
it with its layer structure intact (see appendix 2 for file-
naming conventions). You may need to reexamine the 
masking and blending that take place during composit-
ing at a later time.

•	  File output: full-layered composite RGB image

•	 Flatten (reduce to a single layer) the image, rename it, 
and save it as your starting RGB file. (Photoshop layers 
panel controls>flatten)

•	 File output: flattened composite RGB image
Complete these steps for all images of the thin section 

photographed in different optical orientations. Create a new 
RGB file with the flattened images registered to each other, 
each in their own layer. Using Photoshop>File>File Info, enter 
the sample designation and analyst’s name into the “Document 
Title” and “Author” fields. Into the “Keywords” field, enter 
the true depth range, spatial calibration value (see section 
2.2.2), and the numeric range of the individual raw image 
files used to create the photomerged image. If the image being 
processed has been acquired on a vertical sample, indicate 
which direction is stratigraphic “up.” Name and save this file. 
It is the base for the RGB stack file.

Figure 3.  Photoshop CS5 Extended, “Photomerge” options window.

It is also important to use every opportunity to check the 
accuracy of your work. Several procedural checks are built into 
the process described in this document, but analysts should 
exploit every additional opportunity to check the reasonability 
of their results at every step of the analysis.

2.3	 Intake and Calibration

2.3.1	 Compositing Multiple-Frame Images
For an individual thin section, the image of the entire  

section may need to be composited from multiple high- 
resolution frames, at least one of which contains a scale or 
marker in the frame. (A typical 4″×4″ section requires nine 
frames at a scale factor of 800 pixels per centimeter (cm).)  

Create and maintain
a consistent directory hierarchy

and file-naming convention.

Create and maintain
a consistent directory hierarchy

and file-naming convention.
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2.3.2	 Spatial Calibration
In order to convert measurements made on the digital 

image to real-world units, a scale factor must be derived that 
relates a number of pixels in the image to a real-world length. 
The image of the ruler embedded in the digital photo enables 
us to accomplish this.

2.3.2a	 Spatial Calibration in Photoshop

The “Set Measurement Scale” option in Photoshop CS5 
Extended provides a useful utility for performing direct 
on-screen measurements on the fly. Although it’s not necessary 
to perform this calibration (FoveaPro uses only its own 
spatial-calibration file), it provides some useful conveniences 
and a quick cross-check with the spatial calibration provided 
within FoveaPro.

Starting with the image in the RGB stack that shows 
the scale or marker, increase the screen magnification 
to ensure that the image of the scale is large and easy to 
read. From the Photoshop CS5 Extended menu select 
Analysis>Set Measurement Scale>Custom. In the “Options” 
window, set the “Logical Length” value to 1 and the 
“Logical Units” to “cm” and, using the Photoshop ruler 
tool, draw a line 1 cm in length along the image of the ruler 
in the RGB image. Take note of the value that appears in 
the pixel window of the >“Set Measurement Scale” options 
window when you’ve performed this step. This number 
will be used to cross-check the FoveaPro spatial calibration 
result in the next step, and it can be used to have Photoshop 
place a scale marker on the original flat composite image for 
publication purposes.

2.3.2b	 Spatial Calibration in FoveaPro

With the base layer of the RGB stack selected, choose 
Filter>Measure Global>Calibrate Magnification (fig. 4A). 
Note that the FoveaPro filters appear below the Photoshop 
filters in the drop down menu. The FoveaPro calibration 
window will open.

The default starting location of the FoveaPro “Calibrate 
Magnification” window (fig. 4B) is the upper left-hand corner 
of the image. Use the sliders in this window to locate the 
portion of the image containing the ruler. You cannot control 
the magnification of this window. Ensure that the “cm” radio 
button is checked and that a value of 1.0 is entered into the 
“Value” window. Click on a long tick (centimeter mark) on the 
image of the ruler, scroll to a ruler tick 1 cm away, and place 
the second mark. These two marks will cause the pixel value 
under the image of the ruler to update to the number of pixels 
between your two marks. If the values determined in both 
Photoshop and FoveaPro are within 0.5 percent of each other, 
select the “Save As” button from this window and name the 
file using the appropriate name convention. If the two values 
differ by more than 0.5 percent, perform the calibration opera-
tions again until the two values agree to within this tolerance.

As you navigate through the course of the image 
processing and analysis, be mindful of ensuring that your 
spatial calibration applies to the image you are working on. 
Both Photoshop and FoveaPro retain the last-used value. If 
you are returning to an image after working on another that 
you calibrated more recently, you will need to read in the 
correct calibration file for the image you are currently working 
on (“Import” button in fig. 4B).

Figure 4.  FoveaPro, spatial calibration selection (A) and 
calibration (B) windows. When two end points are identified in the 
calibration window, the calibration value (red ellipse) will update.

BA



2.  Image Processing    5

2.4	 Signal Extraction

This section describes the steps taken to separate the  
features in the image you want to analyze (signal) from every-
thing else (background).

The image of a thin section is an irregular tessellation. 
The goal of this phase of the processing is to identify and 
separate a continuous, closed line (mesh) that represents the loca-
tion of grain boundaries in the image (fig. 5). In order to do this, 
we exploit the color or contrast changes at the grain boundaries.

There are many ways to accomplish each step in this 
process. Depending on the characteristics of the starting image, 
some contrast-enhancement and edge-finding algorithms 
may prove to be more successful than others. The algorithms 
suggested here have proven to be successful in most instances.

The image processing steps needed to accomplish the 
isolation of the grain boundaries typically take the following 
operations in order:
1.	 Remap the image to its best possible contrast

2.	 Locate the edges

3.	 Threshold (reduce from grayscale to black and white) 
the edge file

4.	 Reject unwanted features (such as bubbles), clean up 
the edges

5.	 Use morphological operators to improve the continuity 
of the edge mesh

6.	 Superimpose the edge mesh back onto the RGB image 
in the RGB stack file, check it and, if needed, correct it

7.	 Skeletonize the corrected mesh.
The black and white, skeletonized (reduced to 1-pixel width) 

edge mesh resulting from the last step (7) is the input into the 
analytical routines used in the next phase. A visual walk through 
of each of these steps is provided in appendix 1 of this document.

Staying organized: To keep track of how you perform 
the steps in this phase, create a new layer in the edge stack for 
each processing step and name the layer with the algorithm 
used. For example, if you located edges by using the Photoshop 
“Find Edges” function on the RGB image, name the output 
layer “Photoshop RGB edges.” When you’re ready to move to 
the next image-processing step, duplicate the layer you will use 
as input and use the next operator on the duplicate layer, then 
rename it. In a typical analytical sequence in an edge stack file 
(fig. 6), each layer resulted from an image-processing operation 
on the layer below it.

2.4.1	 Remap the Image

The purpose of this step is to provide the best possible 
input for the edge-finding algorithm that will be used in the 
next step. To do this we remap the starting RGB image using 
principal components analysis.

•	 Open the RGB stack file you created earlier 
(section 2.2.2). If you have more than one image of 
your sample thin section recorded in multiple orienta-
tions, ensure that they are loaded into the RGB stack 
as unique layers that are aligned with each other. A 
typical RGB stack file will have two stacked images 
at this point.

•	 Choose the stacked RGB image with the best color 
contrast and duplicate it into a new layer. Name the 
new layer “principal component analysis result.”

•	 With this new layer selected, choose Filter 
>IP•Multichannel>Compute principal components 
analysis (PCA) transform; a pop-up window will display 
the covariance matrix resulting from the computation of 
the eigenmatrix. Most of the significance will reside in 

Figure 5.  Starting and ending points for image-processing  
phase of grain analysis. A, Starting RGB (red-green-blue) digital 
image; B, Final grain-boundary map derived from processing of 
the RGB image.

A

B

Be mindful that you are using the correct
spatial calibration value as you move

between files. FoveaPro retains the last used
value. If you change the inherent resolution of the 

image, you will need to recalibrate.

Be mindful that you are using the correct
spatial calibration value as you move

between files. FoveaPro retains the last used
value. If you change the inherent resolution of the 

image, you will need to recalibrate.
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one row (fig. 7). If it does not, then a different approach 
may be required. For example, the starting image can 
be remapped into a different color space or this step can 
be omitted completely and the built-in Photoshop RGB 
edge-finding algorithm can be attempted directly on the 
RGB image (Photoshop>Filter>Stylize>Find Edges).

•	 The next FoveaPro pop-up window will give you the 
opportunity to name and save the eigenmatrix file. 
Don’t change the extension when you select a name, 
and save it to a location where you can easily find it—
the next step is going to ask you to point to it.

•	 Select Filter>IP•Multichannel>Apply PCA (forward). 
Point to the eigenmatrix file created in the previous 
step when queried. This step remaps the image using 
the transformation eigenmatrix. The remapped image 
with the largest dynamic contrast is mapped into the 
first (“red”) channel in this image.

•	 With only the “PCA result” layer selected, switch to the 
“Channels” tab in Photoshop. Select the “red” channel 
only, copy it to the clipboard, and create a new file in 
Photoshop with this layer (Photoshop> File>New). Be 
sure to set the color space to grayscale. Photoshop will 
automatically size the new file to match the clipboard 
contents. The file you have just created will become your 
edge-stack file. Save and name it. The resulting image is 
the starting point for the edge-finding algorithm (fig. 8).

Figure 7.  Typical covariance matrix for the principal-component-
analysis transform process. Most of the significance should reside 
in one row (red ellipse).

Figure 8.  Progression of image transformations used to enhance 
edges in preparation for applying an edge-finding algorithm. 
A, Original red-green-blue image. B, Image after principal-component-
analysis forward operation. C, Extraction from B of channel with the 
most comprehensive number of grayscale values. C represents the 
best possible contrast that can be achieved from the original image.

Figure 6.  Layer-naming conventions for a 
typical edge stack. Each layer is the result of 
an image-processing operation on the layer 
below it.

Eigenvalues and eigenvectors for color channels

Significance Red Green Blue

65.4618% 0.67948 0.73106 –0.06211
29.0070% –0.02635 0.10892 0.99370
5.53125% 0.73322 –0.67357 0.09327

B

C

A
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This process can be repeated for each individual RGB 
image that has been recorded, and the result of the edge-
finding algorithms can be Boolean added together at the end 
of the image-processing phase of analysis.

2.4.2	 Locate the Grain Boundaries

•	 Duplicate the principal component analysis result 
into a new layer above the original (Layer panel 
controls>duplicate layer)

•	 With the new layer selected, apply Filter>IP•Process 
>Find Edges. This step will open a FoveaPro pop-up 
preview window that offers a selection of edge-finding 
algorithms of which Sobel, Kirsch, and Gradient 
Vector are probably the most useful. The window 
sliders and magnification controls can be used to 
move around inside the preview window to provide 
the analyst with an overview of how successful each 
algorithm is at producing the most complete grain 
boundary image with the least extraneous information. 
When the best operator is identified, apply it and 
rename the layer with the name of the operator used.

the method or value that retains as much of the grain 
boundary as possible without retaining extraneous 
detail. A threshold value of 225 to 230 is usually 
successful. When you have chosen, select “OK” and 
rename the layer (in the layers panel) with the name 
of the chosen method or threshold value. (For example, 
in fig. 6, the Kittler algorithm was used to create the 
thresholded image that resides in the third layer above 
the Forward PCA base image.) This layer is the starting 
point for the image of the grain boundaries.

2.4.4	 Reject Unwanted Features  
	 and Clean Up Edges

This step improves the appearance of the grain boundaries 
and allows you to discriminate out unwanted features

•	 Duplicate the thresholded image into a new layer and 
rename it.

•	 Using Filter>IP•Measure Features>Reject Features, 
reject small unwanted features. Set a value starting at 
about 1,000 pixels to begin with and ensure that the 
foreground color in Photoshop is black. You may need 
to perform this step in subareas if your image is large. 
If needed, use the Photoshop rectangular marquee tool 
to select subareas and perform this clean up stepwise.

•	 Using the Photoshop tools, open (paint over with white) 
the outer edge of the grain-boundary mesh. You will not 
count grains that touch the edge of the thin section.

2.4.5	 Improve Continuity of the Grain- 
	 Boundary Mesh

Depending on the quality of the grain boundary mesh at 
this point, you may or may not need to improve its continuity 
by using these operators.

•	 Duplicate the cleaned up image into a new layer and 
rename it.

•	 Dilate the mesh using the FoveaPro morphological 
operators (Filter>IP•Morphology>Classic or EDM 
Morphology), so that it becomes contiguous every-
where but at its edges (dilate to 11 or 12). Check the 
mesh against the principal component analysis image 
at the bottom of the stack for any gross discrepancies.

•	 Invoke Filter>IP•Morphology> Skeletonize. Follow 
this with Filter>IP•Morphology>EDM Morphology 
and dilate the image to produce a clean, contiguous 
mesh (dilate to 6.50). This mesh is the starting coarse 
grain-boundary mesh. Name this layer “Starting 
Coarse Mesh.”

2.4.3	 Threshold (Binarize) the Grain- 
	 Boundary Edge Image

This step creates a binary (black and white) rendering 
of the edge image in the active layer.

•	 Duplicate the “Find Edges” result and create a new 
layer with it (layer panel controls>duplicate layer)

•	 With the new layer selected, apply Filter>IP•Threshold 
>Bilevel Thresholding. A pop-up window with the 
bilevel-threshholding controls will open. You are given 
several options for setting a grayscale threshold point 
(value). Assuming that you are working with a white 
(255) background, every point in the image whose 
value is greater than the threshold value will be set to 
255 (white). Every point below the selected threshold 
value is set to 0 (black). The preview window high-
lights features in the image that will be set to black 
in the chosen highlight color (default is red). Select 



8    Digital-Image Processing and Image Analysis of Glacier Ice

2.4.6	 Check and Correct the Coarse  
	 Grain-Boundary Mesh

In this step you will superimpose the edge mesh back 
onto the RGB image in the RGB stack file and, if needed, 
correct it. Starting with this step, you will be moving between 
the edge-stack file and the RGB-stack file, so have both stacks 
open in Photoshop.

•	 Working in the starting coarse grain-boundary layer in 
the edge stack, use the selection tool in Photoshop with 
the color tolerance set to 1 and select an area in the 
background (white).

•	 Invoke Photoshop>Select>Inverse and copy this 
selection to the clipboard.

•	 Paste the coarse grain-boundary mesh from the clip-
board into a new layer at the top the RGB stack. With 
the grain-boundary mesh still selected, remap the 
color to a bright orange or yellow by selecting a bright 
color from the Photoshop color palette and selecting 
Edit>Fill>Foreground color

•	 Working in the RGB stack, turn off any layers between 
the coarse grain-boundary layer you just created and 
the base RGB image from which you created the 
principal component analysis. If you need to reposition 
the mesh to coincide with this bottom-most layer, do so 
by selecting the layer and using the Photoshop Move 
Tool (not the hand tool, which will move the entire 
stack and not just the layer).

•	 Lock the base RGB image layer and verify that you’re 
working in the coarse grain-boundary mesh layer. 
Inspect the mesh for errors and correct them using 
the Photoshop “Erase” and “Pencil” tools (width of 
about 6 pixels). If you are unsure of a particular grain-
boundary location, try turning on the visibility of the 
other RGB image at the base of the stack. Boundaries 
that are obscure in one view may be obvious in the 
other view. This inspection is the most time-consuming 
part of the image processing, but it provides the analyst 
with an excellent opportunity to scrutinize the image 
carefully and to record any observations in a new 
“comments” layer at the top of the RGB stack. Circles 
around unusual or uninterpretable features in the RGB 
image, text comments, or arrows pointing to good 
examples of phenomena of interest are all candidates 
for the “comments” layer.

•	 Erase the margins of the mesh back to the first 
complete grain all the way around the edges of the 
mesh image. When you’re satisfied with the result, 
copy and paste this final coarse mesh into a new layer 
at the top of the edge-stack file and name the layer 
“Final Coarse Mesh.” If necessary, reposition it to 
coincide with the starting coarse mesh layer below it.

•	 In order to continue with the next steps in the analysis, 
the background of the final coarse mesh layer needs 
to be reset to white (at this point it is transparent). Do 
this by creating a new layer just below the final coarse 
mesh layer and setting the fill color to white. Then 
merge the two layers. Fill the background of the “Final 
Coarse Mesh” layer with white and rethreshold it to 
ensure that the only color values in this layer are black 
and white. The correct final configuration will show 
only a black edited grain boundary (the mesh) and a 
white background.

2.4.7	 Skeletonize the Corrected  
	 Grain-Boundary Mesh

•	 Duplicate the “Final Coarse Mesh” layer into a new 
layer above.

•	 With this new layer selected, invoke Filter>IP• 
Morphology>Pruned skeleton followed by Filter 
>IP•Morphology>Thicken skeleton and rethreshold  
the image, accepting everything that is not white (first 
make sure the foreground color in Photoshop is black 
and the background color is white!). These operations 
will reduce the coarse mesh to 1-pixel width, trim off 
most dangling pixels, and ensure that all pixels in the 
resulting mesh are 4-connected (share at least one edge 
with another signal pixel).

•	 As a final step, ensure in this final fine-mesh image  
that there are no stray pixels or open endpoints. This 
final check is best done at a magnification factor of 
200 in Photoshop. In addition, make sure the back-
ground continues all the way to the edge of the canvas.

•	 Invert the final fine mesh layer so that the grain  
boundary is white and the background is black.

•	 To complete your RGB stack, copy and paste this final 
fine mesh back into a new layer at the top of the RGB 
stack. You may need to position it into coincidence 
above the coarse mesh image. Save and close the 
RGB stack. This step completes the image-processing 
portion of the analysis.

3.	 Image Analysis
In this phase of the process, numerical data are generated 

from the fine mesh grain-boundary image. Two families of 
measurements are compiled: global measurements that pertain 
to the image in its entirety, and discrete measurements that are 
generated for each grain.

FoveaPro algorithms assume a value of 0 (black) for 
signal and 255 (white) for nonsignal. In this scheme, grain 
areas must be black and grain boundaries must be white. 
Invert the mesh image if necessary to achieve this relation. 
(Image>Adjustments>Invert), and ensure that your Photoshop 
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foreground color is black and background is white. Set up a 
log file using Filter>IP•Utilities>Setup Log File. This file will 
capture the output of the analytic routines.

3.1	 Global Measurements

Record these measurements for each analysis either 
through the FoveaPro log file or screen captures.

3.1.1	 Mean Planimetric Grain Area
Determine the mean planimetric grain area by dividing 

the total sample area by the number of grains. This value 
provides a double check on statistics generated from the grain-
specific measurements.

•	 Ensure that the spatial calibration in Photoshop is correct.
•	 Select the Photoshop magic wand tool, set the color 

tolerance to 1, and check the “Contiguous” checkbox 
in the brush controls panel. Ensure that the Photoshop 
foreground color is set to black.

•	 Select a spot on the image between the outer edge of 
the grain-boundary mesh and the outside edge of the 
image. If the spot is selected correctly, dotted region 

boundaries will appear along the outer perimeter of 
the image area and along the outer edge of the sample 
(fig. 9).

•	 Invert the selection (Select>Inverse). If the inversion is 
correct, the dotted boundary around the outer edge of 
the image will disappear.

•	 On the Photoshop menu bar choose Analysis>Record 
Measurements. A window will open along the bottom 
of the screen with one or more measurements in it. 
Verify that the scale factor is correct and record the 
“Area” entry. The units should be square centimeters 
(cm2). Check that the number is the correct order of 
magnitude for the approximate sample area. (This is a 
common-sense check.)

•	 As a quick check on the integrity of the final fine mesh 
file, invoke Filter>IP Measure Features>Count. This final 
screen will return a value for the number of grains (n) in 
the image that is one greater than the correct value.

•	 Record the Photoshop scale factor, uncorrected count, 
and sample area.

•	 Divide the sample area by n-1. Record this value as the 
planimetric mean grain area.

Figure 9.  Determining mean planimetric grain size by finding total grain area and dividing by the number of grains. 
A, Selection of image area outside of the grain. B, Inversion to select only the area occupied by grains. The dotted 
line around the perimeter of the image will disappear when the selection is inverted.

A B

Sample
border

remains

Image
border

disappears
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3.1.2	 Distribution Plots

As a first cut, some of the display tools in FoveaPro can 
be used to plot distributions and relations (such as grain area, 
aspect ratio, or moment angle). A few suggestions are given 
below. Note that generating these plots in FoveaPro is time-
consuming because this program recalculates all the needed 
values from the image.

•	 Select Filter>IP•Measure Features>Plot (Distribution) 
and select any parameter for which you would like to 
see a histogram distribution of up to 30 bins. The win-
dow that displays the histogram also provides the statis-
tics. You can save the bin data and the image to the log 
file. Typically, a user saves distribution plots for area, 
elongation, equivalent diameter, and moment angle. 
These routines will also return values for n, the num-
ber of grains in the measurement. Check the value of n 
generated using the FoveaPro count command described 
in the second paragraph above against the total number 
of grains displayed at the top of the distribution plot (fig. 
10). They should be the same.

3.1.3	 Scatter Plots
•	 Select Filters>IP•Measure Features>Plot (Scatter) 

and select x and y values for a simple scatter plot.  
Save scatter plots for area compared with elongation 
and moment angle compared with area (fig. 11).

3.1.4	 Cluster Analysis

•	 Other available operators of interest include Filter 
>IP•Measure Global>Clustering, which performs 
a nearest-neighbor distance analysis and compares 
the values to a random distribution. This option also 
creates a rose plot (fig. 12).

3.2	 Grain-Specific Measurements

The final step of the image analysis phase is the 
generation of the master data table, which calculates a suite 
of parameters for every grain in the image. Each grain is 
assigned a unique number during this step; for identification 
purposes these numbers can be plotted onto the final fine 
grain-boundary mesh image at the top of the edge stack.

3.2.1	 Generate the Master Data Table

•	 Ensure that Photoshop’s foreground color is set to black.

•	 With the final fine grain-boundary mesh layer 
selected in the edge stack, invoke Filter>IP•Measure 
Features>Measure All Features. Select “Create New 
File” and name the output file with the core and sample 
designation leaving the “Feature Data” portion of the 
filename intact (see “File Naming Conventions” in 

Figure 10.  A FoveaPro distribution diagram based on equivalent diameter. The total 
number of grains counted by this algorithm (red circle in figure) should be 1 less than 
the number detected by the global “count” command. The nature of the population will 
be apparent from these types of plots.
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Figure 11.  FoveaPro scatter diagram of points. Elongation on the x-axis 
is compared with area on the y-axis; a linear fit to the data is superimposed.

Figure 12.  FoveaPro cluster-analysis plot. This type of diagram 
gives a quick impression of grain elongation and alignment.

appendix 2.) These steps invoke the primary set of 
FoveaPro measurement algorithms and will produce a 
large, space-delimited plain-text data table that provides 
information for more than 40 parameters for each grain. 
If you have a large number of grains in the image (more 
than 1,000) it is likely to take some time to execute. 
Save the output file and then import it into Excel and 
save it. For a description of how these parameters are 
computed, please refer to Russ (2011a).

•	 The Measure All Features filter generates data table 
entries that are not used for further analysis. Delete these 
columns from your formatted Excel data sheet before 
continuing with the further analysis. These columns are
•	 O	 Num_Holes
•	 V	 Hole_Fraction
•	 Z	 Skel.End_Points through AQ Integ.Optic. 

	 Dens. BB Min.Separation_Dist through BE 
	 Adjusted_Count
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3.2.2	 Statistical Measurements
Full statistics can now be generated on the grain population 

for each of the measured parameters. In a Windows environment, 
the required statistical routines can be accessed directly from 
Excel. In the Mac OS environment, these routines are an add-on 
to Excel (StatPlus:Mac) that must be downloaded and installed. 
Instructions given here refer to the Mac OS environment.

•	 With the Excel data spreadsheet open, launch StatPlus.
•	 Select Statistics>Basic Statistics and Tables >Descriptive 

Statistics. When queried for the columns for which the 
statistics will be computed, select all data columns in the 
Excel spreadsheet except the first one (which contains the 
grain identification numbers). Select “Advanced Options” 
from the Descriptive Statistics window and check the 
“Plot histogram” and “Overlay histogram” boxes; then 
enter 100 in the box opposite “Number of intervals” 
(fig. 13).

•	 After the stat file completes execution, save it and 
name it with the core and sample identification number 
and the word “stats” just ahead of the .xlxs extension.

•	 Check the first entry for “Count” under the “Area” 
parameter located in cell B3. The value displayed here 
will be 1 less than the value for the number of grains you 
retrieved from Measure Features>Count in section 3.1.1. If 
this is not the case, then an undiagnosed problem remains 
in the fine mesh and you need to go back and correct it. 
(For instance, if the statistical count is higher than the 
correct value, stray single pixels probably exist in the fine 
mesh image; if the value is lower than the correct value, 
then an open edge probably lies somewhere in the image.)

•	 After verifying that the feature count is correct, 
retrieve the mean and median values for area, equiva-
lent diameter, aspect ratio and form factor from the 
stats file and record them in a data table to facilitate 
post-processing analysis.

4.	 Postprocessing
Once the grain-level data tables have been acquired and 

the descriptive statistics have been generated for all samples, 
the postprocessing phase of the analysis can be carried out. 
This is the phase that uses the results of the analyses to address 
scientific questions, and it is typically initiated by plotting and 
examining the behavior of specific parameters as a function of 
depth or age and temperature within the ice body and comparing 
the results with those from other sites and with other data sets 
from the same site. Some behaviors are expected and can be 
observed in most deep ice cores; some observations may be 
unique to the site. It is important to remember that, unlike deep 
sea-sediment cores which number in the thousands, relatively 
few deep ice cores have ever been retrieved, so the basis for 
comparison from site to site is limited. Several examples are 
provided here to show how the data generated from the digital 
imagery of an ice core can be used to investigate the textural, 
stratigraphic, and structural characteristics of an ice sheet.

4.1	 Example 1.  Mean Grain Size  
	 as a General Guide

Although the mean grain size is not particularly informa-
tive in anything other than a general sense (grain-size distribu-
tions are typically log normal, not Gaussian), examination of 
mean grain area as a function of depth or age can be used to 
quickly identify important changes in chemistry, particulate 
loading, and ice temperature. Grain size changes can result from 
the deposition of aerosols from nearby minor volcanic eruptions 
or distant major eruptions; increased dust deposition associated 
with glacial periods (resulting from increased availability and 
atmospheric transport during glacial intervals); and increasingly 
warm temperature in samples that are increasingly close to 
the bed of the glacier. Because the majority of early published 
literature also typically characterized grain-size behavior by 
mean grain area, mean intercept length, or mean grain diameter, 
comparison with these earlier works requires the continued use 
of mean grain size.

Mean grain areas of the West Antarctic Ice Sheet Divide 
(Antarctica) deep ice core (WDC 06A) between 120 and 
3,400 meters (m) were determined on a 20-m sampling interval 
(fig. 14). Although the pronounced ‘M’ shape to the curve above 
2,500 m depth is unique to this core, these data have several 
features in common with cores from other sites. The steep 
increase in mean grain area with depth from the shallowest 
sample to about 500 m is typical of the “normal grain growth” 
regime observed in many ice sheets, as are the general grain size 
depression during and around the Last Glacial Maximum and 
the extreme coarsening as the temperature of the ice approaches 
its pressure melting point near the bed. The abrupt, narrow drop 
in mean grain size at the Antarctic Cold Reversal (the depth of 
which has been verified by stable isotope analysis) has been 
observed in other Antarctic cores as well.

The depth and age of these types of transitions in grain 
size should correlate with other measurements that are made 
on the core, such as chemistry, particle count, electrical 
properties, and possibly stable isotopes.

4.2	 Example 2.  Population Statistics  
	 and Distributions

Characterization of population distributions is more 
informative than examination of the simple mean, which can 
be strongly influenced by the presence of a few large grains. 
Grain populations can be compared on the basis of actual 
measured sizes, or the populations can be normalized to 
their mean or mode for comparison. Segregation of specific 
populations (such as the largest 5 percent of grains in a 
sample) is another way to investigate the effects of grain 
growth and recrystallization.

A quantile-quantile comparison was compiled of 
three samples from before, within, and after the Antarctic 
Cold Reversal (ACR) at West Antarctic Ice Sheet Divide 
as identified from the stable isotope record (fig. 15). The 
comparison shows that the difference in mean grain size 



4.  Postprocessing    13

Figure 13.  StatPlus, “Descriptive Statistics” window.

Figure 14.  Mean grain radius as a function of depth in the West Antarctic Ice Sheet Project main 
core (WDC 06A). Core-sample interval, 20 meters. Features of this dataset that are similar to those in 
other Antarctic cores include the following: steep initial curve marking grain growth in the “normal” 
grain-growth regime); a narrow minimum at the Antarctic Cold Reversal (about 2,100 meters depth); 
a region of depressed grain size during and around the time of the Last Glacial Maximum; and 
extreme grain coarsening in the warm-temperature regime at the bottom of the ice sheet, where the 
in-place temperature is warmer than –10°C.
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Figure 15.  Three grain-area populations from the West Antarctic 
Ice Sheet Divide core before, during, and after the Antarctic Cold 
Reversal (ACR). Values on x-axis derived from samples that originated 
during the Antarctic Cold Reversal. Values on y-axis represent the 
difference in grain sizes in each 1 percent quantile between ice from 
the ACR (depth 2,040 to 2,180 meters) and ice either older than the 
ACR (depth 2,200 to 2,240 meters) or younger than the ACR (depth 
1,980 to 2,020 meters). The entire population distribution was nearly 
identical just before and during the ACR. Mean grain size increased 
in younger ice; this increase is attributable to the largest 15 percent 
of grains in that ice. This relation suggests a growth-limiting factor in 
ACR and older ice that is absent in younger ice.

Figure 16.  Rates of recrystallization in a “normal” grain-growth regime from 14 ice-core sites in 
Antarctica and Greenland. The growth rate at West Antarctic Ice Sheet Divide is commensurate with 
previous observations, and it falls near the fitted curve that expresses the temperature dependence 
of growth rate in the uppermost portions of an ice sheet. (Modified from Cuffey and Paterson, 2010.)

between within-ACR and after-ACR samples that is seen in 
figure 14 originates primarily from the coarsest 15 percent 
of the grain population in the after-ACR sample; the remain-
ing 85 percent of the grain population smaller than this 
coarsest part is very similar in size distribution. The entire 
populations of the before-ACR and within-ACR sample are 
essentially identical. A probable explanation resides in the 
dust record, which uses cerium as a continental-dust proxy 
(J.R. McConnell, pers. commun., 2013). The dust record, in 
combination with the isotopic record, indicates that although 

the temperature was warmer in the time immediately before 
the ACR, dust concentrations were still higher than after the 
ACR and that this higher dust concentration is the likely factor 
that limited grain growth before ACR time.

4.3	 Example 3.  Ice Behavior Compared

It is useful to compare the grain characteristics among 
ice cores from different sites in order to separate behaviors that 
are common to all ice sheets from those that may be unique 
to the ice dynamics at a particular site. For example, rates of 
grain growth in the “normal” grain growth regime from several 
ice core sites in Antarctica and Greenland are compared in 
figure 16. The newly measured growth rate at West Antarctic 
Ice Sheet Divide (red triangle in fig. 16) is commensurate with 
previous observations and falls near the fitted curve expressing 
the temperature dependence of this growth rate in the uppermost 
portions of an ice sheet. (Other data compiled by Cuffey and 
Patterson, 2010.)
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5.	 Summary

Image processing and analysis are powerful tools for 
extracting quantitative information from digitally stored images. 
This report provides step-by-step guidance for manipulating 
digital images of a specific substance, glacier ice, with applica-
tions in the fields of glaciology and paleoclimatology. In the 
broader field of image interpretation, these types of techniques 
can be used in applications as diverse as metallurgy, forensics, 
and quality control in manufacturing. 

As with any set of tools, there are many ways to 
accomplish the same task. The instructions given here have 
proven to be generally successful for the task of extracting 
size, shape, and texture information from samples of glacier 
ice, but in specific instances, different approaches may 
sometimes prove to be more successful. As an analyst gains 
experience with the processing and analysis algorithms used 
here, other choices should be explored to gain familiarity with 
other algorithms and their potential applicability to a broader 
range of image types.

Two cautionary notes: first, it is imperative that the 
analyst always understands the nature of each image-processing 
operator and each analytical algorithm used at the array or 
matrix level and not only at the image level. Using an operator 
or algorithm that is poorly understood at the computational 
level can lead to inappropriate applications of such operators 
or algorithms. So doing may yield undetected incorrect results. 

Finally, always document each step in the processing and analy-
sis procedures. This practice serves several purposes—it allows 
the analyst to recreate an analytical pathway long after the recol-
lection of how a particular image was treated has faded and, 
most important, it provides a chain of analytical integrity that is 
necessary for robust scientific research. In short—always know 
what you are doing and always document what you have done.
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Appendix 1.  Image-Processing Walk Through

Original Red-Green-Blue (RGB) image Most significant channel of the Principal Components Analysis (PCA)

Most significant channel of the Principal Components Analysis (PCA) 3d order gradient edges

3d order gradient vector edges Shannon threshold

Shannon threshold Reject features

1. Remap the image to achieve the best possible contrast

2.  Locate the edges

3.  Binarize (threshold) the edge file

4.  Reject unwanted features, clean up edges
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Reject unwanted features Euclidean Distance Mapping (EDM) morphological operators produce the 
starting coarse edge mesh.

Starting coarse edge mesh Superimposed coarse edge mesh

Edited coarse edge mesh

Extracted, edited coarse edge mesh Skeletonized, thickened, inverted fine edge mesh ready for analysis

6.  Superimpose the coarse edge mesh back onto the RGB image and check/correct it.

7.  Skeletonize and thicken the corrected edge mesh

5.  Use morphological operators to improve the continuity of the edge mesh
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Appendix 2.  File Naming Conventions

File naming conventions—in order of creation during analysis
File Type Syntax Example

Fully layered RGB composite of a sample 
photographed in cross-polarized light in 
the 0° orientation

<core identifier><sample identifier> 0°L.psd WDC 06A 320 VTS 
0°L.psd

Flattened RGB composite of a sample 
photographed in cross-polarized light 
in the 0° orientation

<core identifier> <sample identifier>0°F.psd WDC 06A 320 VTS 
0°F.psd

Fully layered RGB composite of a sample 
photographed in cross-polarized light in 
the 45° orientation

<core identifier><sample identifier>45°L.psd WDC 06A 320 VTS 
45°L.psd

Flattened RGB composite of a sample 
photographed in cross-polarized light 
in the 45° orientation

<core identifier><sample identifier>45°F.psd WDC 06A 320 VTS 
45°F.psd

FoveaPro spatial calibration file <sample identifier> calib. (no extension) 1025 VTS calib.
RGB analytical stack <core identifier><sample identifier>RGB stack.psd WDC 06A 1025 VTS 

RGB stack.psd
FoveaPro PCA eigenmatrix file <sample identifier>transform.pca 1025 VTS transform.pca
Grayscale edge analytical stack <core identifier><sample identifier> edge stack.psd WDC 06A 1025 VTS 

edge stack.psd
FoveaPro feature data table <core identifier><sample identifier> Feature Data.txt WDC 06A 2240 VTS 

FeatureData.txt
Excel feature data table <core identifier><sample identifier> FeatureData.xlxs WDC 06A 2240 VTS 

FeatureData.xlxs
StatPlus statistics data table <core identifier><sample identifier> stats.xlxs WDC 06A 2440 VTS 

stats.xlxs
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